Project

General

Profile

action #60041

[functional][u] test fails in system_role - Adaptions needed for Full (no network, no registration) and Online installer

Added by dheidler almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
High
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 28
Start date:
2019-11-19
Due date:
% Done:

0%

Estimated time:
42.00 h
Difficulty:

Description

Observation

No modules are selected by default. The bug is already reported (https://bugzilla.suse.com/show_bug.cgi?id=1156869) and needs a workaround.
At the moment, the information about which modules may be selected comes from SCC, and only possible with the Online installer

Notice: Yast team acknowledges this as an expected behavior and they select the needed modules, not as a workaround.

openQA test in scenario sle-15-SP2-Full-x86_64-create_hdd_gnome@64bit fails in
system_role

Acceptance criteria

  • AC: tests are adapted for the new Full installer.

Reproducible

Fails since Full installer was added Build 89.1

Expected result

Last good: YAST:sle-15-SP2-Full-x86_64-Build89.1-skip_registration@64bit

Further details


Related issues

Related to openQA Tests - action #60230: [functional][y] test fails in system_roleResolved2019-11-25

History

#1 Updated by SLindoMansilla almost 2 years ago

  • Description updated (diff)

#2 Updated by SLindoMansilla almost 2 years ago

  • Subject changed from test fails in system_role: no modules preselected - workaround needed to [functional][u] test fails in system_role: no modules preselected - workaround needed
  • Description updated (diff)
  • Status changed from New to Workable
  • Target version set to Milestone 28

#3 Updated by SLindoMansilla almost 2 years ago

  • Assignee set to SLindoMansilla

Taking this as it is blocking our openQA test results

#4 Updated by SLindoMansilla almost 2 years ago

Investigating if it can be solved by using setting ADDONS=all-packages
https://openqa.suse.de/tests/3616531

#5 Updated by SLindoMansilla almost 2 years ago

  • Subject changed from [functional][u] test fails in system_role: no modules preselected - workaround needed to [functional][u] test fails in system_role - Adaptions needed for Full (no network, no registration) installer
  • Description updated (diff)

It works. So, I added the setting ADDONS=all-packages to the four mediums https://openqa.suse.de/admin/products:

  • sle 15-SP2 Full x86_64
  • sle 15-SP2 Full s390x
  • sle 15-SP2 Full ppc64le
  • sle 15-SP2 Full aarch64

I do not consider worth the effort to record a soft-fail. I consider this like a missing feature.

But, this needs a workaround: https://openqa.suse.de/tests/3616531#step/addon_products_sle/25
I going to reused this same ticket.

#6 Updated by SLindoMansilla almost 2 years ago

  • Description updated (diff)

#7 Updated by SLindoMansilla almost 2 years ago

  • Description updated (diff)

#9 Updated by SLindoMansilla almost 2 years ago

  • Status changed from Workable to In Progress

#11 Updated by SLindoMansilla almost 2 years ago

confirmed that no modules should be preselected for the Full media: https://bugzilla.suse.com/show_bug.cgi?id=1156869#c3

#12 Updated by SLindoMansilla almost 2 years ago

#13 Updated by SLindoMansilla almost 2 years ago

New needles for system role, addon_products_sle, etc:

  • system_role-system-role-default-system-sled-20191125
  • system_role-system-role-default-system-textmode-20191125
  • system_role-system-role-default-system-textmode-kvm-20191125
  • system_role-system-role-default-system-textmode-spvm-20191125
  • system_role-system-role-xen-20191126
  • system_role-system-role-xen-selected-20191126
  • system_role-system-role-xen-focused-20191127
  • system_role-system-role-xen-selected-videomode-text-20191127
  • system_role-system-role-kvm-focused-ncurses-20191127
  • system_role-system-role-kvm-selected-ncurses-20191127
  • before-select-product-bcl-20191127
  • select-product-bcl-masked_version-20191127
  • https://gitlab.suse.de/openqa/os-autoinst-needles-sles/merge_requests/1258

#14 Updated by SLindoMansilla almost 2 years ago

  • Subject changed from [functional][u] test fails in system_role - Adaptions needed for Full (no network, no registration) installer to [functional][u] test fails in system_role - Adaptions needed for Full (no network, no registration) and Online installer

#15 Updated by SLindoMansilla almost 2 years ago

  • Related to action #60230: [functional][y] test fails in system_role added

#18 Updated by SLindoMansilla almost 2 years ago

From https://progress.opensuse.org/issues/60041#note-5

Registration is now expected on Full media, removed setting ADDONS from media https://openqa.suse.de/admin/products as verified in http://openqa.slindomansilla-vm.qa.suse.de/tests/2038

Also available in: Atom PDF