Project

General

Profile

action #59939

[functional][y] first entry in product selection list is not highlighted on s390

Added by ybonatakis almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 30+
Start date:
2019-11-18
Due date:
2019-12-03
% Done:

0%

Estimated time:
5.00 h
Difficulty:

Description

Observation

Seems like the spc keystroke is not click the checkbox as it is expected but instead it presses the next button. this is observed on s390 as there is no occurrence in other archs

It might be that we need to tab to the list.
We also need to check if there are two mechanisms in place, like clicking on checkboxes instead of iterating over the list which is fallback, when needle is not visible.

We should attempt to unify flows of module selection for registered and unregistered installations.

https://openqa.suse.de/tests/3598118#step/scc_registration/13 vs https://openqa.suse.de/tests/3597803#step/addon_products_sle/4

openQA test in scenario sle-15-SP2-Full-s390x-skip_registration@s390x-kvm-sle12 fails in
addon_products_sle

Test suite description

Maintainer: okurz, riafarov

Like a standard scenario with explicit skipping of SCC registration in case where we register by default, e.g. for SLE >= 15
See https://progress.opensuse.org/issues/25264 for details.

Reproducible

Fails since (at least) Build 72.1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by riafarov almost 2 years ago

  • Due date set to 2019-12-03
  • Target version set to Milestone 30+

It looks more like someone has created wrong needle and entry is not highlighted. I will remove it. Someone is actually ybonatakis =D

#2 Updated by riafarov almost 2 years ago

  • Priority changed from Normal to High

#3 Updated by riafarov almost 2 years ago

  • Subject changed from [functional][y] spc key mapping doent perform a selection on s390 to [functional][y] first entry in product selection list is not highlighted on s390
  • Description updated (diff)
  • Status changed from New to Workable
  • Estimated time set to 5.00 h

#4 Updated by oorlov almost 2 years ago

  • Status changed from Workable to In Progress
  • Assignee set to oorlov

#6 Updated by oorlov almost 2 years ago

hyperv is fixed by just removing the wrong needle (addon-products-all_packages-base-highlighted-20191122): https://openqa.suse.de/tests/3629067

#7 Updated by oorlov almost 2 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF