action #59241

[sle][functional][u] test fails in libqt5_qtbase - pkcon giving a false positive

Added by jorauch 4 months ago. Updated 3 months ago.

Status:RejectedStart date:08/11/2019
Priority:HighDue date:
Assignee:jorauch% Done:

0%

Category:Bugs in existing testsEstimated time:42.00 hours
Target version:SUSE QA tests - Milestone 28
Difficulty:medium
Duration:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-extra_tests_on_kde@DrMullings/os-autoinst-distri-opensuse#x11_start@64bit fails in
libqt5_qtbase

pkcon check succeeds despite the program not being installed
This code can be found in lib/susedistribution in ensure_installed

Tasks

  1. Make wait_serial look for 0 or expected return codes for 'package already installed'.
  2. Find out why libqt5-qttools doesn't install designer-qt5

Reproducible

Fails since (at least) Build DrMullings/os-autoinst-distri-opensuse#8810

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Blocks openQA Tests - action #55580: [functional][u] Refactor susedistribution::x11_start_prog... Feedback 15/08/2019

History

#1 Updated by jorauch 4 months ago

  • Blocks action #55580: [functional][u] Refactor susedistribution::x11_start_program to support command not found (and retry) added

#2 Updated by SLindoMansilla 4 months ago

  • Description updated (diff)
  • Status changed from New to Workable
  • Priority changed from Normal to High
  • Estimated time set to 42.00

#3 Updated by jorauch 3 months ago

I can not reproduce this under any means, not sure how to continue

#4 Updated by SLindoMansilla 3 months ago

  • Status changed from Workable to Rejected

Not reproducible on production nor using the PR

Also available in: Atom PDF