Project

General

Profile

action #63442

[functional][u] "pkcon succeeded" but it actually failed to install a package

Added by okurz over 1 year ago. Updated about 1 year ago.

Status:
Rejected
Priority:
Normal
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 30
Start date:
2020-02-13
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-15.2-DVD-x86_64-extra_tests_on_gnome@64bit in
steam shows
"Fatal error: nothing provides" but https://openqa.opensuse.org/tests/1173170#step/steam/26 mentions "pkcon succeeded" which is apparently wrong.

Test suite description

Maintainer: asmorodskyi, okurz. Extra tests which were designed to run on gnome

Reproducible

Fails since (at least) Build 535.2

Expected result

the test code should fail if pkcon fails to install a package.

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #59241: [sle][functional][u] test fails in libqt5_qtbase - pkcon giving a false positiveRejected2019-11-08

History

#1 Updated by SLindoMansilla about 1 year ago

  • Status changed from New to Rejected
  • Assignee set to SLindoMansilla
  • Target version set to Milestone 30

Link to failed test does not exist anymore.
Not able to find exit code different than 0 for the last 4 builds.

Please, reopen when a new occurrence of pckon showing RC different than 0 appears again

#2 Updated by szarate about 1 year ago

  • Related to action #59241: [sle][functional][u] test fails in libqt5_qtbase - pkcon giving a false positive added

Also available in: Atom PDF