Project

General

Profile

action #57785

Remove all assets in iso

Added by andriinikitin 9 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2019-10-08
Due date:
% Done:

0%

Estimated time:
Difficulty:
Duration:

Description

Remove .sha256 file (if exists) when removing .iso assets


Related issues

Related to openQA Project - action #59151: Move sha256 files to 'other'Resolved2019-11-06

History

#1 Updated by coolo 9 months ago

I disagree - this is way too specific for OBS projects. But you'd need to register the asset with the jobs so they are considered at all

#2 Updated by coolo 9 months ago

(which would potentially pollute our DB - why exactly are we syncing them?)

#3 Updated by andriinikitin 9 months ago

rsync.pl way is to read all .iso files as part of generating isos post command to provide ISO_CHECKSUM (and sometimes ISO_CHECKSUM_1?), which sounds inefficient way to do things (and wrong, because the file might be corrupted during rsync).
Can we always carry .sha256 files together with .iso instead?

#4 Updated by okurz 8 months ago

  • Category set to Feature requests

#5 Updated by cdywan 8 months ago

  • Category changed from Feature requests to Concrete Bugs
  • Status changed from New to In Progress
  • Assignee set to cdywan
  • Target version set to Current Sprint

After studying the code I think this is actually a bug. The code intentionally ignores unknown files with no explanation or even a log message.

#6 Updated by coolo 8 months ago

These checksums shouldn't be in 'iso' at all - but in 'other' and tracked as job setting with ASSET_\d+

#7 Updated by coolo 8 months ago

#8 Updated by coolo 8 months ago

  • Subject changed from Remove .sha256 file when removing .iso assets to Remove all assets in iso

Let's redefine this one to what Christian wrote

#9 Updated by cdywan 8 months ago

  • Status changed from In Progress to Feedback

#10 Updated by andriinikitin 8 months ago

So actual problem with sha256 files was started when openqa-trigger-from-ibs started carrying .sha256 files together with .iso files.
Now the problem is fixed with commit below and the scripts do register .sha256 fiels as 'other' assets:

https://gitlab.suse.de/openqa/openqa-trigger-from-ibs/commit/6abdaa8b09bbdba9584ca8f0db846b4694ad12b1

#11 Updated by okurz 7 months ago

  • Status changed from Feedback to Resolved
  • Target version changed from Current Sprint to Done

checked on osd, found no sha256 files in /var/lib/openqa/share/factory/iso and I assume we are good.

Also available in: Atom PDF