Project

General

Profile

action #57014

[tools] test fails in test_results - command 'openqa-client jobs/1/cancel post' fails

Added by mlin7442 9 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Start date:
2019-09-18
Due date:
% Done:

0%

Estimated time:
Difficulty:
Duration:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-openqa_bootstrap@64bit fails in
test_results

Test suite description

Maintainer: dheidler. Install openQA using openqa-bootstrap script.

Reproducible

Fails since (at least) Build 20190917

Expected result

Last good: 20190916 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by okurz 8 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: openqa_bootstrap
https://openqa.opensuse.org/tests/1046108

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#2 Updated by ggardet_arm 8 months ago

  • Subject changed from test fails in test_results - command 'openqa-client jobs/1/cancel post' timed out to test fails in test_results - command 'openqa-client jobs/1/cancel post' fails

Now it is a connection refused, not a timeout anymore: https://openqa.opensuse.org/tests/1044640#step/test_results/23

And the job fails as Incomplete before that.

#3 Updated by ggardet_arm 8 months ago

Nested autoinst-log.txt from a modified test: https://openqa.opensuse.org/tests/1054447/file/nested-autoinst-log.txt
reports:

[2019-10-11T07:43:12.675 EDT] [debug] Backend process died, backend errors are reported below in the following lines:
no kvm-img/qemu-img found

Probably due to https://github.com/os-autoinst/os-autoinst/pull/1205

#4 Updated by SLindoMansilla 8 months ago

  • Subject changed from test fails in test_results - command 'openqa-client jobs/1/cancel post' fails to [tools] test fails in test_results - command 'openqa-client jobs/1/cancel post' fails

#5 Updated by okurz 7 months ago

  • Status changed from New to Feedback
  • Assignee set to okurz
  • Target version set to Current Sprint

#6 Updated by okurz 7 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: openqa_bootstrap
https://openqa.opensuse.org/tests/1076848

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#7 Updated by ggardet_arm 7 months ago

okurz, to add Recommends for qemu-img is not enough to fix this since openqa-bootstrap uses --no-recommends option: https://github.com/os-autoinst/openQA/blob/master/script/openqa-bootstrap#L16

#8 Updated by okurz 7 months ago

yeah, I see. Thanks. Didn't manage to take a look the past days.

openqa-clone-job --within-instance https://openqa.opensuse.org --parental-inheritance --skip-chained-deps 1079966 BUILD= _GROUP=0 CASEDIR=https://github.com/okurz/os-autoinst-distri-opensuse.git#fix/openqa

-> https://openqa.opensuse.org/tests/1080096

=> https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/8878

and https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/8879 to fix the variable name

#9 Updated by okurz 7 months ago

  • Status changed from Feedback to Resolved

#10 Updated by dheidler 3 months ago

  • Status changed from Resolved to Feedback

If qemu-tools is only recommended by some rpm but required to run an openQA test then shouldn't we consider it a bug that qemu-tools is not required by some rpm?

#12 Updated by okurz 3 months ago

dheidler wrote:

If qemu-tools is only recommended by some rpm but required to run an openQA test then shouldn't we consider it a bug that qemu-tools is not required by some rpm?

qemu-tools is not required for all backends but qemu. What you could do is to create a specific subpackage, e.g. the "qemu os-autoinst" or "qemu worker" which requires qemu-tools.

#13 Updated by okurz 3 months ago

  • Status changed from Feedback to Resolved

https://github.com/os-autoinst/openQA/pull/2809 has been merged. As soon as the openQA package is available in Tumbleweed you can merge the test changes as well. However, still, currently no tests in the mentioned scenario are failing for the same symptoms so we can keep this "Resolved" again, right?

https://openqa.opensuse.org/tests/1192902 fails due to #64069

#14 Updated by dheidler 3 months ago

  • Status changed from Resolved to Feedback

Let's keep this in feedback until we saw the new test get executed.
Otherwise I might loose track of this one.

#15 Updated by dheidler 3 months ago

  • Assignee changed from okurz to dheidler

#16 Updated by dheidler 3 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF