Project

General

Profile

action #55286

[qam][urgent] test fails in firefox_html5 - youtube's html5 testing page is gone

Added by vsvecova almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-08-09
Due date:
2020-03-06
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

https://www.youtube.com/html5 now gets redirected to https://www.youtube.com/supported_browsers

It is not clear whether this is a temporary thing or not.

openQA test in scenario sle-15-SP1-Server-DVD-Updates-x86_64-qam-regression-firefox-SLES@64bit fails in
firefox_html5

Test suite description

Reproducible

Fails since (at least) Build 20190809-1 (current job)

Expected result

Last good: 20190808-1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by vsvecova almost 3 years ago

In the meantime, someone has created a new needle, which I'm not sure makes too much of a semantic sense: https://gitlab.suse.de/openqa/os-autoinst-needles-sles/commit/584e139f3aeab7ac10da7167722c0daa3752a032
Also, the previous needle seemed to be entirely wrong too, with very weirdly selected matching areas heaped on one another.

From a broader perspective though, I'm not sure whether our firefox_html5 test makes much sense altogether at this point. Due to the fact that the html5 player has been youtube's default video player for years now, while Flash has been essentially dead anyway all this time, perhaps it would make more sense testing whether the player is even there and actually plays something, rather than checking a random site that just detects the browser version and announces that this particular browser has youtube's seal of approval.

Any thoughts on that?

#2 Updated by okurz almost 3 years ago

I agree. https://bugzilla.suse.com/tr_show_case.cgi?case_id=1479221 was the original base for the automated test module. A test checking simply if playback works would be nice if this can be achieved in a stable and robust way.

#3 Updated by brhavel over 2 years ago

  • Subject changed from [qam] test fails in firefox_html5 - youtube's html5 testing page is gone to [qam][urgent] test fails in firefox_html5 - youtube's html5 testing page is gone
  • Priority changed from Normal to Urgent

#4 Updated by apappas over 2 years ago

  • Assignee set to apappas

The test currently goes to the video page but doesn't actually click on the video player, so assert_screen('firefox-flashplayer-video_loaded'); should become assert_and_click('firefox-flashplayer-video_loaded');

The video has a long testing sequence different than the thumbnail, so playback could be tested with a needle.

Since youtube has been only serving videos exclusively over html5 for quite some time now, I think it would be a sufficient test of html5 video playback.

#5 Updated by tjyrinki_suse over 2 years ago

  • Due date set to 2020-03-06
  • Status changed from New to In Progress

Setting due date to end of this sprint. If this is not under work during this sprint, please correct etc anything.g

#6 Updated by apappas over 2 years ago

  • Status changed from In Progress to Resolved

PR merged.

Also available in: Atom PDF