Project

General

Profile

action #54422

action #55703: send_keys() doesn't guarantee that the application will handle modifiers+normal_key properly

[functional][u] LO recent documents: alt-f not working on wayland (TW)

Added by dimstar 12 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2019-07-18
Due date:
% Done:

0%

Estimated time:
42.00 h
Difficulty:
Duration:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-desktopapps-documentation@64bit fails in
libreoffice_recent_documents

Suggestions

Acceptance criteria

  • AC: A statistical investigation of 100 jobs doesn't reproduce the issue with the applied patch.

Reproducible

Fails since Build 20190705

Expected result

Last good: 20190704

Further details

Always latest result in this scenario: latest

With the switch of the video driver to std, Tumbleweed (and thus also Leap) moved to Wayland as the default session.

In the code for the LO test, there is this block:

 # Because of bsc#1074057 alt-f is not working in libreoffice under wayland
 # use another way to replace alt-f in SLED15
 if (is_sle '15+') {
     assert_and_click('ooffice-writing-file', timeout => 10);
 }
 else {
     send_key "alt-f";    # is_sle('<15') and openSUSE all need to send key
 }

The if clause would better be based on the session type in this case, rather than product version

History

#1 Updated by SLindoMansilla 12 months ago

  • Subject changed from LO recent documents: alt-f not working on wayland (TW) to [functional][u] LO recent documents: alt-f not working on wayland (TW)
  • Priority changed from Normal to High

#2 Updated by okurz 11 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: desktopapps-documentation
https://openqa.opensuse.org/tests/997958

#3 Updated by SLindoMansilla 11 months ago

  • Related to action #43889: [functional][u][virtio][wayland] test fails in ooffice - openQA makes spelling mistakes added

#4 Updated by SLindoMansilla 11 months ago

  • Parent task set to #55703

#5 Updated by SLindoMansilla 11 months ago

  • Related to deleted (action #43889: [functional][u][virtio][wayland] test fails in ooffice - openQA makes spelling mistakes)

#6 Updated by SLindoMansilla 10 months ago

  • Description updated (diff)
  • Status changed from New to Workable
  • Priority changed from High to Normal
  • Estimated time set to 42.00 h

#7 Updated by okurz 10 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: desktopapps-documentation
https://openqa.opensuse.org/tests/1038486

#8 Updated by okurz 9 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: desktopapps-documentation
https://openqa.opensuse.org/tests/1051144

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#9 Updated by okurz 9 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: desktopapps-documentation
https://openqa.opensuse.org/tests/1062808

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#10 Updated by SLindoMansilla 8 months ago

Should be fixed by: https://github.com/os-autoinst/os-autoinst/pull/1260/files

To resolve, provide verification runs, set a proper value for VNC_TYPING_LIMIT if necessary.

#11 Updated by zcjia 8 months ago

Hi, this "missing of alt-f" is caused by https://bugzilla.suse.com/show_bug.cgi?id=1156745 , the key is not actually missing.

I'll submit a workaround for this issue very soon.

#12 Updated by okurz 7 months ago

  • Status changed from Workable to Resolved

Also available in: Atom PDF