Project

General

Profile

action #54314

[vmware] test fails in start_install; /etc/default/grub_installdevice missing in images

Added by michalnowak almost 3 years ago. Updated 4 months ago.

Status:
New
Priority:
Normal
Assignee:
michalnowak
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-07-16
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP5-Server-DVD-x86_64-media_upgrade_sles12sp4_allpatterns_vmware@svirt-vmware65 fails in
start_install

In VMware SP4 migration images /etc/default/grub_installdevice is either missing, or wrongly set (more likely the former).

It worked fine when migrating to 15 SP1 but does not when migrating to 12 SP5 (https://bugzilla.suse.com/show_bug.cgi?id=1141016).

Reproducible

Fails since (at least) Build 0219

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by michalnowak almost 3 years ago

  • Assignee set to michalnowak

#2 Updated by michalnowak almost 3 years ago

Check that /etc/default/grub_installdevice is present in the image. If it isn't create it with device where is bootloader, stop the VM and export the image.

If it didn't help the image should be created again from install disk.

#3 Updated by okurz almost 3 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: media_upgrade_sles12sp4_allpatterns_vmware@svirt-vmware65
https://openqa.suse.de/tests/3204466

#4 Updated by okurz over 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: media_upgrade_sles12sp4_allpatterns_vmware@svirt-vmware65
https://openqa.suse.de/tests/3262945

#5 Updated by okurz over 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: media_upgrade_sles12sp4_allpatterns_vmware@svirt-vmware65
https://openqa.suse.de/tests/3318339

#6 Updated by okurz over 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: media_upgrade_sles12sp4_allpatterns_vmware@svirt-vmware65
https://openqa.suse.de/tests/3389618

#7 Updated by okurz over 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: media_upgrade_sles12sp4_vmware@svirt-vmware65
https://openqa.suse.de/tests/3414374

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#8 Updated by okurz over 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: media_upgrade_sles12sp4_allpatterns_vmware@svirt-vmware65
https://openqa.suse.de/tests/3496622

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#9 Updated by okurz over 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: media_upgrade_sles12sp4_allpatterns_vmware@svirt-vmware65
https://openqa.suse.de/tests/3507760

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#10 Updated by okurz over 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: media_upgrade_sles12sp4_allpatterns_vmware@svirt-vmware65
https://openqa.suse.de/tests/3576800

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#11 Updated by okurz 9 months ago

This ticket was set to "Normal" priority but was not updated within the SLO period for "Normal" tickets (365 days) as described on https://progress.opensuse.org/projects/openqatests/wiki/Wiki#SLOs-service-level-objectives . Please consider picking up this ticket within the next 365 days or just set the ticket to the next lower priority of "Low" (no SLO related time period). This update was done as agreed within the SUSE QE Sync call 2021-09-01

#12 Updated by maritawerner 4 months ago

xlai this is a very old ticket and Michal hs left SUSE already. Do you think that is still relevant or can we close the ticket?

Also available in: Atom PDF