Project

General

Profile

Actions

action #51764

closed

[qe-core][functional][sporadic] test fails in setup_zdup of opensuse-Tumbleweed-NET-x86_64-Build20190520-zdup-Leap-15.0-gnome@64bit in development group

Added by okurz almost 5 years ago. Updated about 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 30
Start date:
2019-05-21
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-NET-x86_64-zdup-Leap-15.0-gnome@64bit fails in
setup_zdup
to accept the boot menu entry.
It looks like this is a race condition triggered in the step one before.
https://openqa.opensuse.org/tests/937452#step/setup_zdup/1
checks for both "grub2" as well as "inst-bootmenu". inst-bootmenu is also the screen that the previous module "bootloader" already checked for and pressed "ret" afterwards. In the next module, setup_zdup, then the test sees still inst-bootmenu when it is fast enough to check or just finds grub2, depending on timing. Could be this is a regression introduced by e.g. someone from qsf-u or the migration time.

Suggestion

Look closer into the code before even trying to fix it

Reproducible

Fails sporadically with a fail ratio of about 70%

Expected result

https://openqa.opensuse.org/tests/934054#step/setup_zdup/2 is how it should look like in the good case.

Further details

Always latest result in this scenario: latest


Related issues 1 (1 open0 closed)

Related to openQA Tests - action #50804: [opensuse] test fails in setup_zdup - bootmenu matched first then inst-bootmenu-boot-harddisk not able to be matched(zdup 15.0 and zdup tw2tw only)In Progressyying2019-04-26

Actions
Actions #1

Updated by szarate over 4 years ago

  • Description updated (diff)

Let's make the suggestion a bit obvious, just in case.

Actions #2

Updated by szarate over 4 years ago

  • Status changed from New to Workable
  • Priority changed from High to Normal
Actions #3

Updated by zluo over 4 years ago

  • Status changed from Workable to In Progress
  • Assignee set to zluo

take over and checking...

Actions #4

Updated by zluo over 4 years ago

  • Target version set to Milestone 25
Actions #5

Updated by zluo over 4 years ago

the link under Observation https://openqa.opensuse.org/tests/938557/modules/setup_zdup/steps/45 and under Expected result https://openqa.opensuse.org/tests/934054#step/setup_zdup/2 are not valid anymore!

checked that recent tests run https://openqa.opensuse.org/tests/997831 failed already for a month, so this is not about a rice condition or sporadic issue.

Actions #6

Updated by zluo over 4 years ago

found out that there is a difference for qemuvga, now we don't use cirrus anymore, the default qemuvga (I even don't know what is used! the setting itself is missing),
so I set this to cirrus and get the test successfully:

http://f40.suse.de/tests/4761

Actions #7

Updated by okurz over 4 years ago

  • Related to action #50804: [opensuse] test fails in setup_zdup - bootmenu matched first then inst-bootmenu-boot-harddisk not able to be matched(zdup 15.0 and zdup tw2tw only) added
Actions #8

Updated by okurz over 4 years ago

#53729 is the ticket for adaption to the "std" graphics adapter.

Actions #9

Updated by zluo over 4 years ago

  • Status changed from In Progress to Blocked

set this ticket (with original issue) as now as blocked because of #53729.

Actions #10

Updated by mgriessmeier over 4 years ago

  • Target version changed from Milestone 25 to Milestone 30+
Actions #11

Updated by zluo over 4 years ago

  • Assignee deleted (zluo)

unassign

Actions #12

Updated by zluo over 4 years ago

  • Assignee set to zluo

keeping assignment for now

Actions #13

Updated by mgriessmeier about 4 years ago

  • Target version changed from Milestone 30+ to Milestone 30

needs to be discussed offline

Actions #14

Updated by tjyrinki_suse over 3 years ago

  • Subject changed from [functional][u][sporadic] test fails in setup_zdup of opensuse-Tumbleweed-NET-x86_64-Build20190520-zdup-Leap-15.0-gnome@64bit in development group to [qe-core][functional][sporadic] test fails in setup_zdup of opensuse-Tumbleweed-NET-x86_64-Build20190520-zdup-Leap-15.0-gnome@64bit in development group
Actions #15

Updated by zluo about 3 years ago

  • Status changed from Blocked to Rejected
Actions

Also available in: Atom PDF