Project

General

Profile

action #50162

[qam][yellow] test fails in 1_postfix

Added by bfilho about 1 year ago. Updated 10 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-04-09
Due date:
% Done:

0%

Estimated time:
Difficulty:
Duration:

Description

Observation

openQA test in scenario sle-12-SP3-Server-DVD-Updates-x86_64-mau-qa_userspace_postfix@64bit fails in
1_postfix

Test suite description

https://openqa.suse.de/tests/2788477#step/1_postfix/5

Reproducible

Fails since (at least) Build 20190409-1

Expected result

Last good: 20190408-2 (or more recent)

Further details

I'm not sure why this is failing a few times in a row.
Would you please investigate this issue? The test is failing for both 12 SP3 and 12 SP4

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #51191: [qam] merge tests from 1_postfix into postfix openqa testNew2019-05-06

History

#1 Updated by bfilho about 1 year ago

  • Status changed from New to Blocked

The package is going to be removed from the queue since it's causing the issues described on bsc#1095073.
I'll update it to rejected or closed after the next round runs without the package.

#2 Updated by bfilho about 1 year ago

Manuel and Jhuraj noticed the issue and already informed the maintainer of the package.

#3 Updated by bfilho about 1 year ago

  • Status changed from Blocked to Rejected

Since the issue were acknowledged, the issue were in the package, and no improvement is supposed to be done on the tests, I'm rejecting it.

#4 Updated by bfilho about 1 year ago

  • Status changed from Rejected to New

As seen on bsc#1095073, comment #15, it seems that there's need to change some of the test's configurations.

I'm reopening the test issue in this case.

#5 Updated by hurhaj about 1 year ago

I'll just copy my findings here so whoever will be fixing it won't have to look into bugzilla:

diff of /etc/postfix/main.cf before/after update:
< daemon_directory = /usr/lib/postfix
---
> daemon_directory = /usr/lib/postfix/bin/

So configs used in tests have to be adjusted too:
# for i in /usr/share/qa/qa_test_postfix/conf/*.conf ; do sed -i 's;daemon_directory = /usr/lib/postfix;daemon_directory = /usr/lib/postfix/bin/;g' $i; done

I did NOT check if this change is in all code streams, only on 12sp3.

#6 Updated by okurz about 1 year ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: mau-qa_userspace_postfix
https://openqa.suse.de/tests/2831815

#7 Updated by msmeissn about 1 year ago

  • Priority changed from Normal to Urgent

causes RED runs in maintenance for 12 sp3 and 12 sp4.

#8 Updated by jbaier_cz about 1 year ago

  • Status changed from New to In Progress
  • Assignee set to jbaier_cz

#9 Updated by jbaier_cz about 1 year ago

  • Subject changed from [qam] test fails in 1_postfix to [qam][yellow] test fails in 1_postfix
  • Status changed from In Progress to Feedback

As hurhaj already mentioned, daemon_directory for SLE >= 12SP3 has changed. This was already covered for SLE15 in qa_test_postfix-0.3. Addressed by https://github.com/SUSE/qa-testsuites/pull/714

#10 Updated by jbaier_cz about 1 year ago

  • Related to action #51191: [qam] merge tests from 1_postfix into postfix openqa test added

#11 Updated by jbaier_cz about 1 year ago

  • Status changed from Feedback to Resolved

#12 Updated by dzedro about 1 year ago

  • Status changed from Resolved to In Progress

This issue looks same on SLE 12sp1 too. https://openqa.suse.de/tests/2890717#step/1_postfix/5

#13 Updated by okurz 12 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: mau-qa_userspace_postfix
https://openqa.suse.de/tests/2932740

#14 Updated by okurz 12 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: mau-qa_userspace_postfix
https://openqa.suse.de/tests/2968473

#15 Updated by okurz 11 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: mau-qa_userspace_postfix
https://openqa.suse.de/tests/3015721

#16 Updated by okurz 11 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: mau-qa_userspace_postfix
https://openqa.suse.de/tests/3045889

#17 Updated by okurz 10 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: mau-qa_userspace_postfix
https://openqa.suse.de/tests/3133559

#18 Updated by jbaier_cz 10 months ago

  • Status changed from In Progress to Feedback

#19 Updated by jbaier_cz 10 months ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF