Project

General

Profile

action #49688

[functional][y] Review the yast2_i module

Added by dimstar over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2019-03-26
Due date:
2019-04-23
% Done:

0%

Estimated time:
5.00 h
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-update_13.1-gnome@64bit fails in
yast2_i

Test suite description

riafarov has added HDDSERIAL_1=1 poo#38963

Reproducible

Fails since (at least) Build 20190319

Expected result

Last good: 20190318 (or more recent)

Further details

Always latest result in this scenario: latest

This issue seems only to happen on machines that were upgraded from very old openSUSE releases; but looking at the screens 'as user' seems not to imply anything going wrong.

Thus, please review this test failure and the module - likely there are invalid needles in play, giving wrong indications as to how to continue with the execution

We have strange condition

until (get_var('YAST_SW_NO_SUMMARY')) {
         assert_screen ['yast2-sw-packages-autoselected', 'yast2-sw_automatic-changes', 'yast2-sw_shows_summary'], 60;

And seems that variable is set somewhere in other test module. Also it works in clean installation (not upgrade scenario), so seems that variable is set there.
It also works fine in the upgrade scenarios with newer leap scenarios.

NOTE: test module is executed as default set of tests for validation

History

#1 Updated by SLindoMansilla over 3 years ago

  • Subject changed from Review the yast2_i module to [functional][y] Review the yast2_i module

As a result of backlog triaging (see https://progress.opensuse.org/projects/openqatests/wiki#ticket-backlog-triaging for more information).

Please, feel free to adjust the category or the "[label]" if you think different.

#2 Updated by riafarov over 3 years ago

  • Description updated (diff)
  • Due date set to 2019-04-09

#3 Updated by riafarov over 3 years ago

  • Description updated (diff)
  • Status changed from New to Workable
  • Estimated time set to 5.00 h

#4 Updated by mloviska over 3 years ago

  • Status changed from Workable to In Progress
  • Assignee set to mloviska

#5 Updated by mloviska over 3 years ago

## Type: list(close,restart,summary)
## Default: "summary"
# Set the default behavior of the package manager when package installation has finished.
# Possible actions are:
#   close - just finish the package manager
#   restart - go back to the package manager, install/remove more packages
#   summary - display an installation summary dialog, there user can decide whether to finish or restart
# The summary dialog is always displayed when an installation error has occured.
PKGMGR_ACTION_AT_EXIT="summary"

I would suggest parsing /etc/sysconfig/yast2 to check what kind of behavior of yast2 we should expect.

YAST_SW_NO_SUMMARY=1 is set in below test suites:

  • update_13.1-gnome
  • zdup-13.1-gnome
  • update_122
  • update_121
  • update_123

And from the code point of view, I haven't found any other trace of YAST_SW_NO_SUMMARY than ./tests/console/yast2_i.pm.

dimstar, I cannot find any schedule that we would use update_12{1..3} jobs, do we still need them?

#6 Updated by dimstar over 3 years ago

mloviska wrote:

dimstar, I cannot find any schedule that we would use update_12{1..3} jobs, do we still need them?

No, upgrades from 12.x to Tumbleweed have been abandoned, as new disk images would have been necessary (out of disk space) - and that was not worth the effort.

#7 Updated by mloviska over 3 years ago

dimstar wrote:

mloviska wrote:

dimstar, I cannot find any schedule that we would use update_12{1..3} jobs, do we still need them?

No, upgrades from 12.x to Tumbleweed have been abandoned, as new disk images would have been necessary (out of disk space) - and that was not worth the effort.

Would you be fine if I remove them? I do not see any point to keep obsolete test suites.

#8 Updated by mloviska over 3 years ago

  • Status changed from In Progress to Feedback

#9 Updated by riafarov over 3 years ago

  • Due date changed from 2019-04-09 to 2019-04-23

#12 Updated by mloviska over 3 years ago

  • Status changed from Feedback to Resolved

YAST_SW_NO_SUMMARY from (update_121, update_122, update_123, update_13.1-gnome, zdup-13.1-gnome) and obsolete test suites as update_121, update_122, update_123 have been removed from o3. I will close this ticket, since the ongoing issues are jeos/aarch64 related.

#14 Updated by okurz over 3 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: jeos-main@svirt-xen-pv
https://openqa.suse.de/tests/2877364

Also available in: Atom PDF