Project

General

Profile

action #49010

[opensuse][functional][y] Add test suite for NET install + expert partitioner on Tumbleweed

Added by karlmistelberger over 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
New test
Target version:
SUSE QA - Milestone 27
Start date:
2019-03-11
Due date:
2019-08-13
% Done:

0%

Estimated time:
3.00 h
Difficulty:

Description

Expert partitioner failed on several occasions in the past. Current installer openSUSE-Tumbleweed-NET-x86_64-Snapshot20190307-Media.iso again has an issue: Deleting a partition will fail. Automatic testing of all options is recommended.

Acceptance criteria

  • AC: Enable one of the test suites which uses Expert Partitioner for UEFI + NET installation media

Suggestions

lvm-encrypt-separate-boot or RAID1 tests are good candidates for the scenario.
We can try to reuse schedule raid1_gpt_uefi.yaml which is specific for uefi, but instead of using in arm for sle, in this case apply it to tw net installation.
We don't remove partitions in any tests, I will create test for that.

y2log-Y7wvcd.tar.xz (118 KB) y2log-Y7wvcd.tar.xz failed install karlmistelberger, 2019-03-12 12:56

Related issues

Related to openQA Project - action #55052: Support for ovmf => 2019 or "current Tumbleweed can not execute UEFI tests anymore"Resolved2019-08-02

History

#1 Updated by mlin7442 over 2 years ago

  • Project changed from openSUSE Release Process to openQA Tests
  • Category set to Enhancement to existing tests

move to openQA tests project

#2 Updated by SLindoMansilla over 2 years ago

  • Subject changed from Tumbleweed netinstall expert partitioner to [functional][opensuse][y] Add test suite for NET install + expert partitioner on Tumbleweed
  • Category changed from Enhancement to existing tests to New test
  • Status changed from New to Feedback
  • Assignee set to SLindoMansilla

Maybe just scheduling btrfs+warnings for NET media is enough to cover it: https://openqa.opensuse.org/tests/876279#step/partitioning_warnings/43
scheduled for Tumbleweed development job group: https://openqa.opensuse.org/admin/job_templates/38

Karl, could you describe the steps to reproduce?

#3 Updated by karlmistelberger over 2 years ago

Steps to reproduce are discussed starting here: https://forums.opensuse.org/showthread.php/535149-efibootmgr-won-t-print-additional-information?p=2896342#post2896342

Short version: Select an existing partition and press "Delete".

#4 Updated by SLindoMansilla over 2 years ago

I don't see any steps to reproduce in that ticket.
One data I got from the ticket is that it happens on UEFI, so, scheduling also for UEFI on Tumbleweed development job group.

This missing data is so important to know that I was scheduling the legacy one. Maybe there it works, and then we get again to the point where we say that our tests pass and users complaining that our tests are screwed up.

Please, take it as a constructive critic. openSUSE doesn't have enough resources to test infinite combinations of use cases. That means, that some users may encounter problems that we (and our tests) din't. But, we are willing to include real use cases from user's feedback. But, for that we need a complete even exhaustive description of how to reproduce the bug. I fear that with your description, we will still miss your use case and nothing will be resolved.
We already covered all the actions mentioned in that mail chain. So, the problem is triggered doing this action in combination with something else. We will see if the combination with UEFI and NET installer is the cause. If not, something is missing.

#5 Updated by SLindoMansilla over 2 years ago

This is a closer description to the environment needed to reproduce the problem about not possible to delete partitions: https://forums.opensuse.org/showthread.php/535149-efibootmgr-won-t-print-additional-information?p=2896622#post2896622

Which actually states that the error happens when using the "guided partitioner" and selecting "remove even if not needed". So, it may not be reproducible by manually deleting a partition.

#6 Updated by karlmistelberger over 2 years ago

Appended y2log

#8 Updated by okurz over 2 years ago

  • Subject changed from [functional][opensuse][y] Add test suite for NET install + expert partitioner on Tumbleweed to [opensuse][functional][u] Add test suite for NET install + expert partitioner on Tumbleweed
  • Target version set to Milestone 25

@SLindoMansilla please track the bug and depending on the outcome close, make the ticket workable or move to QSF-y by replacing the [u] in the subject line with [y] when the time comes, thx.

#9 Updated by SLindoMansilla over 2 years ago

  • Description updated (diff)
  • Status changed from Feedback to Resolved

I was actually waiting for having valid results on the scheduled test suite, but, since it seems clear that the cause of the problem is different. Let's continue in the bug ticket if it is needed to create a new test.

The test suites are already scheduled in the development job group.

But, the problem to be solved is different.

#10 Updated by okurz over 2 years ago

  • Status changed from Resolved to Feedback

SLindoMansilla wrote:

The test suites are already scheduled in the development job group.

ok, but every job in the development job group should have an open ticket attached until we can move the scenario into a validation job group.

#11 Updated by SLindoMansilla over 2 years ago

  • Status changed from Feedback to Workable
  • Assignee deleted (SLindoMansilla)

The test needs adaption for NET install: https://openqa.opensuse.org/tests/880685#step/partitioning_warnings/34

This needs to be properly planned.

#12 Updated by SLindoMansilla over 2 years ago

  • Subject changed from [opensuse][functional][u] Add test suite for NET install + expert partitioner on Tumbleweed to [opensuse][functional][y] Add test suite for NET install + expert partitioner on Tumbleweed

For yast team

#13 Updated by riafarov over 2 years ago

  • Due date set to 2019-06-18

#14 Updated by riafarov over 2 years ago

  • Description updated (diff)
  • Due date changed from 2019-06-18 to 2019-07-09
  • Target version changed from Milestone 25 to Milestone 27

#15 Updated by riafarov over 2 years ago

  • Due date changed from 2019-07-09 to 2019-08-13

#16 Updated by JERiveraMoya about 2 years ago

  • Description updated (diff)

#17 Updated by JERiveraMoya about 2 years ago

  • Estimated time set to 3.00 h

#18 Updated by ybonatakis about 2 years ago

  • Status changed from Workable to In Progress
  • Assignee set to ybonatakis

#19 Updated by JERiveraMoya about 2 years ago

  • Description updated (diff)

#20 Updated by JERiveraMoya about 2 years ago

  • Description updated (diff)

#21 Updated by ybonatakis about 2 years ago

i am encounter to clone and run jobs with uefi against TB.

i learned that i have to install qemu-ovmf-x86_64 but still the cloned job fails.

#22 Updated by ybonatakis about 2 years ago

Problem has been identified by okurz and a ticket has opened [0]

[0] https://progress.opensuse.org/issues/55052#Workaround

Another solution that seems to work for now is to rename the ovmf-x86_64-ms-code.bin

iob@aquarius /usr/share/qemu $ sudo cp ovmf-x86_64-ms-code.bin ovmf-x86_64-ms.bin

#23 Updated by ybonatakis about 2 years ago

  • Related to action #55052: Support for ovmf => 2019 or "current Tumbleweed can not execute UEFI tests anymore" added

#24 Updated by ybonatakis about 2 years ago

  • Status changed from In Progress to Feedback

#25 Updated by ybonatakis about 2 years ago

  • Assignee deleted (ybonatakis)

The PR [0] is ready and waits for reviews. feel free to merge and close the ticket

[0] https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/8112

#27 Updated by riafarov about 2 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF