Project

General

Profile

action #47933

[functional][u] test fails in vlc - unreliably closing the first_time_wizard - the RET key goes to the checkbox for "send data"

Added by dimstar over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA tests - Milestone 24
Start date:
2019-02-15
Due date:
% Done:

0%

Estimated time:
Difficulty:
Duration:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-update_Leap_42.3_gnome@64bit fails in
vlc

Test suite description

Reproducible

Fails since (at least) Build 20190214 (current job)

Expected result

Last good: 20190213 (or more recent)

Further details

Always latest result in this scenario: latest

The test is unreliably closing the first_time_wizard - the RET key goes to the checkbox for "send data"


Related issues

Related to openQA Tests - action #47132: [opensuse][u][sporadic] test fails in vlc - vlc does not closeResolved2019-02-05

Related to openQA Tests - action #47039: [functional][u] test in vlc wastes 30 seconds without us noticing because of `match_typed`Resolved2019-02-02

Related to openQA Tests - action #42773: [functional][u] extend VLC test to check correct renderingNew2018-10-22

Related to openQA Tests - action #42674: [opensuse][functional][u][sporadic] test fails in vlc - cannot open videoResolved2018-10-18

History

#1 Updated by okurz over 1 year ago

  • Related to action #47132: [opensuse][u][sporadic] test fails in vlc - vlc does not close added

#2 Updated by okurz over 1 year ago

  • Related to action #47039: [functional][u] test in vlc wastes 30 seconds without us noticing because of `match_typed` added

#3 Updated by okurz over 1 year ago

  • Related to action #42773: [functional][u] extend VLC test to check correct rendering added

#4 Updated by okurz over 1 year ago

  • Related to action #42674: [opensuse][functional][u][sporadic] test fails in vlc - cannot open video added

#5 Updated by okurz over 1 year ago

  • Subject changed from test fails in vlc to [functional][u] test fails in vlc - unreliably closing the first_time_wizard - the RET key goes to the checkbox for "send data"
  • Status changed from New to Workable
  • Priority changed from Normal to High
  • Target version set to Milestone 24

#6 Updated by agraul over 1 year ago

  • Status changed from Workable to In Progress
  • Assignee set to agraul

#7 Updated by agraul over 1 year ago

I created https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/6854 and https://github.com/os-autoinst/os-autoinst-needles-opensuse/pull/515. They change the test from sending "RET" to clicking on the "Continue" button since "RET" sometimes misses the button.

#8 Updated by agraul over 1 year ago

  • Status changed from In Progress to Feedback

okurz: Is there anything left to take care of for https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/6854 ? I was on sick leave and to me it looks like Max Lin already did the required changes.

#9 Updated by okurz over 1 year ago

  • Status changed from Feedback to Resolved

yes, it seems to be all good after maxlin and me created more needles in e.g. openSUSE Tumbleweed, ports, Leap, maintenance tests. I guess the rest if at all could easily be covered by rather obvious needle creations so I guess we can call this ticket done. Thx.

Also available in: Atom PDF