Project

General

Profile

action #45083

openQA Tests - action #15108: [sle][functional][u][epic] Modules (Installation + migration)

openQA Tests - action #9464: [sle][functional][u] Modules - Advanced Systems Management

[sle][functional][u] test cfengine

Added by okurz over 1 year ago. Updated 10 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Target version:
SUSE QA tests - Milestone 25
Start date:
2018-12-12
Due date:
2019-06-04
% Done:

0%

Estimated time:
Duration: 125

Description

Motivation

The ASMM module of SLE12 includes cfengine, we should test this on openSUSE and SLE, see parent ticket #9464 as well.

Acceptance criteria

  • AC1: A simple functional test of cfengine is executed for automated openSUSE and SLE tests

Suggestions

  • Same applies as in #45080
  • It may be an openQA test but preferrably it is not when we can cover it more easily, e.g. in a package based test, e.g. as done for valgrind, see #36751
  • Add a package based test in the development package first and make sure to have that test in Factory as well as the SLE package (for SLE12) or the packagehub package for SLE15

Further details

The package is available for SLE15 in packagehub

History

#1 Updated by okurz over 1 year ago

  • Copied from action #45080: [sle][functional][u] test machinery added

#2 Updated by okurz over 1 year ago

  • Copied from deleted (action #45080: [sle][functional][u] test machinery)

#3 Updated by okurz over 1 year ago

  • Parent task set to #9464

#4 Updated by okurz over 1 year ago

  • Due date set to 2019-02-08

#5 Updated by okurz over 1 year ago

I suggest to use an approach as presented in http://s.qa.suse.de/2k18l1-okurz

#6 Updated by okurz over 1 year ago

  • Due date changed from 2019-02-08 to 2019-02-26
  • Target version changed from Milestone 22 to Milestone 23

let's plan for next sprint

#7 Updated by okurz over 1 year ago

  • Due date deleted (2019-02-26)
  • Status changed from Workable to Blocked
  • Assignee set to okurz

Waiting for business value clarification in #15108#note-36

#8 Updated by okurz over 1 year ago

  • Due date set to 2019-03-26

#9 Updated by okurz about 1 year ago

  • Due date changed from 2019-03-26 to 2019-06-04
  • Target version changed from Milestone 23 to Milestone 25

#10 Updated by okurz about 1 year ago

  • Assignee changed from okurz to mgriessmeier

Move to new QSF-u PO after I moved to the "tools"-team. I mainly checked the subject line so in individual instances you might not agree to take it over completely into QSF-u. Feel free to discuss with me or reassign to me or someone else in this case. Thanks.

#11 Updated by maritawerner 11 months ago

I have discussed that task with Joachim Werner, the Product MAnager also for Systems Managemenet, and he confirmed that there is no need to test cfengine. There is no request from sudtomers. I close that task.

#12 Updated by maritawerner 11 months ago

  • Status changed from Blocked to Resolved

#13 Updated by SLindoMansilla 10 months ago

  • Status changed from Resolved to Workable

Since we didn't do anything here, this should have rejected status.

#14 Updated by SLindoMansilla 10 months ago

  • Status changed from Workable to Rejected

Also available in: Atom PDF