Project

General

Profile

action #44696

[qam] test fails in sshd - user password is weak

Added by pcervinka almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-12-04
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-GNOME-Live-x86_64-gnome-live@uefi-2G fails in
sshd

Reproducible

Fails since (at least) Build 20181203 (current job)

Expected result

Last good: 20181130 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by pdostal almost 3 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 10

#2 Updated by dimstar almost 3 years ago

A note from my end: the password is not 'weak': it is simply missing in the command that would set the password (see echo sshboy: | chpasswd)

the password is supposed to be after sshboy:

#3 Updated by StefanBruens almost 3 years ago

dimstar wrote:

A note from my end: the password is not 'weak': it is simply missing in the command that would set the password (see echo sshboy: | chpasswd)

the password is supposed to be after sshboy:

os-autoinst-distri-opensuse/lib/main_common.pm:

sub set_defaults_for_username_and_password {
if (get_var("LIVETEST")) {
    $testapi::password = '';
}
    $testapi::password = "nots3cr3t";
}

#4 Updated by dimstar almost 3 years ago

well, well, well

in the past, we had:

user on livecd has no password, hence $testapi::password = '';

sshboy was generated with an explicit password letmein (or a variant thereof)

 my $ssh_testman_passwd = "let3me2in1";  # this was not just decoration

#5 Updated by pdostal almost 3 years ago

Yes, I discovered all that. I changed the password because of the exec_and_insert_password and I'm about to fix that. Please expect the PR later today or tomorrow early morning.

#6 Updated by pdostal almost 3 years ago

  • % Done changed from 10 to 70

The pull request has been opened.

#8 Updated by pdostal almost 3 years ago

I think it's not about password but about the VirtIO console but I'll look it up.

Thank you for letting me know, @JERiveraMoya

#9 Updated by pdostal almost 3 years ago

Another pull request has been opened.

#10 Updated by pdostal almost 3 years ago

I managed to fix the test for s390x architecture but there's still a problem in one ppc64le testsuite. I asked Petr Vorel to help me with that.

#11 Updated by osukup almost 3 years ago

on SLE12 -> SLE12SP2 this tests fails because 'virtio_console' .. You need add hvc0 + console to /etc/securetty

#12 Updated by pdostal almost 3 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 70 to 100

I belive SLE12, SLE12SP1, SLE12SP2, SLE12SP3, SLE12SP4, SLE15 and also latest Tumbleweed should fixed by PR#6404 now.

Also available in: Atom PDF