action #41780

[ppc64] Settings in Qemu 3.0 seem to be troublesome

Added by szarate over 1 year ago. Updated 6 months ago.

Status:ResolvedStart date:28/09/2018
Priority:NormalDue date:
Assignee:okurz% Done:

0%

Category:Concrete Bugs
Target version:QA - future
Difficulty:
Duration:

Description

When running a job using Qemu v3 the following error is being shown,

[2018-09-28T09:03:18.0097 EDT] [info] ::: OpenQA::Qemu::Proc::save_state: Saving QEMU state to qemu_state.json
[2018-09-28T09:03:18.0097 EDT] [debug] QEMU: QEMU emulator version 3.0.0 (Virtualization / SLE_12)
[2018-09-28T09:03:18.0097 EDT] [debug] QEMU: Copyright (c) 2003-2017 Fabrice Bellard and the QEMU Project developers
[2018-09-28T09:03:18.0098 EDT] [debug] QEMU: qemu-system-ppc64: warning: Failed to set KVM's VSMT mode to 8 (errno -22)
[2018-09-28T09:03:18.0098 EDT] [debug] QEMU: qemu-system-ppc64: KVM does not support 1TiB segments which guest expects

might be related to https://lists.gnu.org/archive/html/qemu-devel/2018-06/msg04742.html although Failed to set KVM's VSMT mode to 8 Looks suspicious enough too

History

#1 Updated by szarate over 1 year ago

Since this might be a qemu problem i asked Zaoliang to report it: https://bugzilla.suse.com/show_bug.cgi?id=1110173

#2 Updated by coolo over 1 year ago

That bug is something completely different though

#3 Updated by szarate about 1 year ago

  • Subject changed from Settings in Qemu 3.0 seem to be troublesome to [ppc64] Settings in Qemu 3.0 seem to be troublesome

So this seems to be on ppc64 only for the time being

#4 Updated by pcervinka about 1 year ago

I faced quite similar error during worker setup on ppc64le on SLE15.

[2018-12-05T06:28:19.240 CET] [debug] QEMU: QEMU emulator version 2.11.2(SUSE Linux Enterprise 15)
[2018-12-05T06:28:19.242 CET] [debug] QEMU: Copyright (c) 2003-2017 Fabrice Bellard and the QEMU Project developers
[2018-12-05T06:28:19.243 CET] [debug] QEMU: qemu-system-ppc64: warning: Failed to set KVM's VSMT mode to 8 (errno -22)
[2018-12-05T06:28:19.244 CET] [debug] QEMU: qemu-system-ppc64: KVM implementation does not support Transactional Memory, try cap-htm=off

It is not exactly same (different qemu version and final error), but can be interesting for you.

Created: https://bugzilla.suse.com/show_bug.cgi?id=1118450

#5 Updated by szarate about 1 year ago

Rbrown reported this one for qemu 3.1: https://bugzilla.opensuse.org/show_bug.cgi?id=1121604

"disallowing migration blocker (--only_migratable) for: Nested VMX virtualization does not support live migration yet"

"x86 machines cannot be live-migrated if nested Intel virtualization is enabled. The next version of QEMU will be able to do live migration when nested virtualization is enabled, if supported by the kernel.

#6 Updated by dheidler about 1 year ago

I can reproduce something similar on SLE15SP1:

vugava-1:~ # qemu-system-ppc64 -nographic -enable-kvm
qemu-system-ppc64: warning: Failed to set KVM's VSMT mode to 8 (errno -22)
qemu-system-ppc64: KVM does not support 1TiB segments which guest expects

.

vugava-1:~ # qemu-system-ppc64 -version
QEMU emulator version 3.1.0 (SUSE Linux Enterprise 15)

.

vugava-1:~ # lscpu 
Architecture:        ppc64le
Byte Order:          Little Endian
CPU(s):              8
On-line CPU(s) list: 0-7
Thread(s) per core:  8
Core(s) per socket:  1
Socket(s):           1
NUMA node(s):        1
Model:               2.2 (pvr 004e 0202)
Model name:          POWER9 (architected), altivec supported
Hypervisor vendor:   pHyp
Virtualization type: para
L1d cache:           32K
L1i cache:           32K
L2 cache:            512K
L3 cache:            10240K
NUMA node0 CPU(s):   0-7
Physical sockets:    2
Physical chips:      1
Physical cores/chip: 4

As this is a POWER9 machine, this kernel patch could be related: https://patchwork.kernel.org/patch/10717339/

#8 Updated by okurz 8 months ago

  • Category set to Concrete Bugs

#9 Updated by okurz 6 months ago

  • Status changed from New to Resolved
  • Assignee set to okurz

https://bugzilla.suse.com/show_bug.cgi?id=1124589 was fixed. I have never seen this error, e.g. also not after upgrading all workers to openSUSE Leap 15.1 so I assume it's not a problem anymore

Also available in: Atom PDF