Project

General

Profile

action #41030

[qam] test fails in updates_packagekit_kde - zypper update requires additional install step

Added by pcervinka almost 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2018-09-14
Due date:
% Done:

0%

Estimated time:
Difficulty:
Duration:

Description

Observation

openQA test in scenario opensuse-15.0-DVD-Updates-x86_64-install_with_updates_kde@uefi-2G fails in
updates_packagekit_kde

Reproducible

Fails since (at least) Build 20180913-1

Expected result

Last good: 20180912-4 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #41396: [qam] Revise updates_packagekit_kdeNew2018-09-21

History

#1 Updated by pcervinka almost 2 years ago

Updates contain zypper update, incident 8725. Update will install zypper first, than it tries to install the rest.
Code in updates_available-tray is not designed for this case.
I will try to implement fix.

#3 Updated by pcervinka almost 2 years ago

  • Subject changed from [qam] test fails in updates_packagekit_kde to [qam] test fails in updates_packagekit_kde - zypper update requires additional install step

#5 Updated by AndreasStieger almost 2 years ago

We had successful runs with this PR merged.

#6 Updated by pcervinka almost 2 years ago

  • Status changed from In Progress to Feedback

Wait few for more days to see, if there is no side effect. I will also try to recheck soft-failed bugs in updates_packagekit_kde, there seems to be no progress on them. Maybe it is time to revise the code of the test(from the long term point of view).

#7 Updated by pcervinka almost 2 years ago

  • Related to action #41396: [qam] Revise updates_packagekit_kde added

#8 Updated by pcervinka almost 2 years ago

  • Status changed from Feedback to Resolved

Seems to be after several ooo runs.

#9 Updated by sebchlad over 1 year ago

  • Project changed from openQA Tests to SUSE QA tests
  • Category deleted (Bugs in existing tests)
  • Target version changed from Current Sprint - kernel to Done - kernel&network

#10 Updated by okurz over 1 year ago

  • Project changed from SUSE QA tests to openQA Tests
  • Category set to Bugs in existing tests
  • Target version deleted (Done - kernel&network)

not quite sure why you still do this but moving the tickets into a private subproject will hide it and this makes a problem, especially for "openSUSE only" tickets. Did you consider using maybe the top-level public QA project?

#11 Updated by pcervinka over 1 year ago

To track work in particular team where the work was done.

#12 Updated by okurz over 1 year ago

That's what I assumed but I do not understand how you "track work" which would restrict you to a single project. As I suggested, why not use the top-level public QA project?

Also available in: Atom PDF