Project

General

Profile

action #38957

[functional] Refactor the openqa-review code to not use "Issue" object for the messages that does not have a valid bugref.

Added by oorlov about 2 years ago. Updated 7 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Enhancement to existing tests
Target version:
Start date:
2018-07-31
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

There is a case in openQA, when soft fail is raised, but it does not contain a valid bug reference ('bugref' is a ticket number on Bugzilla or Progress tracking systems, written in a format of #, e.g. bcs#12345, poo#12345).

In the past, those soft-fail messages did not appear in the report and even might broke the report generation, as invalid bugref might be found.

We've fixed this behavior in poo#35760 with some workarounds. According to dheidler, the message, that does not contain a valid bugref, should not be an Issue object, as the object was designed to represent an issue from bug tracker.

The task is to refactor the existing code in order to avoid using Issue object for the soft-fail messages, that does not contain a valid bugref.


Related issues

Related to openQA Tests - action #35760: [functional][u][medium] work on any issue from http://github.com/okurz/openqa_review/issues/Resolved2018-05-022018-07-31

History

#1 Updated by oorlov about 2 years ago

  • Related to action #35760: [functional][u][medium] work on any issue from http://github.com/okurz/openqa_review/issues/ added

#2 Updated by okurz about 2 years ago

  • Subject changed from [functional] Refactor the openqa-review code to not use "Issue" object for the messages that does not have a valid bugref. to [functional][u] Refactor the openqa-review code to not use "Issue" object for the messages that does not have a valid bugref.
  • Category set to Enhancement to existing tests
  • Target version set to Milestone 19

#3 Updated by okurz almost 2 years ago

  • Target version changed from Milestone 19 to future

#4 Updated by mgriessmeier 7 months ago

  • Subject changed from [functional][u] Refactor the openqa-review code to not use "Issue" object for the messages that does not have a valid bugref. to [functional] Refactor the openqa-review code to not use "Issue" object for the messages that does not have a valid bugref.
  • Assignee set to okurz

please check if this already done, nothing for u team though, since we don't use openqa_review anymore for manually generating report

#5 Updated by okurz 7 months ago

you rely on it for automatic reports though, right?

#6 Updated by okurz 7 months ago

  • Status changed from New to Rejected

I am a bit sad with what happened here. Someone added a feature and did it "hacky" style to finish the ticket early. Then as a response to #35760#note-25 this ticket was created to finish the task for good by including the relevant refactoring to not increase the technical dept. And now you don't want it to be followed up with. By now I myself have a very hard time to do a refactoring around this area as it is was mainly dheidler+oorlov et al. who introduced the code for the "Issue" object. Feels like the next time I will not give others the permission to merge in a repo that easily.

Also available in: Atom PDF