Project

General

Profile

coordination #38798

[functional][u][epic] Unaccounted ISOs on SP4

Added by coolo about 3 years ago. Updated 11 months ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
Infrastructure
Target version:
SUSE QA - Milestone 25
Start date:
2016-09-27
Due date:
2018-07-31
% Done:

100%

Estimated time:
(Total: 0.00 h)
Difficulty:

Description

Unaccounted ISOs:
iso/SLE-12-SP4-Server-DVD-x86_64-Build0292-Media2.iso

We had this problem before - and I thought we fixed it?


Subtasks

action #38804: [functional][u][fast] Make sure Media2 isos from SLE12SP4 are accounted for in ISO_* variables in any jobResolvedSLindoMansilla

action #15202: [functional][u] osd: A lot of assets are synced by rsync.pl which are never usedResolvedokurz

openQA Project - action #13938: Need to do something real about unregistered assetsResolvedcoolo

History

#1 Updated by okurz about 3 years ago

  • Subject changed from Unaccounted ISOs on SP4 to [functional] Unaccounted ISOs on SP4

It's called "regression" ;)

https://openqa.suse.de/tests/1853448#step/zypper_info/2 is a SLES12SP4 test which uses the FTP repo which AFAIK is extracted from the ISO. I don't know if we can delete the ISO afterwards – from rsync.pl. https://github.com/os-autoinst/os-autoinst-distri-opensuse/blob/master/lib/repo_tools.pm#L135 shows that we also use the ISO-medium but probably only on openSUSE

#2 Updated by coolo about 3 years ago

You don't need to remove it - just make sure it's accounted to the proper job group by adding it as ISO_9 in that test suite

#3 Updated by okurz about 3 years ago

Yes, but we do not need it. And I do not want this iso to be provided as an asset by the job so that everyone would need to download the ISO which is not used. I guess we have a similar problem for e.g. s390x ISO media which are never directly used. Any idea to that?

#4 Updated by coolo about 3 years ago

Then create a dummy test you attach this ISO to, but we can't sync X*7G unaccounted ISOs stalling for weeks. If you prefer to delete them after sync, fine with me - but do something.

#6 Updated by okurz about 3 years ago

  • Subject changed from [functional] Unaccounted ISOs on SP4 to [functional][u] Unaccounted ISOs on SP4
  • Status changed from New to In Progress
  • Assignee set to okurz
  • Target version set to Milestone 18

ok, let's bring the team on it.

#7 Updated by okurz about 3 years ago

  • Due date changed from 2018-07-31 to 2018-08-14

due to changes in a related task

#8 Updated by okurz about 3 years ago

  • Status changed from In Progress to Blocked

-> subtickets

#9 Updated by okurz about 3 years ago

bulk move to next sprint as could not be discussed in SR

#10 Updated by okurz about 3 years ago

  • Due date changed from 2018-08-14 to 2018-08-28

due to changes in a related task

#11 Updated by mgriessmeier about 3 years ago

  • Due date changed from 2018-08-28 to 2018-09-11

due to changes in a related task

#12 Updated by mgriessmeier about 3 years ago

  • Due date changed from 2018-09-11 to 2018-09-25

due to changes in a related task

#13 Updated by SLindoMansilla almost 3 years ago

  • Due date changed from 2018-09-25 to 2018-10-09

due to changes in a related task

#14 Updated by SLindoMansilla almost 3 years ago

  • Due date changed from 2018-10-09 to 2018-10-23

due to changes in a related task

#15 Updated by okurz almost 3 years ago

  • Target version changed from Milestone 18 to Milestone 25

#16 Updated by SLindoMansilla almost 3 years ago

  • Subject changed from [functional][u] Unaccounted ISOs on SP4 to [functional][u][epic] Unaccounted ISOs on SP4

#17 Updated by okurz almost 3 years ago

  • Due date changed from 2018-10-23 to 2018-07-31

due to changes in a related task

#18 Updated by okurz over 2 years ago

  • Status changed from Blocked to Resolved

Crosschecked https://openqa.suse.de/admin/assets for Untracked, found some HA builds, noticed ldevulder in #testing about it but SP4 seems good.

#19 Updated by szarate 11 months ago

  • Tracker changed from action to coordination

Also available in: Atom PDF