Project

General

Profile

action #38606

proceed_on_failure option in script_output is broken

Added by szarate almost 2 years ago. Updated about 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2018-07-19
Due date:
% Done:

0%

Estimated time:
Difficulty:
Duration:

Description

apparently calling script_output('blah', proceed_on_failure => 1); ends up in the following:

[2018-07-19T13:50:15.0373 CEST] [debug] <<< testapi::wait_serial(regexp='SCRIPT_FINISHED25dbl-\\d+-', record_output=1, timeout='proceed_on_failure')
Argument "proceed_on_failure" isn't numeric in multiplication (*) at /usr/lib/os-autoinst/bmwqemu.pm line 316.

https://github.com/os-autoinst/os-autoinst/pull/954

Argument "proceed_on_failure" isn't numeric in multiplication (*) at /usr/lib/os-autoinst/bmwqemu.pm line 316.

History

#1 Updated by asmorodskyi almost 2 years ago

I found root cause, it is really simple to fix the issue :
you need just call function in documented way - script_output('blah',30 , proceed_on_failure => 1);

#2 Updated by mkittler over 1 year ago

So the issue can be considered resolved/rejected?

#3 Updated by okurz over 1 year ago

  • Status changed from New to Rejected
  • Assignee set to okurz

yes, the "wait" parameter is simply a mandatory one. We can't fix perl's crazy approach of function parameter validation ;)

#4 Updated by coolo about 1 year ago

  • Target version changed from Ready to Done

Also available in: Atom PDF