Project

General

Profile

action #38393

action #17436: [tools][functional][y][epic] tests must not have access to published repos, e.g. download.o.o on Tumbleweed -> remove all references to download.o.o from repos during installation and afterwards

[functional][u] updates_packagekit_kde must not be scheduled before zypper_clear_repos

Added by okurz about 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA tests - Milestone 18
Start date:
2018-07-13
Due date:
2018-08-14
% Done:

0%

Estimated time:
3.00 h
Difficulty:
Duration: 23

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-kde@64bit fails in
updates_packagekit_kde

[13 Jul 2018 10:54:11] <DimStar> meh - https://openqa.opensuse.org/tests/706341#step/updates_packagekit_kde/9 - again download.o.o interfering with our tests
[…]
[13 Jul 2018 15:21:52] <okurz> DimStar: regarding https://openqa.opensuse.org/tests/706341#step/updates_packagekit_kde/9 I do not know, how the test should behave. I guess it should follow the recommendation and call zypper dup, isn't it?
[13 Jul 2018 15:22:18] <DimStar> okurz: well, IF there were no invalid repo setup, the problem would not exist to start with
…
[13 Jul 2018 15:23:09] <DimStar> okurz: the issue is (once again) that we test snapshot n+1 and have the repos of download.o.o enabled (which means we don't test what we want to publish nexT)
[13 Jul 2018 15:25:07] <okurz> DimStar: so then zypper_clear_repos should be scheduled before updates_packagekit_kde?
[13 Jul 2018 15:27:21] <DimStar> okurz: or before prepare_sysem_for_updaetes is probably even better
[13 Jul 2018 15:27:30] <okurz> yes, sure

Reproducible

Fails since (at least) Build 20180712

Expected result

Last good: 20180710 (or more recent)

Suggestions

  • Talk to riafarov about the epic
  • Decide if (1) zypper_clear_repos should be scheduled earlier, if (2) updates_packagekit_kde should be scheduled later or (3) something else :)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #31954: [functional][y][medium]harmonize updating handling in openSUSE/SLE scheduleResolved2018-02-192018-10-09

Blocks openQA Tests - action #36313: [sle][opensuse][qam] enhance update_packagekit testsWorkable2017-12-05

History

#1 Updated by okurz about 2 years ago

  • Subject changed from updates_packagekit_kde must not be scheduled before zypper_clear_repos to [functional][u] updates_packagekit_kde must not be scheduled before zypper_clear_repos
  • Description updated (diff)
  • Due date set to 2018-08-28
  • Target version set to Milestone 18

#2 Updated by okurz about 2 years ago

  • Related to action #31954: [functional][y][medium]harmonize updating handling in openSUSE/SLE schedule added

#3 Updated by okurz about 2 years ago

  • Priority changed from Normal to High

openSUSE Leap 15.1 is greatly affected by this, e.g. see https://openqa.opensuse.org/tests/709342#step/consoletest_setup/29

#4 Updated by dheidler about 2 years ago

  • Status changed from New to In Progress
  • Assignee set to dheidler

#5 Updated by dheidler about 2 years ago

  • Due date changed from 2018-08-28 to 2018-08-14

#6 Updated by mgriessmeier about 2 years ago

  • Blocks action #36313: [sle][opensuse][qam] enhance update_packagekit tests added

#7 Updated by mgriessmeier about 2 years ago

  • Estimated time set to 3.00 h

#8 Updated by dheidler about 2 years ago

  • Status changed from In Progress to Resolved

PR merged.

#9 Updated by dheidler about 2 years ago

  • Status changed from Resolved to In Progress

needs some more tweaking

#12 Updated by dheidler about 2 years ago

  • Status changed from In Progress to Resolved

Verification runs are looking good.

#13 Updated by yuanren10 almost 2 years ago

Here is a test case "libreoffice_mainmenu_components" in "qam-regression-documentation" testsuite. The libreoffice-base is not installed by default on Tumbleweed. And this rpm not included in local iso repo. But the "download.opensuse.org" repo has been cleared in zypper_clear_repos.
So, I can't download the libreoffice-base result in I can't test "libreoffice_mainmenu_components".

Please reference:
create_hdd_gnome
qam-regression-documentation

Also available in: Atom PDF