Project

General

Profile

action #36333

[opensuse][y][medium] Invalid repositories - failing kate install

Added by dimstar about 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Start date:
2018-05-17
Due date:
2018-06-05
% Done:

0%

Estimated time:
Difficulty:
Duration: 14

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-update_Leap_42.1_kde@64bit fails in
zypper_lr

Reproducible

Fails since (at least) Build 20180516

Expected result

Last good: 20180515 (or more recent)

Further details

Always latest result in this scenario: latest

Analysis

the kate test in this run fails as it wants to install kate (18.04.1, highest version), which in turn requires kate-plugins to be of the same version. The test though has the DVD enabled plus the download.o.o repositories, which is an invalid test setup and fails in this scenario.

The test would need the openqa-mirrored repository, not download.o.o


Related issues

Related to openQA Tests - action #32038: [opensuse][functional][medium] Sync all repos for TW and Leap for all tested versionsResolved2018-02-202018-04-24

Copied to openQA Tests - action #36829: [opensuse][y][medium] repositories not added/added twice - failing in scenarios zdup_tw2twnext_gnome and cryptlvmResolved2018-05-172018-06-19

History

#1 Updated by okurz about 2 years ago

  • Subject changed from Invalid repositories - failing kate install to [opensuse][y] Invalid repositories - failing kate install
  • Due date set to 2018-06-05
  • Target version set to Milestone 16

riafarov sounds closely related to what mainly you lead along. If you think it's easy, take it for sooner.

#2 Updated by riafarov about 2 years ago

  • Status changed from New to Workable

Looks like some dependency was not available, this scenario uses official openSUSE repos and not mirrors, as it's update scenario. So, we need to enable repos replacement here, which we have introduced on purpose: https://github.com/os-autoinst/os-autoinst-distri-opensuse/blob/master/lib/main_common.pm#L266

This failure shows that we should reconsider condition.

#3 Updated by SLindoMansilla about 2 years ago

  • Subject changed from [opensuse][y] Invalid repositories - failing kate install to [opensuse][y][medium] Invalid repositories - failing kate install

#4 Updated by JERiveraMoya about 2 years ago

  • Assignee set to JERiveraMoya

#5 Updated by riafarov about 2 years ago

  • Related to action #32038: [opensuse][functional][medium] Sync all repos for TW and Leap for all tested versions added

#6 Updated by JERiveraMoya about 2 years ago

  • Status changed from Workable to In Progress

#7 Updated by JERiveraMoya almost 2 years ago

  • Status changed from In Progress to Feedback

#8 Updated by JERiveraMoya almost 2 years ago

  • Status changed from Feedback to Resolved

According latest TW build (searching for jobs containing 'update'), the change seems to be ok, for instance, kate

#9 Updated by JERiveraMoya almost 2 years ago

  • Copied to action #36829: [opensuse][y][medium] repositories not added/added twice - failing in scenarios zdup_tw2twnext_gnome and cryptlvm added

Also available in: Atom PDF