Project

General

Profile

action #35890

[functional][y][easy] test fails in addon_products_sle - matching on non-active addon selection when it should not

Added by okurz about 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Start date:
2018-05-04
Due date:
2018-06-05
% Done:

0%

Estimated time:
Difficulty:
Duration: 23

Description

Observation

openQA test in scenario sle-15-Installer-DVD-x86_64-addon-module-http@64bit fails in
addon_products_sle
matching the needle addon-menu-active-2-20180220 created by

commit e0ba6843
Author: Stephan Kulow <coolo@suse.com>
Date:   Tue Feb 20 08:17:57 2018 +0100

    addon-menu-active-2-20180220 for sle-15-Installer-DVD-Staging:F-x86_64-BuildF.372.1-cryptlvm_minimal_x@64bit-staging

diff --git a/addon-menu-active-2-20180220.json b/addon-menu-active-2-20180220.json
new file mode 100644
index 00000000..90980310
--- /dev/null
+++ b/addon-menu-active-2-20180220.json
@@ -0,0 +1,16 @@
+{^M
+  "properties": [],^M
+  "tags": [^M
+    "ENV-SP2ORLATER-1",^M
+    "addon-menu-active"^M
+  ],^M
+  "area": [^M
+    {^M
+      "ypos": 348,^M
+      "height": 27,^M
+      "type": "match",^M
+      "xpos": 494,^M
+      "width": 11^M
+    }^M
+  ]^M
+}
\ No newline at end of file

which should not match. My proposal is to bump the "matching level"

As per coolo's comment, bumping matching level won't help as it's already 100%.
We should rather create needles, so we assert that checkbox is checked: see addon-menu-active-2-20180220 vs addon-menu-active-20180220 in https://openqa.suse.de/tests/1667144#step/addon_products_sle/6

Hence, removing needle which matches radio buttons only.

Hint

Use https://openqa.suse.de/admin/needles to find out if some needle is in use, so removal of wrong needles doesn't break existing scenarios.

Reproducible

Fails since (at least) Build 597.2 (current job)

Expected result

Last good: 594.1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by coolo about 2 years ago

It matches 100% - how high do you want to go?

#2 Updated by coolo about 2 years ago

  • Assignee deleted (coolo)

#3 Updated by okurz about 2 years ago

  • Description updated (diff)

#4 Updated by okurz about 2 years ago

  • Subject changed from test fails in addon_products_sle - matching on non-active addon selection when it should not to [functional][y] test fails in addon_products_sle - matching on non-active addon selection when it should not
  • Due date set to 2018-06-05
  • Target version set to Milestone 16

should not be too hard.

#5 Updated by riafarov about 2 years ago

  • Description updated (diff)
  • Status changed from New to Workable

#6 Updated by riafarov about 2 years ago

  • Description updated (diff)

#7 Updated by SLindoMansilla about 2 years ago

  • Subject changed from [functional][y] test fails in addon_products_sle - matching on non-active addon selection when it should not to [functional][y][easy] test fails in addon_products_sle - matching on non-active addon selection when it should not

#8 Updated by zluo about 2 years ago

  • Assignee set to zluo

take over

#10 Updated by zluo about 2 years ago

  • Status changed from Workable to In Progress

#11 Updated by riafarov almost 2 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF