Project

General

Profile

action #35883

[functional][u] test fails in php7_postgresql96

Added by JWSun about 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA tests - Milestone 17
Start date:
2018-05-04
Due date:
2018-06-19
% Done:

100%

Estimated time:
Difficulty:
Duration: 33

Description

Observation

openQA test in scenario sle-15-Installer-DVD-s390x-proxyscc_upgrade_sles12sp3+alladdons_s390x@s390x-kvm-sle12 fails in
php7_postgresql96

Reproducible

Fails since (at least) Build 489.2

Expected result

A version agnostic test of the test module should be scheduled instead.

Further details

Always latest result in this scenario: latest

From the bug 1091769 https://bugzilla.suse.com/show_bug.cgi?id=1091769#c1

PostgreSQL 9.6 has been replaced by PostgreSQL 10 in SLES15, we need update our test code such as
zypper_call 'in postgresql10-* sudo';


Related issues

Related to openQA Tests - action #33985: [sle][functional][u][medium]functional tests covering php from the "web & scripting" moduleResolved2015-11-112018-08-28

History

#1 Updated by maritawerner about 2 years ago

I think that is a duplicate of:

https://progress.opensuse.org/issues/33985

#2 Updated by okurz about 2 years ago

  • Related to action #33985: [sle][functional][u][medium]functional tests covering php from the "web & scripting" module added

#3 Updated by okurz about 2 years ago

  • Subject changed from [functional] test fails in php7_postgresql96 to [functional][u] test fails in php7_postgresql96
  • Description updated (diff)
  • Due date set to 2018-06-19
  • Status changed from New to Workable
  • Priority changed from Normal to High
  • Target version set to Milestone 17

Certainly at least related. I plan to have this fixed in sprint 19, that is before 2018-06-19. Feel free to plan to fix it within the migration team before that date.

#4 Updated by JWSun about 2 years ago

  • Assignee set to JWSun

I will take care of it.

#5 Updated by JWSun about 2 years ago

  • Status changed from Workable to In Progress
  • % Done changed from 0 to 50

#6 Updated by okurz almost 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: scc_upgrade_sles12sp3+allmodules_x86_64_
https://openqa.suse.de/tests/1673340

#7 Updated by mgriessmeier almost 2 years ago

your PR got merged some time ago - what's the status here?
Did you check recent testresults?

#8 Updated by JWSun almost 2 years ago

  • % Done changed from 50 to 100

mgriessmeier wrote:

your PR got merged some time ago - what's the status here?
Did you check recent testresults?

Test result has passed with latest build.

https://openqa.suse.de/tests/1743761#step/php7_postgresql96/1

But there is an enhancement require here - postgresql version can be chosen with different product.
I will open a new ticket for it

#9 Updated by JWSun almost 2 years ago

  • Status changed from In Progress to Resolved

#10 Updated by okurz almost 2 years ago

  • Target version changed from Milestone 17 to Milestone 17

Also available in: Atom PDF