Project

General

Profile

action #35140

Parallel job don't see mutex of sibling

Added by asmorodskyi over 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Concrete Bugs
Target version:
-
Start date:
2018-04-18
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

  1. Create 3 jobs - master and slave tests and supportserver for them
  2. define a PARALLEL_WITH as suggested in https://github.com/os-autoinst/openQA/blob/master/docs/WritingTests.asciidoc master and slave has PARALLEL_WITH=supportserver , supportserver don't have PARALLEL_WITH

==> during execution jobs slave would stuck on waiting for mutex from master , which master already successfully pass

Example :
https://openqa.suse.de/tests/1627328
https://openqa.suse.de/tests/1627329
https://openqa.suse.de/tests/1627327

Note: I will revert PARALLEL_WITH setup to one which stated by tools team as "wrong" (see https://progress.opensuse.org/issues/32545) since this one generally works just fails sporadically from time to time. So you can't reproduce issue by just re-trigger jobs on osd


Related issues

Related to openQA Project - action #32545: Provide warning when user creates/triggers misconfigured multi-machine clustersResolved2018-02-28

History

#1 Updated by asmorodskyi over 3 years ago

  • Related to action #32545: Provide warning when user creates/triggers misconfigured multi-machine clusters added

#2 Updated by asmorodskyi over 3 years ago

  • Project changed from SUSE QA to openQA Project

move to correct project

#3 Updated by mkravec over 3 years ago

asmorodskyi:
Documentation talks about mutexes on parents/children. Siblings are not mentioned anywhere ;)
Jobs can lock mutexes owned by siblings if you provide mutex owner (jobid) when calling mutex_lock.

Sibling unlocking is not implemented yet, should be fixed by those:
https://github.com/os-autoinst/os-autoinst/pull/969
https://github.com/os-autoinst/openQA/pull/1677

#4 Updated by okurz over 2 years ago

  • Category set to Concrete Bugs

#5 Updated by mkravec over 2 years ago

  • Status changed from New to Resolved
  • Assignee set to mkravec

Also available in: Atom PDF