Project

General

Profile

action #34837

[sle12][functional][u][s390x-kvm] test fails in consoletest_finish while switching from console to GUI desktop, stuck on black screen

Added by oorlov about 2 years ago. Updated almost 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Start date:
2018-04-12
Due date:
2018-06-05
% Done:

0%

Estimated time:
Difficulty:
Duration: 39

Description

Observation

openQA test in scenario sle-12-SP4-Server-DVD-s390x-allpatterns@zkvm fails in
consoletest_finish

Reproducible

Fails since (at least) Build 0234

The test fails while going from console to GUI desktop. Happened only on s390x and it is the first occurrence.
Not sure if it is a test issue or an app issue. Need investigation.

Expected result

Last good: 0233 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Is duplicate of openQA Tests - action #36268: [sle][functional][u][hard][s390x] test fails in consoletest_finish - screen does not show desktop sessionResolved2018-05-162018-09-11

History

#1 Updated by oorlov about 2 years ago

  • Subject changed from test fails in consoletest_finish to [sle12][functional]test fails in consoletest_finish

#2 Updated by oorlov about 2 years ago

  • Subject changed from [sle12][functional]test fails in consoletest_finish to [sle12][functional]test fails in consoletest_finish while switching from console to GUI desktop

#3 Updated by okurz about 2 years ago

  • Related to action #34003: [tools] Better logging and error handling in case of remote console connections in consoles or backends, e.g. ssh added

#4 Updated by okurz about 2 years ago

  • Subject changed from [sle12][functional]test fails in consoletest_finish while switching from console to GUI desktop to [sle12][functional][u][s390x-kvm] test fails in consoletest_finish while switching from console to GUI desktop, stuck on black screen
  • Due date set to 2018-05-22
  • Target version set to Milestone 16

Hi oorlov, thanks for the review. Suggestions for improvement in the ticket itself:

  • It's about switching consoles so not related to YaST and therefore a clear candidate for '[u]'. You can add the tag yourself.
  • If you see something "only failing on " then please also add this to the subject line so that we have a hint that most likely it is backend specific. You know, like for all the hyperv issues which we can already recognize in the subject line :)
[2018-04-04T18:11:11.0042 CEST] [debug] /var/lib/openqa/cache/tests/sle/tests/console/consoletest_finish.pm:43 called testapi::select_console
[2018-04-04T18:11:11.0043 CEST] [debug] <<< testapi::select_console(testapi_console='x11', await_console=0)

Is the code that should switch to the grapical mode but here AFAIK it involves switching to a vncviewer window which might be gone so another case where #34003 should help.

#5 Updated by oorlov about 2 years ago

  • Status changed from New to Blocked
  • Assignee set to mloviska

Blocked by #34003

#6 Updated by okurz about 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: lvm-encrypt-separate-boot
https://openqa.suse.de/tests/1706792

#7 Updated by mgriessmeier about 2 years ago

  • Due date changed from 2018-05-22 to 2018-06-05

#8 Updated by oorlov about 2 years ago

  • Related to action #36268: [sle][functional][u][hard][s390x] test fails in consoletest_finish - screen does not show desktop session added

#9 Updated by oorlov about 2 years ago

  • Status changed from Blocked to Rejected

Seems like the same issue as #36268.

mloviska, can we close this ticket as duplication of #36268? Though #36268 is appeared later, but it is added to the current sprint.

#10 Updated by oorlov about 2 years ago

  • Related to deleted (action #34003: [tools] Better logging and error handling in case of remote console connections in consoles or backends, e.g. ssh)

#11 Updated by oorlov about 2 years ago

  • Related to deleted (action #36268: [sle][functional][u][hard][s390x] test fails in consoletest_finish - screen does not show desktop session)

#12 Updated by oorlov about 2 years ago

  • Is duplicate of action #36268: [sle][functional][u][hard][s390x] test fails in consoletest_finish - screen does not show desktop session added

#13 Updated by mloviska about 2 years ago

oorlov I am not really sure why I am assigned for this ticket. I cannot recall that I would work on this issue.

#14 Updated by okurz about 2 years ago

  • Is duplicate of deleted (action #36268: [sle][functional][u][hard][s390x] test fails in consoletest_finish - screen does not show desktop session)

#15 Updated by okurz about 2 years ago

  • Is duplicate of action #36268: [sle][functional][u][hard][s390x] test fails in consoletest_finish - screen does not show desktop session added

#16 Updated by okurz about 2 years ago

mloviska wrote:

oorlov I am not really sure why I am assigned for this ticket. I cannot recall that I would work on this issue.

See #34837#note-5 and its timestamp. It happened during a refinement meeting so I assume we decided within that meeting - hopefully when you were there - that you can track the blocking ticket.

#17 Updated by mloviska about 2 years ago

Alright, I will track it.

#18 Updated by okurz almost 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: lvm-encrypt-separate-boot
https://openqa.suse.de/tests/1754797

Also available in: Atom PDF