Project

General

Profile

action #34381

[functional][opensuse][u][fast] live_installation: 'full screen' often not happening

Added by dimstar over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 17
Start date:
2018-04-05
Due date:
2018-05-08
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-KDE-Live-x86_64-kde-live_installation@64bit fails in
live_installation

Reproducible

Fails since (at least) Build 20180404

Expected result

Last good: 20180403 (or more recent)

Further details

Always latest result in this scenario: latest

This is after 'more/full screen' was selected in the menu, a dialog should show up about the fact. Very often, this does not show up (sometimes it works, then the installation succeeds)

History

#1 Updated by okurz over 4 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: kde-live_installation
https://openqa.opensuse.org/tests/658981

#2 Updated by okurz over 4 years ago

  • Subject changed from live_installation: 'full screen' often not happening to [functional][opensuse]ly] live_installation: 'full screen' often not happening
  • Due date set to 2018-07-03
  • Status changed from New to Workable
  • Target version set to Milestone 17

#3 Updated by favogt over 4 years ago

  • Status changed from Workable to Feedback
  • % Done changed from 0 to 100

#4 Updated by okurz over 4 years ago

  • Subject changed from [functional][opensuse]ly] live_installation: 'full screen' often not happening to [functional][opensuse][u][fast] live_installation: 'full screen' often not happening
  • Due date changed from 2018-07-03 to 2018-05-08
  • Assignee set to oorlov
  • Priority changed from Normal to Urgent

[7 May 2018 15:22:20] okurz: https://github.com/os-autoinst/os-autoinst-distri-opensuse/commit/ec9075c2f79233a9371d748bf9e6a045dbda1078#diff-abb2ee997e1cfb62a4ec3d70f4adf2e0 doesn't seem to work: https://openqa.opensuse.org/tests/670982
[7 May 2018 15:22:56] fvogt: thanks! I was just trying to look into what commit broke that :P
[7 May 2018 16:09:13] checking…
[7 May 2018 16:11:04] fvogt, DimStar: have you understood why it worked in the verification run then?
[7 May 2018 16:20:46] okurz: the entire script seems different: 571067 has await_install, logs_from…., reboot_aftern_install, grub_test, and your test run (which was krypton, not TW) has start_install, install_and_reboot, grub-test
[7 May 2018 16:21:38] sure, since then we split install_and_reboot
[7 May 2018 16:22:35] waaait, oorlov broke it with 81869ac4
[7 May 2018 16:23:43] okurz, yes, right now I want to change
[7 May 2018 16:23:44] and that seemed not to help cases like https://openqa.opensuse.org/tests/671084#step/shutdown/16 - where shutdown still did not succeed
[7 May 2018 16:24:04] I pasted the if('LIVECD') to the wrong place
[7 May 2018 16:24:08] serial claims: [ 1398.749883] reboot: Power down

#5 Updated by mgriessmeier over 4 years ago

  • Status changed from Feedback to Resolved

#6 Updated by okurz over 4 years ago

  • Target version changed from Milestone 17 to Milestone 17

Also available in: Atom PDF