Project

General

Profile

action #33946

Iso image of Parent Job is downloaded even if "--skip-deps" property is specified while cloning Child Job

Added by oorlov over 2 years ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
Start date:
2018-03-28
Due date:
2019-11-12
% Done:

0%

Estimated time:
Difficulty:
Duration: 425

Description

Steps to reproduce:

  1. Start cloning any Job that is linked to Parent one with "--skip-deps" property (e.g. wicked_basic: OpenSUSE Tumbleweed > {build_number} > wicked_basic );
  2. Wait until the cloning process will be finished;
  3. Focus on the output in Terminal and check what the files were downloaded.

Expected result:
Only ".qcow2" image is downloading.
Actual result:
Both ".iso" and ".qcow2" images are downloaded, though ".iso" is not required for starting Child Job, as an appropriate ".qcow2" image contains all the required data.

Please, see the screenshot for more details.
screenshot

NOTE: The same issue is reproduced while cloning Child Job with the "--skip-chained-deps".


Related issues

Related to openQA Project - action #34783: Don't let jobs incomplete if mandatory resources are missingResolved2018-04-12

Copied to openQA Tests - action #59394: [functional][u] Overwrite empty ISO variable everywhere where not needed, i.e. `+ISO=`, to prevent useless ISO downloading and storageWorkable2019-11-13

Copied to openQA Project - action #59397: Make openQA less "iso" centricNew2019-11-13

History

#1 Updated by okurz about 2 years ago

  • Related to action #34783: Don't let jobs incomplete if mandatory resources are missing added

#2 Updated by okurz about 1 year ago

  • Category set to Feature requests

#3 Updated by okurz 8 months ago

  • Due date set to 2019-11-12
  • Status changed from New to Feedback
  • Assignee set to okurz
  • Target version set to Current Sprint

The ISO image is downloaded because it also belongs to the child job, e.g. take a look on the extra_tests_in_textmode scenario that boots a qcow image provided by a parent but the settings specify both ISO and HDD. Having the ISO also does make a difference, e.g. it might be configured to be used as a repo source within openSUSE/SLE. What we can try to do is to override the ISO with ISO= when we do not need it. Or should be try to automatically delete ISO when HDD is specified? Then we would need to still foresee a way to specify an ISO if one really wants to. I favor the first option. Let me see if we can already override ISO in the test settings in https://openqa.opensuse.org/tests/latest?arch=x86_64&distri=opensuse&flavor=DVD&machine=64bit&test=yast2_ui_devel&version=Tumbleweed which is in "Development: Tumbleweed" anyway. So I added ISO= in "yast2_ui_devel" in https://openqa.opensuse.org/admin/test_suites and will wait for the next TW snapshot.

EDIT: https://openqa.opensuse.org/tests/1077392#settings still shows the ISO. I assume we need to overwrite with +ISO=. Done that, waiting for next build.

EDIT: 2019-11-13: yast2_ui_devel is nearly never triggered as it relies on yast2_ncurses. Trying with different scenario

openqa-clone-job --skip-chained-deps --within-instance https://openqa.opensuse.org 1083960 _GROUP=0 BUILD= TEST=okurz_poo33946_gnuhealth ISO=

Created job #1084352: opensuse-Tumbleweed-DVD-x86_64-Build20191112-gnuhealth@64bit -> https://openqa.opensuse.org/t1084352

The job passed and cloning that one does only trigger a download of the needed qcow image, no ISO image. I made that change live now on the test suite "gnuhealth".

#4 Updated by okurz 8 months ago

  • Copied to action #59394: [functional][u] Overwrite empty ISO variable everywhere where not needed, i.e. `+ISO=`, to prevent useless ISO downloading and storage added

#5 Updated by okurz 8 months ago

#6 Updated by okurz 8 months ago

  • Status changed from Feedback to Resolved

So I see two independant ways how to continue:

  • Somehow make an empty ISO variable the default when an HDD is used -> #59397
  • Specify +ISO= on all test suites that do not need the ISO -> #59394

Also available in: Atom PDF