action #33274

[functional][y] Reproduce bsc#1017558 "Cannot view timestamp of read-only snapshots in GRUB as names truncated"

Added by okurz almost 2 years ago. Updated 7 months ago.

Status:ResolvedStart date:14/03/2018
Priority:LowDue date:
Assignee:riafarov% Done:

0%

Category:New testEstimated time:3.00 hours
Target version:QA - future
Difficulty:
Duration:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-boot_to_snapshot@64bit in
grub_test does not show the boot menu entries but we would like to see them to be able to reproduce bsc#1017558

Tasks

  • DONE: Show screens with save_screenshot
  • Reproduce bsc#1017558 with automatic test
  • Optional: Convert save_screenshot to assert_screen and add bug detection tracker needle with workaround property pointing to bug
  • Motivate work on bug when we can confirm it on SLE as well

Further details

Always latest result in this scenario: latest

tw_snapshots.png (9.68 KB) mloviska, 18/07/2018 03:13 pm

scrn.png (8.51 KB) mloviska, 18/07/2018 03:13 pm

scrn_after_install.png (8.71 KB) mloviska, 18/07/2018 03:13 pm

6482
6485
6488

History

#2 Updated by okurz almost 2 years ago

  • Description updated (diff)

#3 Updated by okurz almost 2 years ago

PR merged, https://openqa.opensuse.org/tests/634073 triggered to check the screenshots

#4 Updated by okurz almost 2 years ago

https://openqa.opensuse.org/tests/634077#step/grub_test/6 shows the situation on openSUSE Tumbleweed, the text is clearly truncated but obviously there is more unused screen space available.

https://openqa.suse.de/tests/1543487 scheduled for SLE15

#5 Updated by okurz almost 2 years ago

Actually we are lucky for SLE because it's abbreviated "SLES15" so the whole string matches on the available space: https://openqa.suse.de/tests/1543487#step/grub_test/6

#6 Updated by okurz almost 2 years ago

  • Description updated (diff)
  • Category changed from Bugs in existing tests to New test
  • Status changed from In Progress to Workable
  • Assignee deleted (okurz)

First step is done, next steps can be conducted as mentioned in the description.

#7 Updated by okurz almost 2 years ago

  • Due date deleted (08/05/2018)
  • Target version changed from Milestone 16 to Milestone 17

ok, can wait a bit longer, S16 is full.

#8 Updated by okurz over 1 year ago

  • Subject changed from [functional][u]Reproduce bsc#1017558 "Cannot view timestamp of read-only snapshots in GRUB as names truncated" to [functional][y] Reproduce bsc#1017558 "Cannot view timestamp of read-only snapshots in GRUB as names truncated"
  • Due date set to 17/07/2018

#9 Updated by okurz over 1 year ago

  • Target version changed from Milestone 17 to Milestone 17

#10 Updated by okurz over 1 year ago

  • Target version changed from Milestone 17 to Milestone 18

#11 Updated by okurz over 1 year ago

  • Due date changed from 17/07/2018 to 31/07/2018

It's hackweek time!

#12 Updated by riafarov over 1 year ago

  • Estimated time set to 3.00

#14 Updated by mloviska over 1 year ago

Timestamps are present in Build20180713.

#15 Updated by okurz over 1 year ago

Hm, looking at the latest Tumbleweed test https://openqa.opensuse.org/tests/7088820 I can find that the snapshot names are actually not displayed as screenshots within openQA. It looks like the whole menu of snapshots is not there.

@mloviska I wonder how did you generate the screenshots and why? The screenshots should be recorded by openQA. And just for clarification: The original bug – see the subject line – is not about the timestamps not being visible at all but truncated, i.e. they are not fully visible because they are cut from the right side. This is not a problem for SLE as noted in #33274#note-5 but only for openSUSE.

#16 Updated by mloviska over 1 year ago

@okurz, manual test. As long as there is only 1 snapshot, sublist is not displayed.

#17 Updated by okurz over 1 year ago

ah, I see. So even that behaviour changed. https://openqa.opensuse.org/tests/634077#step/grub_test/6 showed the situation – including the bug – from 4 months ago, mentioned in #33274#note-4

#18 Updated by mloviska over 1 year ago

We can reproduce the issue on Leap 15.1. Since issue is not touching SLE and TW has changed its behavior, I am not really sure what should be our next step with this ticket.

#19 Updated by okurz over 1 year ago

As recommended in the ticket description I would go for making https://openqa.opensuse.org/tests/715084#step/grub_test/6 a check which we can then soft-fail referencing the bug. It should be enough to have this issue on openSUSE Leap but to further motivate, maybe we can find a SLE product where this happens as well, but just not SLES itself. Maybe "SLES for SAP" is longer?

#20 Updated by mloviska over 1 year ago

  • Status changed from Workable to Feedback

#21 Updated by riafarov over 1 year ago

  • Due date changed from 31/07/2018 to 14/08/2018

#22 Updated by riafarov over 1 year ago

https://openqa.opensuse.org/tests/717024#step/grub_test/6
@okurz, please review, if you're fine with resolving it.

#23 Updated by okurz over 1 year ago

yes, nice. So my one concern did not turn into reality ;) Please see about the other (two?) points though

#24 Updated by mloviska over 1 year ago

I am not really convinced that we are talking about recent builds only, since the behavior changes have been recorded in openQA for few months https://openqa.opensuse.org/tests/677094#step/grub_test/5.
The second point, it would be nice to recognize some string which is enclosed in brackets by a needle. According to the bug, grub can display only limited amount of characters in certain resolution. The same issue was with leap 15.0 GM, thus when this bug is going to be resolved fix, we can just easily remove current workaround.

#25 Updated by okurz over 1 year ago

What workaround do you mean, the record_soft_failure?

Could you please also relate to my comment Nr. 19

#26 Updated by mloviska over 1 year ago

  • Status changed from Feedback to Resolved

Feel free to create a separate ticket for other sles products. :)

#27 Updated by okurz over 1 year ago

  • Status changed from Resolved to Feedback

No, this is not how it works. I repeatedly tell that I if people prefer to close off tickets and continue the work in new tickets I consider this useless additional buerocrazy but I will go with it. However, accepting that we just do parts of what has been noted down and openly ignoring open points which have been stated already in the initial description – so no scope creep – I consider as not nice. Again: Feel free to keep the ticket open, unassign or clone into a new ticket but please do not just call it as resolved when we state that it is not. Feel free to bring it up again in the next retro or with your SM as well.

#28 Updated by mloviska over 1 year ago

  • Assignee deleted (mloviska)

Initial description does not states anything regarding other SLE products (SAP etc.) as well as there are not in functional openQA group.

#29 Updated by riafarov over 1 year ago

  • Status changed from Feedback to Workable

#30 Updated by riafarov over 1 year ago

  • Assignee set to riafarov

#31 Updated by riafarov over 1 year ago

  • Status changed from Workable to Resolved

@okurz I believe that it's overkill to detect truncated snapshot name with needle, so, I've commented that we have same issue on SLE 12 SP4, provided screenshot. If you still believe it's not enough and would like to have precise check of bug existence, I will escalate this issue as I don't see anything to be done here except parts which are already done, and I strongly believe that we don't have resources for such unimportant issues. Feel free to re-open.

#32 Updated by okurz over 1 year ago

  • Status changed from Resolved to Feedback
  • Assignee changed from riafarov to okurz

I really would like to understand better why you urge to keep it closed. Is it OK for you to keep it assigned to myself then until we can clarify how I can improve the description, how another ticket can track it better or what we should do? The bug is important to me and openQA is a very feasible way to show it hence this issue

#33 Updated by riafarov over 1 year ago

okurz wrote:

I really would like to understand better why you urge to keep it closed. Is it OK for you to keep it assigned to myself then until we can clarify how I can improve the description, how another ticket can track it better or what we should do? The bug is important to me and openQA is a very feasible way to show it hence this issue

I guess that's the main issue here, as you have mentioned that it's important for you. I guess we should discuss how far we should get, but I don't believe that bugs get self-resolved, so sending automated 'up' comments do not help here imho. So, let's discuss in more details, as it's a good topic and if we would add soft-failures to all existing bugs then.

#34 Updated by riafarov over 1 year ago

  • Due date deleted (14/08/2018)
  • Target version changed from Milestone 18 to future

As per discussion, need to reconsider.

#36 Updated by okurz over 1 year ago

  • Status changed from Feedback to Blocked

ok, we have since 2018-07 an unconditional "record_soft_failure" referencing https://bugzilla.suse.com/show_bug.cgi?id=1017558 "if is_leap" which is not perfect but at least reminds about the bug ;) Also we have a SLE15SP1 feature request now so I would say we should wait for #41279 first.

#37 Updated by okurz 9 months ago

  • Assignee changed from okurz to riafarov

Move to new QSF-y PO after I moved to the "tools"-team. I mainly checked the subject line so in individual instances you might not agree to take it over completely into QSF-y. Feel free to reassign to me or someone else in this case. Thanks.

#38 Updated by riafarov 7 months ago

  • Status changed from Blocked to Resolved

Bug is fixed, unconditional soft failure was removed: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/7318
In case issue exists in older versions, we should use needles with bug references.

Also available in: Atom PDF