Project

General

Profile

action #33136

[virtualization][functional][y] XEN/KVM host text mode installation on ipmi backend fails.

Added by xlai over 4 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
New test
Target version:
SUSE QA - Milestone 24
Start date:
2018-03-21
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

On build 499.1, most virtualization jobs fail at host installation phase, because PR https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4565 does not add needed needles for such installations.

Virtualization tests really depend on and affected by common installation or special change for xen/kvm roles or special change for ipmi backend. Not only test process delayed, but also we need spend quite some effort to debug the root cause.

Suggestion for future openqa PR-- to deliver to openqa PR reviewers:
when there is code change on common installation or special change for xen/kvm roles or special change for ipmi backend, please add verification run on https://openqa.suse.de/tests/1536711 (kvm) and https://openqa.suse.de/tests/1534947 (xen) and make sure the host installation part pass , before it gets merged.

History

#1 Updated by okurz over 4 years ago

  • Subject changed from [virtualization]XEN/KVM host text mode installation on ipmi backend fails. to [virtualization][functional]XEN/KVM host text mode installation on ipmi backend fails.
  • Due date set to 2018-05-22
  • Category set to New test
  • Target version set to Milestone 16

I assume the problem here is not "ipmi" but rather "textmode". It looks like these needles are missing. I think it is feasible to add a test like "textmode+kvm_role" but in general I do not think we can prevent errors like these from happening again.

What we probably would all like if investigation on job failures would be helped by more automation, e.g. to point directly to recent test code changes so that the PR author could be immediately informed.

#2 Updated by xlai over 4 years ago

okurz wrote:

I assume the problem here is not "ipmi" but rather "textmode". It looks like these needles are missing. I think it is feasible to add a test like "textmode+kvm_role" but in general I do not think we can prevent errors like these from happening again.

Yes, the problem here is on textmode.

I fully agree to add basic tests like "textmode+kvm_role@64bit-ipmi" and "textmode+xen_role@64bit-ipmi", which can expose all installation issues due to any relative code change on textmode, virt roles and ipmi special code path.

If above cases can be added to validation run for relative PRs, then such issues can be avoided well, why not ;-)?

What we probably would all like if investigation on job failures would be helped by more automation, e.g. to point directly to recent test code changes so that the PR author could be immediately informed.

If such intelligent things can be automated, it will be cool~ I raise my two hands up to support :)

#3 Updated by okurz over 4 years ago

  • Due date set to 2018-05-29

due to changes in a related task

#4 Updated by okurz over 4 years ago

  • Status changed from New to Blocked
  • Assignee set to okurz

I updated the ticket dependency chain. The ticket that we need to work on at first is #32089 . slindomansilla is working on this one currently. This ticket here is not expected to be resolved before 2018-06 based on these dependencies.

#5 Updated by okurz about 4 years ago

  • Subject changed from [virtualization][functional]XEN/KVM host text mode installation on ipmi backend fails. to [virtualization][functional][y] XEN/KVM host text mode installation on ipmi backend fails.

#6 Updated by mgriessmeier about 4 years ago

  • Due date changed from 2018-05-29 to 2018-06-19

due to changes in a related task

#7 Updated by okurz about 4 years ago

  • Due date changed from 2018-06-19 to 2018-10-09

due to changes in a related task

#8 Updated by okurz about 4 years ago

  • Target version changed from Milestone 16 to Milestone 21+

based on dependencies

#9 Updated by okurz about 4 years ago

  • Target version changed from Milestone 21+ to Milestone 21+

#10 Updated by okurz almost 4 years ago

  • Due date changed from 2018-10-09 to 2019-02-12

due to changes in a related task

#11 Updated by okurz over 3 years ago

  • Target version changed from Milestone 21+ to Milestone 24

#12 Updated by xlai over 3 years ago

  • Status changed from Blocked to Resolved

It is resolved already.

#13 Updated by okurz over 3 years ago

Are you sure it is resolved? The subtask is still open and I think by now we do not yet have an installation of xen/kvm server role text mode on ipmi which I thought was the idea of the ticket, isn't it? Do you have jobs you can reference that cover this?

#14 Updated by xlai over 3 years ago

okurz wrote:

Are you sure it is resolved? The subtask is still open and I think by now we do not yet have an installation of xen/kvm server role text mode on ipmi which I thought was the idea of the ticket, isn't it? Do you have jobs you can reference that cover this?

This card's problem that 'XEN/KVM host text mode installation on ipmi backend fails' is actually fixed, see
kvm : https://openqa.suse.de/tests/2341580#step/system_role/6
xen: https://openqa.suse.de/tests/2341397#step/system_role/7

The sub-task #33556 of adding xen/kvm server role text mode on ipmi in functinal job group is not done as you said ;-). The purpose of adding them to functional group is to expose the system role related fundamental host installation issues earlier. Still valid!

So I suggest to close this one and keep task 33556 open. Feel free to reopen it if you find it meaningful to be open though.

#15 Updated by okurz over 3 years ago

xlai wrote:

The sub-task #33556 of adding xen/kvm server role text mode on ipmi in functinal job group is not done as you said ;-). The purpose of adding them to functional group is to expose the system role related fundamental host installation issues earlier. Still valid!

agreed. It just looks a bit unusual now that this "parent" ticket is "Resolved" while the "child" is not but I am sure we can live with that. Ok, fine.

#16 Updated by okurz over 3 years ago

  • Due date changed from 2019-02-12 to 2019-12-31

due to changes in a related task

#17 Updated by riafarov over 2 years ago

  • Due date changed from 2019-12-31 to 2018-03-21

due to changes in a related task

Also available in: Atom PDF