Project

General

Profile

action #33019

[opensuse][functional][sporadic][u][medium] Frequent fails in firefox_audio, firefox not started

Added by dimstar about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Start date:
2018-03-09
Due date:
2018-05-22
% Done:

0%

Estimated time:
Difficulty:
medium
Duration: 53

Description

Observation

openQA test in scenario opensuse-Tumbleweed-GNOME-Live-x86_64-gnome-live@uefi-usb fails in
firefox_audio

Firefox is not started, check if can simply increase timeout.

Reproducible

Fails since (at least) Build 20180308

This seems to happen commonly on the live images (GNOME and KDE); often, reruns are fine, often they are not.

Last good

last good


Related issues

Related to openQA Tests - action #34471: [functional][opensuse][u][medium] too early matching in too generic needle text-login-20160812New2018-04-08

History

#1 Updated by okurz about 2 years ago

  • Subject changed from Frequent fails in firefox_audio to [functional]Frequent fails in firefox_audio

#2 Updated by okurz about 2 years ago

  • Subject changed from [functional]Frequent fails in firefox_audio to [functional][u]Frequent fails in firefox_audio
  • Due date set to 2018-05-08
  • Priority changed from Normal to High
  • Target version set to Milestone 16

#3 Updated by okurz about 2 years ago

  • Due date changed from 2018-05-08 to 2018-04-10
  • Target version changed from Milestone 16 to Milestone 15

ok, we see that happening a lot in current openSUSE TW tests. Should take a look into it sooner.

#4 Updated by zluo about 2 years ago

  • Assignee set to zluo

take over...

#5 Updated by zluo about 2 years ago

test-firefox_audio-1 has not matched as I can see atm.

#6 Updated by riafarov about 2 years ago

  • Subject changed from [functional][u]Frequent fails in firefox_audio to [opensuse][functional][u] Frequent fails in firefox_audio, firefox not started
  • Description updated (diff)
  • Status changed from New to Workable

#7 Updated by okurz about 2 years ago

  • Subject changed from [opensuse][functional][u] Frequent fails in firefox_audio, firefox not started to [opensuse][functional][u][medium] Frequent fails in firefox_audio, firefox not started

#8 Updated by cwh about 2 years ago

  • Difficulty set to medium

#9 Updated by zluo about 2 years ago

  • Status changed from Workable to In Progress

increase timeout to 90:

--

x11_start_program('firefox ' . data_url('1d5d9dD.oga'), target_match => 'test-firefox_audio-1', match_timeout => 90);

it looks much better now, but failed sometimes the reason for failure is worker performance which is low.

For example:
http://e13.suse.de/tests/873#step/firefox_audio/4

I triggered more than 10 same jobs on loewe and QEMURAM is 2048 MB, not so much (I personally think this setup is quite slow for running firefox).

#11 Updated by okurz about 2 years ago

  • Subject changed from [opensuse][functional][u][medium] Frequent fails in firefox_audio, firefox not started to [opensuse][functional][sporadic][u][medium] Frequent fails in firefox_audio, firefox not started
  • Status changed from In Progress to Workable
  • Assignee deleted (zluo)

PR is merged. Next step: Check if we have current failures in e.g. openSUSE Tumbleweed and openSUSE Leap tests.

Unassigning zluo due to absence.

#12 Updated by oorlov about 2 years ago

  • Status changed from Workable to In Progress
  • Assignee set to oorlov

#14 Updated by oorlov about 2 years ago

  • Status changed from Resolved to Workable
  • Assignee deleted (oorlov)

#15 Updated by mgriessmeier about 2 years ago

  • Due date changed from 2018-04-10 to 2018-04-24

#16 Updated by okurz about 2 years ago

  • Blocked by action #34471: [functional][opensuse][u][medium] too early matching in too generic needle text-login-20160812 added

#17 Updated by okurz about 2 years ago

  • Due date changed from 2018-04-24 to 2018-05-22
  • Target version changed from Milestone 15 to Milestone 16

good observation but I the issue you mentioned I consider blocked by #34471 so we should do #34471 first.

#18 Updated by jorauch about 2 years ago

  • Assignee set to jorauch

#19 Updated by jorauch about 2 years ago

  • Status changed from Workable to In Progress

#20 Updated by jorauch about 2 years ago

Last seen a month ago

#21 Updated by jorauch about 2 years ago

Highly suspect that this is actually this bug:
https://bugzilla.suse.com/show_bug.cgi?id=1088282

#22 Updated by jorauch about 2 years ago

  • Status changed from In Progress to Feedback

Started 100 runs to see if this failure still appears:
http://pinky.arch.suse.de/tests/overview?distri=opensuse&version=Tumbleweed&build=20180513&groupid=3

Waiting for the runs to finish and then revisit this ticket

#23 Updated by jorauch about 2 years ago

  • Status changed from Feedback to In Progress

Error didnt appear anymore, resolving this

#24 Updated by jorauch about 2 years ago

  • Status changed from In Progress to Feedback

Cannot resolve it, needs to be clarified in Review Meeting

#25 Updated by mgriessmeier about 2 years ago

  • Blocked by deleted (action #34471: [functional][opensuse][u][medium] too early matching in too generic needle text-login-20160812)

#26 Updated by mgriessmeier about 2 years ago

  • Related to action #34471: [functional][opensuse][u][medium] too early matching in too generic needle text-login-20160812 added

#27 Updated by mgriessmeier about 2 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF