Project

General

Profile

action #32293

action #30388: [qam] openqaworker10:4 - worker fail all tests - qemu instances are left behind

action #32263: [tools] Implement sub-reaper support in workers when starting isotovideo

[tools] Implement sub-reaper support in isotovideo

Added by EDiGiacinto over 3 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
Start date:
2018-02-26
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

From http://e122.suse.de/tests/7790/file/autoinst-log.txt it can be seen that on sigterm, isotovideo is leaking childs, and the worker is reaping them.

To better handle this, we should do the same change in isotovideo and enable sub-reaping, and (try to) propagate the sigterm on the childs.


Checklist

  • Messages with: "Collected unknown process with pid 14306 and exit status: 0" are not shown anymore
  • Use rwp in a similar fashion as poo#32263 on os-autoinst

Related issues

Related to openQA Project - action #33037: dead children uncaught (again)Resolved2018-03-10

History

#1 Updated by szarate over 3 years ago

  • Checklist set to [ ] Messages with: "Collected unknown process with pid 14306 and exit status: 0" are not shown anymore
  • Target version set to Ready

I think we have enough to pick this one soonish.

An approach similar to pr#1590 in openQA

#2 Updated by szarate over 3 years ago

  • Checklist changed from [ ] Messages with: "Collected unknown process with pid 14306 and exit status: 0" are not shown anymore to [ ] Messages with: "Collected unknown process with pid 14306 and exit status: 0" are not shown anymore, [ ] Use rwp in a similar fashion as poo#32263 on os-autoinst

#3 Updated by coolo over 3 years ago

  • Target version changed from Ready to future

I don't care - for production it's perfectly fine if openQA worker cleans up

#4 Updated by EDiGiacinto over 3 years ago

#5 Updated by okurz about 3 years ago

  • Target version changed from future to future

#6 Updated by EDiGiacinto almost 3 years ago

  • Checklist changed from [ ] Messages with: "Collected unknown process with pid 14306 and exit status: 0" are not shown anymore, [ ] Use rwp in a similar fashion as poo#32263 on os-autoinst to [ ] Messages with: "Collected unknown process with pid 14306 and exit status: 0" are not shown anymore, [x] Use rwp in a similar fashion as poo#32263 on os-autoinst

#7 Updated by okurz about 2 years ago

  • Category set to Feature requests

#8 Updated by okurz over 1 year ago

  • Checklist changed from [ ] Messages with: "Collected unknown process with pid 14306 and exit status: 0" are not shown anymore, [x] Use rwp in a similar fashion as poo#32263 on os-autoinst to [x] Messages with: "Collected unknown process with pid 14306 and exit status: 0" are not shown anymore, [x] Use rwp in a similar fashion as poo#32263 on os-autoinst
  • Status changed from New to Resolved
  • Assignee set to okurz

The problem is gone. Also with https://github.com/os-autoinst/os-autoinst/pull/1277 and e.g. https://github.com/os-autoinst/os-autoinst/pull/1302 we have a cleaner and faster shutdown.

Also available in: Atom PDF