Project

General

Profile

action #31921

[kernel][network]Wicked fails the newly added dhcp test on o3

Added by dimstar over 4 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
High
Assignee:
-
Category:
Infrastructure
Start date:
2018-02-16
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-wicked_basic@64bit fails in
basic

Reproducible

Fails since (at least) Build 20180215

Expected result

Last good: 20180214 (or more recent)

Further details

Always latest result in this scenario: latest

At least until now, o3 had no multi-worker config and even if this was now configured, it is not working as expected.


Related issues

Related to openQA Tests - action #30892: [opensuse][tools]multi-machine worker setupResolved2018-01-29

Related to openQA Tests - action #31852: o3 does not support multimachine testing Rejected2018-02-15

History

#1 Updated by asmorodskyi over 4 years ago

  • Has duplicate action #31852: o3 does not support multimachine testing added

#2 Updated by asmorodskyi over 4 years ago

  • Category changed from Bugs in existing tests to Infrastructure
  • Assignee set to asmorodskyi

#3 Updated by okurz over 4 years ago

  • Subject changed from Wicked fails the newly added dhcp test on o3 to [network]Wicked fails the newly added dhcp test on o3
  • Priority changed from Normal to High

seems to be easily reproducible

#4 Updated by asmorodskyi over 4 years ago

test is failing because o3 infrastructure does have multi-machine worker and since sometime wicked_basic scenario require it. So it is Infrastructure bug.
I am working on it, currently I am trying to setup salt recipe repo for o3 so it will take some time to fix this

#5 Updated by sebchlad over 4 years ago

  • Subject changed from [network]Wicked fails the newly added dhcp test on o3 to [kernel][network]Wicked fails the newly added dhcp test on o3

Hi Oli,

keep in mind that we have scrum team: Kernel&Network, so please add kernel tag for anything for this scrum team.

Due to limitation of the redmine tool we can use only one tag to track Product Backlog for Kernel&Network Scrum team. We use tag: kernel.

#6 Updated by okurz over 4 years ago

  • Blocked by action #30892: [opensuse][tools]multi-machine worker setup added

#7 Updated by sebchlad over 4 years ago

  • Target version set to Milestone 15

#8 Updated by asmorodskyi over 4 years ago

  • Blocked by deleted (action #30892: [opensuse][tools]multi-machine worker setup)

#9 Updated by asmorodskyi over 4 years ago

  • Has duplicate deleted (action #31852: o3 does not support multimachine testing )

#10 Updated by asmorodskyi over 4 years ago

  • Subject changed from [kernel][network]Wicked fails the newly added dhcp test on o3 to [kernel][network]Wicked fails the newly added dhcp test
  • Status changed from New to In Progress

Failure is general for o3 and osd

#11 Updated by asmorodskyi over 4 years ago

  • Related to action #30892: [opensuse][tools]multi-machine worker setup added

#12 Updated by asmorodskyi over 4 years ago

  • Related to action #31852: o3 does not support multimachine testing added

#13 Updated by asmorodskyi over 4 years ago

  • Subject changed from [kernel][network]Wicked fails the newly added dhcp test to [kernel][network]Wicked fails the newly added dhcp test on o3
  • Status changed from In Progress to Workable
  • Assignee deleted (asmorodskyi)

reverting changes which I made by mistake

#14 Updated by asmorodskyi over 4 years ago

I created first raw draft of expected salt recepie repository for o3 - https://gitlab.suse.de/asmorodskyi/o3-openqa-salt-review. Mainly it is copy/paste of osd salt/pillar repos with cutting all unrelated / too complex for first draft things. There is still a lot of thing to cut/modify but before going further I want to get early feedback if I am generally moving in a right direction

#15 Updated by asmorodskyi over 4 years ago

  • Status changed from Workable to Rejected

rejecting as duplicate of #30892

Also available in: Atom PDF