Project

General

Profile

Actions

action #31687

closed

[opensuse][functional][medium][u] x11_start_program does not care if program can not be called in desktop runner even after three 'ret' presses with "valid" and "target_match"

Added by okurz over 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Start date:
2018-02-12
Due date:
2018-04-24
% Done:

0%

Estimated time:
Difficulty:
medium

Description

Observation

openQA test in scenario opensuse-15.0-NET-x86_64-update_Leap_42.2_kde@64bit fails in
vlc to see the first-time-wizard of VLC and was previously trying to press 'ret' multiple times to confirm the typed command but that is never accepted. After three tries to no avail x11_start_program exits silenty and then continues into the next test command which - confusing enough - is also just a press of the 'ret' key. Problem is that this key press is meant to discard the first time wizard assuming that x11_start_program would have only returned when the first-time-wizard is shown. Instead the desktop runner is still active with the typed but never executed command. Surprisingly this final 'ret' press worked to activate the command in the desktop runner, VLC is started with the first-time-wizard but at this point the test does not expect it anymore and therefore the normal flow can not be followed.

Reproducible

Fails since (at least) Build 124.1

Expected result

Last good: 123.1 (or more recent)

Suggestion

  • Ensure that x11_start_program dies if the desktop-runner-border is still shown after the for-loop exits without success.

Further details

Always latest result in this scenario: latest


Related issues 4 (0 open4 closed)

Related to openQA Tests - action #30805: [functional][opensuse][leap][medium][u] first test after reboot fails in krunner, potential system overload (was: test fails in inkscape - typing too fast?)Resolvedokurz2018-01-252018-08-14

Actions
Related to openQA Tests - action #30808: [opensuse][leap][functional][u]test fails in vlc when opening vlcResolvedokurz2018-01-25

Actions
Related to openQA Tests - action #33571: [opensuse][functional][u][medium] test fails in shutdown - emoticon settings are openedResolved2018-03-212018-06-05

Actions
Related to openQA Tests - action #33949: [sle][functional][fast][u]test fails in updates_packagekit_gpk - updates-none is not matchingResolvedokurz2018-03-282018-04-10

Actions
Actions #1

Updated by okurz over 6 years ago

  • Target version set to Milestone 15
Actions #2

Updated by okurz over 6 years ago

  • Due date set to 2018-03-27
Actions #3

Updated by okurz over 6 years ago

  • Status changed from New to Workable
Actions #4

Updated by okurz over 6 years ago

  • Priority changed from Normal to High

reproducible in multiple scenarios.

Actions #5

Updated by jorauch over 6 years ago

Will work on this since it goes good in parallel with:
https://progress.opensuse.org/issues/30805

Actions #6

Updated by mgriessmeier over 6 years ago

  • Related to action #30805: [functional][opensuse][leap][medium][u] first test after reboot fails in krunner, potential system overload (was: test fails in inkscape - typing too fast?) added
Actions #7

Updated by jorauch over 6 years ago

  • Status changed from Workable to In Progress
Actions #8

Updated by jorauch over 6 years ago

  • Assignee set to jorauch
Actions #10

Updated by okurz over 6 years ago

  • Related to action #30808: [opensuse][leap][functional][u]test fails in vlc when opening vlc added
Actions #11

Updated by jorauch over 6 years ago

Actions #12

Updated by jorauch over 6 years ago

Interesting phenomenon:
http://pinky.arch.suse.de/tests/709#step/vlc/21
x11_start_program does not realize the program is already started and tries again

Actions #13

Updated by jorauch about 6 years ago

  • Related to action #33571: [opensuse][functional][u][medium] test fails in shutdown - emoticon settings are opened added
Actions #15

Updated by mgriessmeier about 6 years ago

  • Due date changed from 2018-03-27 to 2018-04-10
Actions #16

Updated by okurz about 6 years ago

PR merged, but in the reduced set. Please make sure to open a PR for the missing two parts.

Actions #17

Updated by okurz about 6 years ago

  • Status changed from Feedback to Workable
  • Assignee deleted (jorauch)

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4670 was merged … and reverted as it broke tests, see comments on github. back to workable due to current unavailability of jorauch.

Actions #18

Updated by cwh about 6 years ago

  • Difficulty set to medium
Actions #19

Updated by riafarov about 6 years ago

  • Subject changed from [opensuse][functional][medium]x11_start_program does not care if program can not be called in desktop runner even after three 'ret' presses with "valid" and "target_match" to [opensuse][functional][medium][u] x11_start_program does not care if program can not be called in desktop runner even after three 'ret' presses with "valid" and "target_match"
Actions #20

Updated by okurz about 6 years ago

  • Related to action #33949: [sle][functional][fast][u]test fails in updates_packagekit_gpk - updates-none is not matching added
Actions #21

Updated by jorauch about 6 years ago

  • Assignee set to jorauch

Apparently there are some type problems in the code, trying to fix this

Actions #22

Updated by jorauch about 6 years ago

  • Status changed from Workable to Feedback

Fixed the type magic in:
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4808
Waiting for merge and verification in production

Actions #23

Updated by jorauch about 6 years ago

PR has been merged, waiting for verification in production

Actions #24

Updated by mgriessmeier about 6 years ago

  • Due date changed from 2018-04-10 to 2018-04-24
Actions #25

Updated by jorauch about 6 years ago

  • Status changed from Feedback to Resolved

No angry reacts since 3 days, I assume nothing has been broken and we can close this

Actions

Also available in: Atom PDF