Project

General

Profile

action #31489

[sle15sp1][desktop] Migrate regression-remote cases to SLED15

Added by qkzhu over 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
New test
Target version:
-
Start date:
2018-03-20
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Difficulty:

Description

This testsuite will be renamed as desktopapps-firefox and scheduled under Desktop Applications

Remote Server: SLE12SP2 or SLE12SP3
Remote Client: SLED15


Subtasks

action #33493: [sle15sp1][desktop] Add RDP remote desktop cases to SLED15ResolvedGraceWang

History

#1 Updated by okurz over 3 years ago

  • Category set to New test

#2 Updated by qkzhu over 3 years ago

  • Status changed from New to In Progress

Remote desktop support server (based on SLES12SP3) was generated:

The image was generated via:
/usr/share/openqa/script/client --host openqa.suse.de --apikey your_key --apisecret your_secret jobs post DISTRI=sle VERSION=12-SP3 ISO=SLE-1
2-SP3-Server-DVD-x86_64-CURRENT-Media1.iso ARCH=x86_64 FLAVOR=Server-DVD TEST=supportserver_generator MACHINE=64bit DESKTOP=gnome INSTALLONLY=1 AUTOYAST=x11/autoyast_remote_desktop_sle12sp2_gnome.xml SUPPORT_SERVER_GENERATOR=1 PUBLISH_HDD_1=remote_desktop_supportserver.qcow2

#3 Updated by qkzhu over 3 years ago

Migrate 2 xvnc cases to SLE15

testsuite:

desktopapps-remote-client1:

BOOTFROM=c
HDD_1=SLE-%VERSION%-%ARCH%-Build%BUILD%-sled-gnome.qcow2
NETWORKS=fixed
NICTYPE=tap
PARALLEL_WITH=desktopapps-remote-supportserver1
REGRESSION=remote
REMOTE_DESKTOP_TYPE=one_time_vnc
SLE_PRODUCT=sled
WORKER_CLASS=tap
START_AFTER_TEST=create_hdd_sled_gnome

desktopapps-remote-supportserver1:

BOOTFROM=c
DESKTOP=gnome
FLAVOR=Server-DVD
HDD_1=remote_desktop_supportserver.qcow2
NETWORKS=fixed
NICTYPE=tap
REMOTE_DESKTOP_TYPE=one_time_vnc
SHUTDOWN_NEEDS_AUTH=1
SUPPORT_SERVER=1
SUPPORT_SERVER_ROLES=xvnc,dhcp
VIRTIO_CONSOLE=0
WORKER_CLASS=tap
START_AFTER_TEST=create_hdd_sled_gnome


  • These cases will be added to testsuite desktopapps-remote
  • Update the setup steps of supportserver role xvnc_server since we are using SLES12SP3 as the remote desktop supportserver
  • Drop onetime_vncsession_xvnc_java.pm for SLE15, the NPAPI needed for the Java plugin is deprecated in Esr52
  • Update 2 xvnc cases

desktopapps-remote-client1: http://10.67.17.30/tests/233
desktopapps-remote-supportserver1: http://10.67.17.30/tests/232

  • Needles: Needles will be submitted later, I am preparing the latest qcow2 image which has new fonts

#6 Updated by qkzhu over 3 years ago

  • % Done changed from 0 to 20

2 xvnc cases were added: https://openqa.suse.de/tests/1555769

#7 Updated by qkzhu over 3 years ago

Migrate persistent vnc and x11 forwarding cases to SLED15


testsuite:

desktopapps-remote-client2
BOOTFROM=c
HDD_1=SLE-%VERSION%-%ARCH%-Build%BUILD%-sled-gnome.qcow2
NETWORKS=fixed
NICTYPE=tap
PARALLEL_WITH=desktopapps-remote-supportserver2
REGRESSION=remote
REMOTE_DESKTOP_TYPE=persistent_vnc
SLE_PRODUCT=sled
WORKER_CLASS=tap
START_AFTER_TEST=create_hdd_sled_gnome

desktopapps-remote-supportserver2
BOOTFROM=c
DESKTOP=gnome
FLAVOR=Server-DVD
HDD_1=remote_desktop_supportserver.qcow2
NETWORKS=fixed
NICTYPE=tap
REMOTE_DESKTOP_TYPE=persistent_vnc
SHUTDOWN_NEEDS_AUTH=1
SUPPORT_SERVER=1
SUPPORT_SERVER_ROLES=dhcp,xdmcp,xvnc,ssh
VIRTIO_CONSOLE=0
WORKER_CLASS=tap
START_AFTER_TEST=create_hdd_sled_gnome


#8 Updated by qkzhu over 3 years ago

testsuites of x11 forwarding, persistent vnc were added: https://openqa.suse.de/admin/job_templates/118

#9 Updated by qkzhu over 3 years ago

Add a remmina xvcn remote desktop case

We replaced vinagre with remmina in SLE15, this case will use remmina as client to access onetime xvnc remote desktop server.


#10 Updated by qkzhu over 3 years ago

Migrate two xdmcp cases to SLED15

  • Migrate xdmcp_gdm, xdmcp_xdm to SLED15, the steps of setting firewall were updated since we are using firewalld in SLE15
  • Replace script_run with assert_script_run for xdmcp supportserver setup in setup.pm

testsuite:

  1. xdmcp_gdm should be scheduled by testsuite: desktopapps-remote-client2 and desktopapps-remote-supportserver2
  2. testsuite for xdmcp_xdm:

desktopapps-remote-client3:
BOOTFROM=c
HDD_1=SLE-%VERSION%-%ARCH%-Build%BUILD%-sled-gnome.qcow2
NETWORKS=fixed
NICTYPE=tap
PARALLEL_WITH=desktopapps-remote-supportserver3
REGRESSION=remote
REMOTE_DESKTOP_TYPE=xdmcp_xdm
SLE_PRODUCT=sled
WORKER_CLASS=tap
START_AFTER_TEST=create_hdd_sled_gnome

desktopapps-remote-supportserver3:
BOOTFROM=c
DESKTOP=gnome
FLAVOR=Server-DVD
HDD_1=remote_desktop_supportserver.qcow2
NETWORKS=fixed
NICTYPE=tap
REMOTE_DESKTOP_TYPE=xdmcp_xdm
SHUTDOWN_NEEDS_AUTH=1
SUPPORT_SERVER=1
SUPPORT_SERVER_ROLES=xdmcp,dhcp
VIRTIO_CONSOLE=0
WORKER_CLASS=tap
START_AFTER_TEST=create_hdd_sled_gnome


xdmcp_xdm: http://10.67.17.30/tests/356
xdmcp_gdm: http://10.67.17.30/tests/357


PR was merged and testsuites were added: https://openqa.suse.de/admin/job_templates/118

#12 Updated by yfjiang about 3 years ago

  • Assignee changed from qkzhu to GraceWang

#13 Updated by yfjiang about 3 years ago

  • Subject changed from [sle15][desktop] Migrate regression-remote cases to SLED15 to [sle15sp1][desktop] Migrate regression-remote cases to SLED15

#14 Updated by GraceWang over 2 years ago

  • Status changed from In Progress to Resolved

Close this poo since subtasks have been resolved.

Also available in: Atom PDF