Project

General

Profile

action #33493

action #31489: [sle15sp1][desktop] Migrate regression-remote cases to SLED15

[sle15sp1][desktop] Add RDP remote desktop cases to SLED15

Added by qkzhu over 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
New test
Target version:
-
Start date:
2018-03-20
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

We should implement the windows related remote desktop testing for SLED15.

Protocol: RDP
RDP (Client: SLED, Windows; Server: SLES, Windows)

Test matrix:

  1. Windows access SLES with xrdp enabled use Windows built-in Remote desktop client and ensure you get sesman session chooser and try to login. This should bring up gdm
  2. SLED using vinagre with NLA enabled and NLA disabled access Windows

We could use windows10 qcow from the case https://openqa.opensuse.org/tests/616485


Related issues

Related to openQA Tests - action #9504: [desktop]Remote Desktop TestingResolved2015-11-11

History

#1 Updated by qkzhu over 3 years ago

  • Related to action #9504: [desktop]Remote Desktop Testing added

#2 Updated by yfjiang about 3 years ago

  • Assignee set to GraceWang

#3 Updated by yfjiang about 3 years ago

  • Subject changed from [sle15][desktop] Add RDP remote desktop cases to SLED15 to [sle15sp1][desktop] Add RDP remote desktop cases to SLED15

#4 Updated by GraceWang almost 3 years ago

  • Status changed from New to In Progress

qkzhu wrote:

We should implement the windows related remote desktop testing for SLED15.

Protocol: RDP
RDP (Client: SLED, Windows; Server: SLES, Windows)

This should be
Protocol: RDP
Client: Windows; Server: SLES15SP1
Client: SLED15SP1; Server: Windows (NLA enabled)
Client: SLED15SP1; Server: Windows (NLA disable)

Test matrix:

  1. Windows access SLES with xrdp enabled use Windows built-in Remote desktop client and ensure you get sesman session chooser and try to login. This should bring up gdm
  2. SLED using vinagre with NLA enabled and NLA disabled access Windows

In SLED15SP1, we should use remmina not vinagre.

We could use windows10 qcow from the case https://openqa.opensuse.org/tests/616485

#5 Updated by GraceWang almost 3 years ago

  • % Done changed from 0 to 70

Since https://bugzilla.suse.com/show_bug.cgi?id=1116281 was found.
So, the case Client: Windows; Server: SLES15SP1 was finished with softfailed.

https://bugzilla.suse.com/show_bug.cgi?id=1117402 was found in SLED15SP1.
So, I am working on adding softfailed to the below two test cases:
Client: SLED15SP1; Server: Windows (NLA enabled)
Client: SLED15SP1; Server: Windows (NLA disable)

Will submit PR once finished.

#6 Updated by GraceWang almost 3 years ago

Test Cases PR:
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/6350

Needles:
https://gitlab.suse.de/openqa/os-autoinst-needles-sles/merge_requests/1020

Verification Run:
desktopapps-remote-desktop-xrdp-server1 http://10.67.18.241/tests/943
desktopapps-remote-desktop-xrdp-client1 http://10.67.18.241/tests/944
desktopapps-remote-desktop-xrdp-client2 http://10.67.18.241/tests/960
desktopapps-remote-desktop-xrdp-server2 http://10.67.18.241/tests/959
remote-desktop-client4 http://10.67.18.241/tests/994
remote-desktop-supportserver4 http://10.67.18.241/tests/993

#7 Updated by GraceWang almost 3 years ago

  • % Done changed from 70 to 90

For test suites settings please find http://10.67.18.241/admin/test_suites
Will add to osd once the test cases and needles have been merged.

#8 Updated by GraceWang over 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100

Also available in: Atom PDF