Project

General

Profile

action #29419

[tools] MULTINET parameter cause incomplete job

Added by asmorodskyi over 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
Start date:
2017-12-14
Due date:
% Done:

0%

Estimated time:
Difficulty:
Duration:

Description

According to https://github.com/os-autoinst/os-autoinst/blob/master/doc/networking.md

MULTINET parameter giving ability to have SUT with two network cards

when running job on 4.5.1512119921.b2fe214f-12.1 with MULTINET parameter I get qemu exception :

QEMU: qemu-system-x86_64: -net nic,vlan=1,model=virtio-net,macaddr=52:54:00:12:34:57: 'vlan' is deprecated. Please use 'netdev' instead.

autoinst-log.txt (6.93 KB) autoinst-log.txt asmorodskyi, 2017-12-14 13:57
vars.json (1.74 KB) vars.json asmorodskyi, 2017-12-14 13:57
multinet.patch (474 Bytes) multinet.patch asmorodskyi, 2019-02-13 15:05

Related issues

Related to openQA Project - action #32968: [kernel][tools] Refactor QEMU backend - Create QEMU process manager and save configuration stateResolved2018-04-24

Blocks openQA Tests - action #41729: [qac][wicked] Complex layout - ifup, ifstatus, ifdown, ifstatusNew2018-09-27

Blocks openQA Tests - action #41726: [qac][wicked] Complex layout - ifup, ifstatusNew2018-09-27

Blocks openQA Tests - action #41723: [qac][wicked] Complex layout - ifreload, config change, ifreloadNew2018-09-27

Blocks openQA Tests - action #41720: [qac][wicked] Complex layout - ifreload twiceNew2018-09-27

Blocks openQA Tests - action #41717: [qac][wicked] Complex layout - ifreloadNew2018-09-27

Blocks openQA Tests - action #41714: [qac][wicked] Complex layout - ifdown 3 timesNew2018-09-27

Blocks openQA Tests - action #41711: [qac][wicked] Complex layout - ifdown twiceNew2018-09-27

Blocks openQA Tests - action #41705: [qac][wicked] Complex layout - ifup 3 timesNew2018-09-27

Blocks openQA Tests - action #41708: [qac][wicked] Complex layout - ifdownNew2018-09-27

History

#2 Updated by asmorodskyi over 2 years ago

this issue blocks wicked testing

#3 Updated by coolo over 2 years ago

  • Category set to 132
  • Target version set to Ready

well, if it blocks you - downgrade to the qemu version this documentation was written for.

#4 Updated by asmorodskyi over 2 years ago

it fails also on osd https://openqa.suse.de/tests/1323658. Not sure if problem is the same but nevertheless I can influence on version of qemu in osd but I need to make it work there too

#6 Updated by asmorodskyi over 2 years ago

small clarification - when I stated that it's blocks wicked testing I did mean that it's fully block , just all test cases which require second network card ( really approx. 10% of all tests )

#7 Updated by EDiGiacinto over 2 years ago

  • Related to action #32968: [kernel][tools] Refactor QEMU backend - Create QEMU process manager and save configuration state added

#8 Updated by asmorodskyi over 1 year ago

  • Blocks action #41729: [qac][wicked] Complex layout - ifup, ifstatus, ifdown, ifstatus added

#9 Updated by asmorodskyi over 1 year ago

  • Blocks action #41726: [qac][wicked] Complex layout - ifup, ifstatus added

#10 Updated by asmorodskyi over 1 year ago

  • Blocks action #41723: [qac][wicked] Complex layout - ifreload, config change, ifreload added

#11 Updated by asmorodskyi over 1 year ago

  • Blocks action #41720: [qac][wicked] Complex layout - ifreload twice added

#12 Updated by asmorodskyi over 1 year ago

  • Blocks action #41717: [qac][wicked] Complex layout - ifreload added

#13 Updated by asmorodskyi over 1 year ago

  • Blocks action #41714: [qac][wicked] Complex layout - ifdown 3 times added

#14 Updated by asmorodskyi over 1 year ago

  • Blocks action #41711: [qac][wicked] Complex layout - ifdown twice added

#15 Updated by asmorodskyi over 1 year ago

  • Blocks action #41705: [qac][wicked] Complex layout - ifup 3 times added

#16 Updated by asmorodskyi over 1 year ago

  • Blocks action #41702: [qac][wicked] Complex layout - ifup twice added

#17 Updated by asmorodskyi over 1 year ago

  • Blocks action #41708: [qac][wicked] Complex layout - ifdown added

#18 Updated by mkittler over 1 year ago

  • Status changed from New to In Progress
  • Assignee set to mkittler
  • Target version changed from Ready to Current Sprint

I can reproduce this by cloning the mentioned o3 job locally. Let's see whether I can adjust the invocation of qemu to use 'netdev' instead.

#19 Updated by asmorodskyi over 1 year ago

I invested some time into this ticket today. In attachment you can find patch which fixing current issue.
Current issue consists from two problems :

  1. deprecated "vlan" option
  2. fault usage of NICMODEL variable for nic model

with applying my patch you will get two nics in SUT . I haven't create a real PR from my patch because actually you will get only one of them in operable state . second nic create exactly in patch is not assigned to any virtual network so it is not clear if there any chance to use it

#20 Updated by mkittler over 1 year ago

asmorodskyi Ok. I've tried your patch and yes - it isn't connected to any virtual network. I believe that the -net nic... option added by your patch is not sufficient. It only creates the device the guest sees but not the backend on the host-side. I'll look into this. Likely there's just a further option missing.

#22 Updated by mkittler over 1 year ago

  • Status changed from In Progress to Resolved

The PR has been merged. So the issue has technically been resolved by not providing the MULTINET parameter anymore. We found out that the same can be achieved using other variables: https://github.com/os-autoinst/os-autoinst/pull/1103#issuecomment-463958149

#23 Updated by asmorodskyi about 1 year ago

  • Blocks deleted (action #41702: [qac][wicked] Complex layout - ifup twice)

Also available in: Atom PDF