Project

General

Profile

action #28955

coordination #28949: [sle][functional][opensuse][epic] Improve test coverage of partitioning_raid

[sle][functional][easy][yast] Specific needle for each raid type

Added by SLindoMansilla about 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Category:
Bugs in existing tests
Start date:
2017-12-06
Due date:
2018-02-13
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

At the moment, there is a general needle used to assert the final step of partitioning. That means that we could have a false negative if the needle match with a non-expected result.

openQA test in scenario sle-15-Installer-DVD-x86_64-RAID0@64bit fails in
partitioning_raid

Acceptance criteria

  • AC1: Each raid type has its own needle for acceptedpartitioning matching exactly the expected result.
  • AC2: The code still uses the tag acceptedpartitioningraidefi.
  • AC3: The verification runs match the proper specific needle for each raid type.
  • AC4: The test module partitioning_raid doesn't fail on this needle.

Tasks

  1. Create specific needles for each raid type taking care of not breaking the current code base.

Tags examples

SLE 15

"ENV-15ORLATER-1",
"acceptedpartitioningraidX", (use here the raid type instead of **X**, like _acceptedpartitioningraid0efi_)
"acceptedpartitioningraid"

SLE 15 EFI

"ENV-15ORLATER-1",
"ENV-UEFI-1",
"acceptedpartitioningraidXefi", (use here the raid type instead of **X**, like _acceptedpartitioningraid0efi_)
"acceptedpartitioningraidefi"

SLE 15 OFW

"ENV-15ORLATER-1",
"ENV-OFW-1",
"acceptedpartitioningraidXofw", (use here the raid type instead of **X**, like _acceptedpartitioningraid0ofw_)
"acceptedpartitioningraid"

SLE 12-SP4

"ENV-12SP4ORLATER-1",
"acceptedpartitioningraidX", (use here the raid type instead of **X**, like _acceptedpartitioningraid0_)
"acceptedpartitioningraid"

Reproducible

Fails since (at least) Build 288.8

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #31867: [qam] test fails in partitioning_raid - failures after update to needlesResolved2018-02-15

Has duplicate openQA Tests - action #28970: [sle][functional][easy][yast] Use the specific tag for each raid type in codeResolved2017-12-062018-02-27

History

#1 Updated by SLindoMansilla about 4 years ago

  • Blocks action #28970: [sle][functional][easy][yast] Use the specific tag for each raid type in code added

#2 Updated by SLindoMansilla almost 4 years ago

  • Description updated (diff)

#3 Updated by SLindoMansilla almost 4 years ago

  • Description updated (diff)

#4 Updated by SLindoMansilla almost 4 years ago

  • Description updated (diff)

Verification on OSD:

SLE 15

aarch64
x86_64

Leap 15

aarch64
  • RAID0 N/A
  • RAID1 N/A
  • RAID10 N/A
  • RAID5 N/A
  • RAID6 N/A
  • LVM+RAID N/A
ppc64le
  • RAID0 N/A
  • RAID1 N/A
  • RAID10 N/A
  • RAID5 N/A
  • RAID6 N/A
  • LVM+RAID N/A
s390x
  • RAID0 N/A
  • RAID1 N/A
  • RAID10 N/A
  • RAID5 N/A
  • RAID6 N/A
  • LVM+RAID N/A
x86_64

#5 Updated by SLindoMansilla almost 4 years ago

  • Description updated (diff)

#6 Updated by okurz almost 4 years ago

  • Target version set to Milestone 14

#7 Updated by SLindoMansilla almost 4 years ago

  • Status changed from New to Workable
  • Assignee set to zluo

#8 Updated by zluo almost 4 years ago

needles for x86_64 created.

#9 Updated by zluo almost 4 years ago

needles for ppc64le created as well.

#10 Updated by zluo almost 4 years ago

needles for aarch64 created except raid10.

#11 Updated by okurz almost 4 years ago

  • Due date set to 2018-02-13

planned for next sprint now.

#12 Updated by zluo almost 4 years ago

for sles 15 part:

all needls are in place.

x86_64 still has following problems:
vm+RAID1@svirt-hyperv, lvm+RAID1@svirt-hyperv-uefi, lvm+RAID1@svirt-xen-hvm, lvm+RAID1@svirt-xen-pv : never worked for sles 15

#13 Updated by zluo almost 4 years ago

  • Assignee changed from zluo to SLindoMansilla

@SLindoMansilla: my part has been done, please take over, thanks!

#15 Updated by SLindoMansilla almost 4 years ago

  • Status changed from Workable to In Progress

#17 Updated by riafarov almost 4 years ago

  • Subject changed from [sle][functional][easy] Specific needle for each raid type to [sle][functional][easy][yast] Specific needle for each raid type

#18 Updated by SLindoMansilla almost 4 years ago

All PR merged

#19 Updated by riafarov almost 4 years ago

  • Due date changed from 2018-02-13 to 2018-02-27

Moving to the next sprint

#21 Updated by SLindoMansilla almost 4 years ago

  • Due date changed from 2018-02-27 to 2018-02-13
  • Status changed from In Progress to Resolved

As spoken, only verified on OSD so setting due date to sprint 10.

#22 Updated by pcervinka almost 4 years ago

  • Related to action #31867: [qam] test fails in partitioning_raid - failures after update to needles added

#23 Updated by SLindoMansilla almost 4 years ago

  • Blocks deleted (action #28970: [sle][functional][easy][yast] Use the specific tag for each raid type in code)

#24 Updated by SLindoMansilla almost 4 years ago

  • Has duplicate action #28970: [sle][functional][easy][yast] Use the specific tag for each raid type in code added

Also available in: Atom PDF