Project

General

Profile

action #28657

[functional]Amarok rather frequently fails test

Added by dimstar almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Start date:
2017-11-30
Due date:
2018-01-16
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-kde@USBboot_64 fails in
amarok

Reproducible

Fails since (at least) Build 20171129

Expected result

Last good: 20171127 (or more recent)

Further details

Always latest result in this scenario: latest

This happens in random tests, usually a rerun of the test makes it pass. This needs to be debugged to find out if this is rather a product bug or a test that needs to be improved


Related issues

Related to openQA Tests - action #25894: [sle][functional][opensuse]Mistyping in openQA again? - in kdeResolved2017-10-10

History

#1 Updated by okurz almost 4 years ago

  • Related to action #25894: [sle][functional][opensuse]Mistyping in openQA again? - in kde added

#2 Updated by okurz almost 4 years ago

  • Subject changed from Amarok rather frequently fails test to [functional]Amarok rather frequently fails test
  • Due date set to 2017-12-19
  • Target version set to Milestone 12

#3 Updated by nicksinger almost 4 years ago

Some information I found during review:
We assert the "sound has played" needle pretty quick after the playback is done. In some jobs the "recently played" list gets filled, in others not (as I said, maybe because we're to fast with asserting).
E.g. https://openqa.opensuse.org/tests/546382#step/amarok/22 shows "withing the last minute" instead of "one minute ago".
In addition to that it is pretty unclear is a song is currently playing. The only indicator I could make out is this spectrogram (?) right at the bottom but there is no moving progress bar, no time-left-counter, nothing.

Besides that I could not really figure out what the "-l" parameter does which is hardcoded in this test - maybe its behavior changed over time.

#4 Updated by sebchlad almost 4 years ago

  • Due date changed from 2017-12-19 to 2018-01-16

#5 Updated by zluo almost 4 years ago

  • Status changed from New to In Progress
  • Assignee set to zluo

take over

#7 Updated by dimstar almost 4 years ago

zluo wrote:

check statistic and found that onyl 2 time failed.

So I won't say this is frequently...

It was definitively much worse in the past - the KDE Team did disable a bunch of plugins that seemed to trigger it more frequently

#8 Updated by zluo almost 4 years ago

  • Status changed from In Progress to Rejected

I don't see any issue according to recent re-runs of the test.

reject this for now.
Please open it if it happens again, thanks!

#9 Updated by okurz almost 4 years ago

  • Status changed from Rejected to Resolved

Let's track it as "resolved" then when the accepted fix is the KDE team disabled plugins to stabilize behaviour.

Also available in: Atom PDF