Project

General

Profile

Actions

action #27457

closed

coordination #27074: [sle][functional][epic][sle15][opensuse][y] Update yast2 ui (gui & ncurses) tests for SLE15 and Leap 15

[sle][functional][sle15][bsc#1072808][y][yast][medium] yast2 samba-server - create new workflow because of product change

Added by zluo over 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Start date:
2017-11-07
Due date:
2018-05-22
% Done:

0%

Estimated time:
Difficulty:
medium

Description

Motivation

from sle 15 we have samba server which doesn't provide server role page anymore.
So this change is quite big and it requires a new workflow for samba-server.

We still need to keep current workflow to make sure that tests for sle 12 and current TW are not going to fail.

Blocked by bsc#1072808 although I feel we could still move forward and adjust the current test workflow.

Suggestions


Related issues 2 (0 open2 closed)

Has duplicate openQA Tests - action #30064: [sle][functional][blocked][bsc#1072808]test fails in yast2_sambaRejectedokurz2018-01-092018-04-24

Actions
Has duplicate openQA Tests - action #34009: Failure in yast2_samba: yast2 auth-server no longer existsRejectedokurz2018-03-29

Actions
Actions #1

Updated by okurz over 6 years ago

  • Target version set to Milestone 12
Actions #2

Updated by okurz over 6 years ago

  • Subject changed from [sle][functional][sle15] yast2 samba-server - create new workflow because of product change to [sle][functional][sle15][bsc#1072808] yast2 samba-server - create new workflow because of product change
  • Status changed from New to Blocked
  • Assignee set to okurz
  • Target version changed from Milestone 12 to Milestone 14
Actions #3

Updated by okurz over 6 years ago

  • Due date set to 2018-03-13

No movement in bug since 2017-12, asked back.

Actions #4

Updated by okurz about 6 years ago

  • Description updated (diff)
  • Due date deleted (2018-03-13)
  • Target version changed from Milestone 14 to Milestone 15
Actions #5

Updated by okurz about 6 years ago

  • Subject changed from [sle][functional][sle15][bsc#1072808] yast2 samba-server - create new workflow because of product change to [sle][functional][medium][sle15][bsc#1072808][y][yast] yast2 samba-server - create new workflow because of product change
  • Description updated (diff)
  • Due date set to 2018-04-10
  • Category changed from Enhancement to existing tests to Bugs in existing tests
  • Status changed from Blocked to Workable
  • Assignee deleted (okurz)
Actions #6

Updated by riafarov about 6 years ago

  • Status changed from Workable to Blocked
  • Assignee set to okurz

Blocked by https://bugzilla.suse.com/show_bug.cgi?id=1072808 @okurz, please track and revisit before planning.

Actions #7

Updated by okurz about 6 years ago

  • Has duplicate action #30064: [sle][functional][blocked][bsc#1072808]test fails in yast2_samba added
Actions #8

Updated by okurz about 6 years ago

  • Status changed from Blocked to Workable
  • Assignee deleted (okurz)
  • Priority changed from Normal to High

@riafarov I think you misunderstood my last change in #27457#note-5 . I mentioned the bug and we can continue with the necessary test adaption now even though the bug is/was open. But to make that more clear I did set the bug to RESOLVED FIXED. We can now adapt the test accordingly.

Actions #9

Updated by okurz about 6 years ago

  • Parent task set to #27074
Actions #10

Updated by okurz about 6 years ago

  • Subject changed from [sle][functional][medium][sle15][bsc#1072808][y][yast] yast2 samba-server - create new workflow because of product change to [sle][functional][medium][sle15][bsc#1072808][y][yast][medium] yast2 samba-server - create new workflow because of product change
Actions #11

Updated by mloviska about 6 years ago

  • Assignee set to mloviska
Actions #12

Updated by cwh about 6 years ago

  • Difficulty set to medium
Actions #13

Updated by okurz about 6 years ago

  • Has duplicate action #34009: Failure in yast2_samba: yast2 auth-server no longer exists added
Actions #14

Updated by mloviska about 6 years ago

  • Status changed from Workable to In Progress
Actions #15

Updated by mloviska about 6 years ago

https://bugzilla.suse.com/show_bug.cgi?id=1088152 opened for 389-ds,which does not start after configuration via yast2 ldap-server.

Actions #16

Updated by okurz about 6 years ago

  • Subject changed from [sle][functional][medium][sle15][bsc#1072808][y][yast][medium] yast2 samba-server - create new workflow because of product change to [sle][functional][sle15][bsc#1072808][y][yast][medium] yast2 samba-server - create new workflow because of product change
Actions #17

Updated by riafarov about 6 years ago

  • Due date changed from 2018-04-10 to 2018-04-24
Actions #18

Updated by mloviska about 6 years ago

  • Status changed from In Progress to Feedback
Actions #19

Updated by mgriessmeier about 6 years ago

  • Due date changed from 2018-04-24 to 2018-05-08
  • Target version changed from Milestone 15 to Milestone 16
Actions #20

Updated by okurz about 6 years ago

  • Status changed from Feedback to In Progress

Please regard this with high priority as is marked in the ticket priority field. I assume either the work is actually in progress or you are waiting for something where we could help with. OR can we actually merge the PR as is and see an improvement in tests on production already?

Actions #21

Updated by mloviska about 6 years ago

I am waiting for Zsolt's response on my last mail. There is still a problem to load properly pcks12 certificate store on my side. He has already confirmed that steps to create CA & server key/certificate are correct and are working for him. I have sent him my files to check, whether he has the same problem to setup ldap as I do.

Actions #22

Updated by riafarov about 6 years ago

  • Due date changed from 2018-05-08 to 2018-05-22

Martin, is it blocked? How can we proceed here?

Actions #23

Updated by okurz about 6 years ago

Not blocked, just working on the PR.

Actions #24

Updated by mloviska about 6 years ago

Currently I am done with the PR atm.

Actions #25

Updated by okurz about 6 years ago

PR merged, tests retriggered, waiting for execution:

But subsequent test module yast2_hostname failed because of the change in the domain name, created needle and retriggered:

  • tw, obsoleted by new TW build, new job tw
  • leap15 -> ok
Actions #28

Updated by okurz about 6 years ago

  • Status changed from In Progress to Resolved

see #27457#note-25

Thank you for your hard work.

Actions #29

Updated by mloviska about 6 years ago

Thanks for support Oli!

Actions

Also available in: Atom PDF