Project

General

Profile

action #25972

[opensuse][krypton][functional][medium] test fails in firefox - html5test page does not show up, is the address typed at all?

Added by okurz almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Start date:
2017-10-11
Due date:
2018-02-13
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-5.11.90-Krypton-Live-x86_64-krypton-live-wayland@64bit_virtio-2G fails in
firefox

Reproducible

Fails since (at least) Build 1.1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #14848: [qam][sle][opensuse][functional][x11regressions]test fails in firefox with what looks like temporary problem to access html5test.comResolved2016-11-16

Related to openQA Tests - action #47039: [functional][u] test in vlc wastes 30 seconds without us noticing because of `match_typed`Resolved2019-02-02

History

#1 Updated by okurz almost 3 years ago

  • Subject changed from [opensuse][krypton]test fails in firefox - html5test page does not show up, is the address typed at all? to [opensuse][krypton][functional]test fails in firefox - html5test page does not show up, is the address typed at all?
  • Target version set to Milestone 12

#2 Updated by jorauch almost 3 years ago

#3 Updated by okurz almost 3 years ago

  • Due date set to 2018-01-16
  • Target version changed from Milestone 12 to Milestone 13

#4 Updated by okurz over 2 years ago

  • Related to action #14848: [qam][sle][opensuse][functional][x11regressions]test fails in firefox with what looks like temporary problem to access html5test.com added

#6 Updated by nicksinger over 2 years ago

  • Subject changed from [opensuse][krypton][functional]test fails in firefox - html5test page does not show up, is the address typed at all? to [opensuse][krypton][functional][medium] test fails in firefox - html5test page does not show up, is the address typed at all?
  • Description updated (diff)
  • Status changed from New to In Progress

Current suspect under investigation: wayland. I play a little bit around (removing the switch to wayland before the test, validate manually, etc…) to see if wayland is again involved.

#7 Updated by okurz over 2 years ago

  • Due date changed from 2018-01-16 to 2018-01-30

mass-shift of tickets to next sprint due to training on sprint review day

#8 Updated by okurz over 2 years ago

  • Due date changed from 2018-01-30 to 2018-02-13
  • Target version changed from Milestone 13 to Milestone 14

#9 Updated by JERiveraMoya over 2 years ago

  • Status changed from In Progress to Workable

#10 Updated by JERiveraMoya over 2 years ago

  • Status changed from Workable to In Progress
  • Assignee set to JERiveraMoya

Checking the video is typing "f" and then delete it and then types "efox" with the url, not finding other thing different than firefox home page, what is expected given that the initial search is still there and "Application Firefox" is the only match. VM needs to type this text slower.
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4356(closed due to it would cause unnecessary slowing down of many tests)

#11 Updated by JERiveraMoya over 2 years ago

  • Assignee deleted (JERiveraMoya)

After typing "fox https://html5t" krunner's UI controls looks disabled (gray) for a moment (frozen?). Perhaps the "Software Updates Available" that is prompted during previous tests is affecting it (but just a theory because is not visible in this particular test). It might be some behavior of krunner with auto-completion or some comflict with another UI element. I was not able to reproduce it in my local environment and in production is very sporadic, so I don't know how to proceed forward (without creating too much needles or slowing down many tests). Unassigning myself this ticket so others can provide more ideas.

#12 Updated by mgriessmeier over 2 years ago

  • Status changed from In Progress to Workable

as agreed - we don't want to have tests "in progress" without assignee -> workable

#13 Updated by riafarov over 2 years ago

  • Assignee set to riafarov

#14 Updated by riafarov over 2 years ago

  • Status changed from Workable to In Progress

#15 Updated by riafarov over 2 years ago

  • Status changed from In Progress to Feedback

#16 Updated by riafarov over 2 years ago

  • Status changed from Feedback to Resolved

https://openqa.opensuse.org/tests/607964#step/firefox/2 feel free to reopen if fails again.

#17 Updated by okurz over 1 year ago

  • Related to action #47039: [functional][u] test in vlc wastes 30 seconds without us noticing because of `match_typed` added

Also available in: Atom PDF