action #25972

[opensuse][krypton][functional][medium] test fails in firefox - html5test page does not show up, is the address typed at all?

Added by okurz over 2 years ago. Updated about 2 years ago.

Status:ResolvedStart date:11/10/2017
Priority:HighDue date:13/02/2018
Assignee:riafarov% Done:

0%

Category:Bugs in existing tests
Target version:openQA Project - Milestone 14
Difficulty:
Duration: 90

Description

Observation

openQA test in scenario opensuse-5.11.90-Krypton-Live-x86_64-krypton-live-wayland@64bit_virtio-2G fails in
firefox

Reproducible

Fails since (at least) Build 1.1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #14848: [qam][sle][opensuse][functional][x11regressions]test fail... Resolved 16/11/2016
Related to openQA Tests - action #47039: [functional][u] test in vlc wastes 30 seconds without us ... Resolved 02/02/2019

History

#1 Updated by okurz over 2 years ago

  • Subject changed from [opensuse][krypton]test fails in firefox - html5test page does not show up, is the address typed at all? to [opensuse][krypton][functional]test fails in firefox - html5test page does not show up, is the address typed at all?
  • Target version set to Milestone 12

#2 Updated by jorauch about 2 years ago

#3 Updated by okurz about 2 years ago

  • Due date set to 16/01/2018
  • Target version changed from Milestone 12 to Milestone 13

#4 Updated by okurz about 2 years ago

  • Related to action #14848: [qam][sle][opensuse][functional][x11regressions]test fails in firefox with what looks like temporary problem to access html5test.com added

#6 Updated by nicksinger about 2 years ago

  • Subject changed from [opensuse][krypton][functional]test fails in firefox - html5test page does not show up, is the address typed at all? to [opensuse][krypton][functional][medium] test fails in firefox - html5test page does not show up, is the address typed at all?
  • Description updated (diff)
  • Status changed from New to In Progress

Current suspect under investigation: wayland. I play a little bit around (removing the switch to wayland before the test, validate manually, etc…) to see if wayland is again involved.

#7 Updated by okurz about 2 years ago

  • Due date changed from 16/01/2018 to 30/01/2018

mass-shift of tickets to next sprint due to training on sprint review day

#8 Updated by okurz about 2 years ago

  • Due date changed from 30/01/2018 to 13/02/2018
  • Target version changed from Milestone 13 to Milestone 14

#9 Updated by JERiveraMoya about 2 years ago

  • Status changed from In Progress to Workable

#10 Updated by JERiveraMoya about 2 years ago

  • Status changed from Workable to In Progress
  • Assignee set to JERiveraMoya

Checking the video is typing "f" and then delete it and then types "efox" with the url, not finding other thing different than firefox home page, what is expected given that the initial search is still there and "Application Firefox" is the only match. VM needs to type this text slower.
https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4356(closed due to it would cause unnecessary slowing down of many tests)

#11 Updated by JERiveraMoya about 2 years ago

  • Assignee deleted (JERiveraMoya)

After typing "fox https://html5t" krunner's UI controls looks disabled (gray) for a moment (frozen?). Perhaps the "Software Updates Available" that is prompted during previous tests is affecting it (but just a theory because is not visible in this particular test). It might be some behavior of krunner with auto-completion or some comflict with another UI element. I was not able to reproduce it in my local environment and in production is very sporadic, so I don't know how to proceed forward (without creating too much needles or slowing down many tests). Unassigning myself this ticket so others can provide more ideas.

#12 Updated by mgriessmeier about 2 years ago

  • Status changed from In Progress to Workable

as agreed - we don't want to have tests "in progress" without assignee -> workable

#13 Updated by riafarov about 2 years ago

  • Assignee set to riafarov

#14 Updated by riafarov about 2 years ago

  • Status changed from Workable to In Progress

#15 Updated by riafarov about 2 years ago

  • Status changed from In Progress to Feedback

#16 Updated by riafarov about 2 years ago

  • Status changed from Feedback to Resolved

https://openqa.opensuse.org/tests/607964#step/firefox/2 feel free to reopen if fails again.

#17 Updated by okurz about 1 year ago

  • Related to action #47039: [functional][u] test in vlc wastes 30 seconds without us noticing because of `match_typed` added

Also available in: Atom PDF