Project

General

Profile

action #25450

[sle][functional][medium] test fails in zypper_lr_validate

Added by jorauch about 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Start date:
2017-09-20
Due date:
2018-01-17
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

Adapt the test to SLE15

openQA test in scenario sle-15-Leanos-DVD-x86_64-extra_tests_in_textmode@64bit fails in
zypper_lr_validate

Reproducible

Fails since (at least) Build 264.3 (current job)

Expected result

Last good: https://openqa.suse.de/tests/1359280 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #28988: [qe-core][sle][functional] modify or drop scripted_run_slow function since it makes test module not fail on errorBlocked2017-12-06

History

#1 Updated by okurz about 4 years ago

  • Target version set to Milestone 12

#2 Updated by JERiveraMoya about 4 years ago

It is failing here: https://github.com/os-autoinst/os-autoinst-distri-opensuse/blob/master/lib/utils.pm#L987 when grep tries to highlight some entries based on a pattern that does not match anymore due to changes in name format of SLE-15 repos.
"Pool" and "Updates" seems to be only elements interesting to be match from this list https://github.com/os-autoinst/os-autoinst-distri-opensuse/blob/master/lib/utils.pm#L1113 that are also Enabled Yes regarding the list of repos displayed in the test https://openqa.suse.de/tests/1193249#step/zypper_lr_validate/3

Included within a condition to only be applied to SLE-15 and also only for Pool and Updates, the following modified grep command would highlight the enabled product channels (that in my opinion seems to be the original goal of those lines, correct me if I am wrong):
my $distri = uc(get_var('DISTRI')); // Capital letter, in this case SLE
grep --color \"$distri\[\[:alnum:\]\[:punct:\]\]*-*$version-$product_channel $distri\[\[:alnum:\]\[:punct:\]\[:space:\]\]*-*$version-$product_channel $enabled_repo $uri\"";

#3 Updated by nicksinger about 4 years ago

Still appears in the most recent build (303.1). We should also really consider to improve the output of this module and what it tries to do to ease the process of debugging without digging in the code too much (like it is right now).

#4 Updated by jorauch about 4 years ago

Also appears in toolchain test:
https://openqa.suse.de/tests/1216241#

#5 Updated by okurz about 4 years ago

  • Priority changed from Normal to High

If you continue to comment seems like it's important enough to handle it with "high" value, also because it is the first test module in at least one scenario which fails.

#6 Updated by okurz about 4 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: toolchain_zypper
https://openqa.suse.de/tests/1245488

#7 Updated by okurz about 4 years ago

  • Due date set to 2017-12-06

failing in current tests, let's try to handle in next sprint

#8 Updated by nicksinger about 4 years ago

  • Subject changed from [sle][functional] test fails in zypper_lr_validate - adapt for sle15 to [sle][functional][medium] test fails in zypper_lr_validate - adapt for sle15
  • Status changed from New to In Progress

Looks like that there is just some adjustment in the regex needed. I've adjusted the topic to make this item workable and will try to tackle it.

#9 Updated by Anonymous about 4 years ago

  • Assignee set to Anonymous

#10 Updated by Anonymous almost 4 years ago

  • Priority changed from High to Low

Previously there was a zypper_lr test module, which did basic validation. Since zypper_lr_validate validates the output of certain command, and based on the fact that the test module didn't register as failed but only the command output is empty because of syntax issue, I am lowering the priority here.

#11 Updated by Anonymous almost 4 years ago

JERiveraMoya, could you please point which line numbers should it be for your suggested modifications? (i.e. my $distri ; grep --color )

#13 Updated by okurz almost 4 years ago

Can you please try to find a reference first? I.e. the "Last good" in the description should be found. Therefore I also suggest to verify against that "last good", e.g. SLE 12 SP3 GM.

#14 Updated by Anonymous almost 4 years ago

For SLE12SP3 there was no zypper_lr_validate, but zypper_lr called: https://openqa.suse.de/tests/1058478

#15 Updated by Anonymous almost 4 years ago

When was zypper_lr_validate first used for SLE15, I have no idea. From the failed test in the description for Build264.3 there's no previous results recorded. The previous tests were incomplete. There's no reference.

#16 Updated by Anonymous almost 4 years ago

This change didn't work for SLE12: http://f146.suse.de/tests/1756. Can someone also have a look and give any hint about it?

#17 Updated by okurz almost 4 years ago

  • Due date changed from 2017-12-06 to 2017-12-19

SR: suggested to move to next sprint, maybe mnowak can help when he returns from vacation

#18 Updated by Anonymous almost 4 years ago

  • Subject changed from [sle][functional][medium] test fails in zypper_lr_validate - adapt for sle15 to [sle][functional][medium] test fails in zypper_lr_validate

For SLE15 the grep command greps the repos with update or pool, however for SLS12 this command won't find anything from repo with name like SLES12-SP3-12.3-0.

The approach: we can leave the PR only for SLE15: grep --color \"$distri[[:alnum:][:punct:]]-$version-$product_channel $distri[[:alnum:][:punct:][:space:]]-$version-$product_channel $enabled_repo
And write a new line for SLE12.

Or re-enable zypper_lr.pm for SLE12 and only call zypper_lr_validate for SLE15 and newer products.

#19 Updated by Anonymous almost 4 years ago

  • Related to action #28988: [qe-core][sle][functional] modify or drop scripted_run_slow function since it makes test module not fail on error added

#20 Updated by Anonymous almost 4 years ago

  • Priority changed from Low to Normal

#21 Updated by SLindoMansilla almost 4 years ago

  • Status changed from In Progress to Feedback
  • Assignee changed from Anonymous to JERiveraMoya

Waiting for update of PR by yi.

jrivera could take over the ticket.

#22 Updated by Anonymous almost 4 years ago

PR updated.

#23 Updated by JERiveraMoya almost 4 years ago

Comments provided in the PR.

#24 Updated by SLindoMansilla almost 4 years ago

jrivera, just in case, I have a backup of the branches in my repo where you could pull them from: https://github.com/SergioAtSUSE/os-autoinst-distri-opensuse/tree/zypper_lr

#25 Updated by okurz almost 4 years ago

  • Due date changed from 2017-12-19 to 2018-01-17
  • Status changed from Feedback to New

@JERiveraMoya please make it a workable item, e.g. update the "expected result"

#26 Updated by JERiveraMoya almost 4 years ago

  • Description updated (diff)
  • Status changed from New to Workable

#28 Updated by JERiveraMoya almost 4 years ago

  • Status changed from Workable to Blocked

#29 Updated by JERiveraMoya almost 4 years ago

  • Status changed from Blocked to Feedback

#30 Updated by JERiveraMoya almost 4 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF