Project

General

Profile

coordination #23820

[sle][functional][sle15][epic]update yast2_ui for sle15

Added by okurz about 4 years ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Start date:
2017-09-25
Due date:
2017-12-06
% Done:

100%

Estimated time:
(Total: 0.00 h)
Difficulty:

Description

Observation

openQA test in scenario sle-15-Leanos-DVD-x86_64-yast2_ui@64bit fails in
yast2_proxy
now as the first failing test

Reproducible

Fails since Build 173.8 (current job) the first time ever we reached that far since SLE 12 SP3

Expected result

Last good: SLE 12 SP3 GM

Further details

Always latest result in this scenario: latest


Subtasks

action #25562: [sle][functional][sle15] update yast2_tftp.pm for sles 15Resolvedokurz

action #25672: [sle][functional][sle15][leap][medium] adjust yast2_control-center test module for SLE 15 and leapResolvedriafarov


Related issues

Related to openQA Tests - action #19922: [sle][functional][opensuse]Harmonize extratests/yast2_ui tests for openSUSE and SLEResolved2017-06-202017-10-25

Blocked by openQA Tests - coordination #23864: [sle][functional][sle15][epic] all needles for yast2_gui test need to replaced because of product changesResolved2017-09-28

Blocks openQA Tests - action #23852: [sle][functional][sle15] yast2_ui test - ntpclient failedResolved2017-09-012017-12-19

History

#1 Updated by zluo about 4 years ago

As I can see there is only a couple of yast2 modules passed testing.
Need to investigate all failed tests and provide fix or bug reports.

#2 Updated by zluo about 4 years ago

  • Assignee set to zluo

I will create sub tasks for this ticket.

#3 Updated by zluo about 4 years ago

  • Status changed from New to In Progress

for yast2_proxy I filed bug report:
https://bugzilla.suse.com/show_bug.cgi?id=1056793

#4 Updated by zluo about 4 years ago

  • Related to action #23852: [sle][functional][sle15] yast2_ui test - ntpclient failed added

#5 Updated by zluo about 4 years ago

for yast2_tftp I filed bug report:
https://bugzilla.suse.com/show_bug.cgi?id=1056801

#6 Updated by zluo about 4 years ago

for yast2_vnc I filed a bug report:
https://bugzilla.suse.com/show_bug.cgi?id=1056806

#7 Updated by zluo about 4 years ago

  • Related to action #23858: sles 15 - yast2_ui test - yast2_lan_hostname got failed added

#8 Updated by zluo about 4 years ago

  • Related to action #23860: sles 15 yast2_ui test - yast2_nis got failed added

#9 Updated by zluo about 4 years ago

  • Related to coordination #23864: [sle][functional][sle15][epic] all needles for yast2_gui test need to replaced because of product changes added

#10 Updated by zluo about 4 years ago

yast2_gui tests are blocked because of following issue:
it seems that yast2 launch doesn't work.

https://bugzilla.suse.com/show_bug.cgi?id=1057400

#11 Updated by zluo about 4 years ago

for SLE 15 we have now issue for yast2_xinetd:

https://bugzilla.suse.com/show_bug.cgi?id=1057550

#12 Updated by zluo about 4 years ago

just for record: issue for running yast bootloader
https://bugzilla.suse.com/show_bug.cgi?id=1057604

this could block yast ui later...

#13 Updated by okurz about 4 years ago

  • Due date set to 2017-09-27
  • Priority changed from Normal to High

so we have a lot of product bugs and we should consider to be blocked by this. I suggest to also link other progress tickets to each other using "Blocked by" and "Blocking".

exit criteria:

  • make sure we do not have progress tickets for product bugs
  • existing valid test issues are either in a workable state or blocked by product bugs

#14 Updated by zluo about 4 years ago

  • Related to deleted (action #23852: [sle][functional][sle15] yast2_ui test - ntpclient failed)

#15 Updated by zluo about 4 years ago

  • Related to deleted (action #23858: sles 15 - yast2_ui test - yast2_lan_hostname got failed)

#16 Updated by zluo about 4 years ago

  • Related to deleted (action #23860: sles 15 yast2_ui test - yast2_nis got failed)

#17 Updated by SLindoMansilla about 4 years ago

Since this ticket has high priority, I would like to help you finish it within this sprint.
Please inform me about the current status of your work in relation with this ticket.

#18 Updated by zluo about 4 years ago

  • Related to deleted (coordination #23864: [sle][functional][sle15][epic] all needles for yast2_gui test need to replaced because of product changes)

#19 Updated by zluo about 4 years ago

  • Blocked by coordination #23864: [sle][functional][sle15][epic] all needles for yast2_gui test need to replaced because of product changes added

#20 Updated by okurz about 4 years ago

  • Related to action #19922: [sle][functional][opensuse]Harmonize extratests/yast2_ui tests for openSUSE and SLE added

#21 Updated by okurz about 4 years ago

  • Blocks action #23852: [sle][functional][sle15] yast2_ui test - ntpclient failed added

#22 Updated by SLindoMansilla about 4 years ago

  • Status changed from In Progress to Feedback

Status Feedback since this ticket is blocked by https://progress.opensuse.org/issues/23864, which is blocked by https://bugzilla.suse.com/show_bug.cgi?id=1059071

#23 Updated by okurz about 4 years ago

  • Target version set to Milestone 11

#24 Updated by okurz about 4 years ago

  • Status changed from Feedback to In Progress
  • Assignee changed from zluo to okurz

I have some changes prepared to various ncurses modules that I want to provide today

#25 Updated by okurz about 4 years ago

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3640 and https://gitlab.suse.de/openqa/os-autoinst-needles-sles/merge_requests/505 for some fixes, some soft-fails and some better investigation approaches. merged.

Triggered as https://openqa.suse.de/tests/1190101#live

EDIT: So that passed already more modules than in before so an improvement :-)

#26 Updated by okurz about 4 years ago

  • Assignee deleted (okurz)

retriggered: https://openqa.suse.de/tests/1190902

Two modules are still failing:

  • yast2_nis
  • yast2_dns_server

All other test modules are either passed or soft-failed with a proper bugref. I will leave the other two modules to others to pick up.

#27 Updated by zluo about 4 years ago

  • Subject changed from [sle][functional][sle15]update yast2_ui for sle15 to [sle][functional][sle15][epic]update yast2_ui for sle15

#28 Updated by okurz about 4 years ago

  • Status changed from In Progress to Feedback
  • Assignee set to zluo

again blocked by product either never reaching the point of yast2_gui or being blocked by yast2_gui specific bugs. -> on feedback until we have resolved at least https://bugzilla.suse.com/show_bug.cgi?id=1062733

#29 Updated by okurz about 4 years ago

  • Due date set to 2017-11-08

due to changes in a related task

#30 Updated by okurz about 4 years ago

  • Status changed from Feedback to In Progress
  • Assignee deleted (zluo)

new sprint, new game.

https://openqa.suse.de/tests/1226873#step/yast2_control_center/13 shows that we need a needle update here.

#31 Updated by okurz about 4 years ago

  • Due date changed from 2017-11-08 to 2017-11-22

due to changes in a related task

#32 Updated by okurz about 4 years ago

  • Target version changed from Milestone 11 to Milestone 12

#33 Updated by okurz about 4 years ago

  • Due date changed from 2017-11-22 to 2017-12-06

due to changes in a related task

#35 Updated by okurz almost 4 years ago

  • Assignee set to riafarov

SR: please link the corresponding tickets

#36 Updated by riafarov almost 4 years ago

  • Status changed from In Progress to Resolved

All tickets will be addressed in one big epic: https://progress.opensuse.org/issues/27074 as we have two to avoid any possible confusion.

#37 Updated by szarate about 1 year ago

  • Tracker changed from action to coordination

Also available in: Atom PDF