Project

General

Profile

action #23736

coordination #18602: [sles][functional][epic]review existing autoyast tests (was: test fails in repos because ip and tar is not installed)

[sle][functional] Adjust autoinst profiles for sle 15

Added by riafarov about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Start date:
2017-08-28
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

At the moment, there is no single autoyast profile which works with sle 15.
Some of them require adjustments, some will reveal product bugs.

Acceptance criteria:

  • For all existing test suites in SLE 15 Functional and Development / Regression: Autoyast job groups review profiles
  • Either adjust profiles and create sle15 specific versions of those
  • Create a bug
  • Remove test suite from sle 15 related job groups is scenario is irrelevant

Related issues

Related to openQA Tests - action #20830: [tools][sles][functional]Get rid of version specific prefix in test suite names when the test suites also apply for other versionsResolved2017-06-11

Related to openQA Tests - coordination #20580: [sle][functional][epic] sle 15 setupResolved2017-07-202017-09-27

Related to openQA Tests - action #27505: [sle][functional][y][autoyast][fast] Modify autoyast profiles during the runResolved2017-11-082018-05-22

Has duplicate openQA Tests - action #23722: [sle][functional][sle15] Update autoyast profiles to be compatible with SLE15Resolved2017-08-282017-12-19

History

#1 Updated by riafarov about 4 years ago

  • Related to action #20830: [tools][sles][functional]Get rid of version specific prefix in test suite names when the test suites also apply for other versions added

#2 Updated by riafarov about 4 years ago

#3 Updated by riafarov about 4 years ago

Verified 7 profiles and filed bugs for following jobs, if we ignore known issues for some of them installation will work:
sles12_autoyast_bug-872532 - doesn't work
sles12_autoyast_bug-877438 - works
sles12_autoyast_bug-879147 - possible to complete installation
sles12_autoyast_bug-887126 - doesn't work
sles12_autoyast_bug-887653 - possible to complete installation
sles12_autoyast_mini - works
sles12sp2_autoyast_bug-876 - doesn't work

As next step we should introduce workaround for same 2 bugs which prevent system from installation:
https://bugzilla.suse.com/show_bug.cgi?id=1047327
https://bugzilla.suse.com/show_bug.cgi?id=1055034
So automated tests will show more issues, which expose current development stage.

#4 Updated by riafarov about 4 years ago

  • Status changed from New to In Progress

Adjusted to ignore same issues as we have in normal installer, namely missing packages and not able to set patterns.

#5 Updated by riafarov about 4 years ago

  • Status changed from In Progress to Feedback

Wait for fixes or way to adjust profiles.

#6 Updated by riafarov about 4 years ago

  • Status changed from Feedback to Resolved

All autoyast tests fail with relevant bugs now. When there is any update on bugs solutions, how to proceed with certain profile, we should target these in individual tickets.

#7 Updated by okurz about 4 years ago

  • Due date set to 2017-11-08
  • Status changed from Resolved to In Progress

I thought the idea was to get rid of "sle12" in profile names? This is why we have split this ticket out of #20830 which is about "get rid of sle12 prefix in testsuites". I get questions by colleagues what it means if a test suite is called "sle12_something" and it's applied to sle15. Can you please take care?

#8 Updated by riafarov about 4 years ago

okurz I'm not sure if it's correct to reopen the ticket which is one month old. But at that point of time we've done everything we could. Now it's clear that all profiles have to be changed for sle 15, hence they will get new prefix. We also will need to create new test suites set or use some version magic. But fine with me, we can proceed with this ticket.

#9 Updated by riafarov about 4 years ago

https://www.suse.com/documentation/sles-12/singlehtml/book_autoyast/book_autoyast.html documentation how to register system and select modules.

#10 Updated by riafarov about 4 years ago

  • Related to action #27076: [tools][functional][hard] Add functionality to be able to modify data available via http in share directory added

#11 Updated by riafarov about 4 years ago

For SLE15 following changes have to be introduced in order to make sle12 specific profiles work:

  1. Add <suse_register> section to register SUT to be able to add modules:
  <suse_register>
      <do_registration config:type="boolean">true</do_registration>
      <email></email>
      <reg_code>{{REG_CODE}}</reg_code>
      <install_updates config:type="boolean">true</install_updates>
      <reg_server>http://all-321.5.proxy.scc.suse.de</reg_server> <!-- Required for getting correct packages -->
  </suse_register>
  1. Add <product>SLES15</product> under <software> for sles.

This brings a need to modify autoyast profiles before the installation in order to insert non-public data (e.g. reg code), and/or test scenario specific variable (e.g. architecture and version for module).

The solution which is preferable at the moment is to use one test suite which modifies the profiles and uploads them as assets and chained jobs use them for installation.
We will try to estimate implementation in api, so we could do that on the fly in single test suite, but solution mentioned about is already available and will work.

#12 Updated by okurz about 4 years ago

With the need to do the registration during installation and our hesitation to put the regcode into profiles into a public repo I wonder how customers see it because they basically have a similar problem then or would they use the all-packages-iso in such case to do the initial installation?

#13 Updated by riafarov about 4 years ago

  • Related to deleted (action #27076: [tools][functional][hard] Add functionality to be able to modify data available via http in share directory)

#14 Updated by riafarov about 4 years ago

  • Blocked by action #27076: [tools][functional][hard] Add functionality to be able to modify data available via http in share directory added

#15 Updated by riafarov about 4 years ago

  • Status changed from In Progress to Feedback

For SLE15 we need to introduce information for registration, modules into the profiles which differ for architectures. As an alternative we could use chained test suites or support server. However, support server does variables expansion using apache features, and would introduce more load on multimachine capable workers. Chained jobs is better solution than support server, and basic sharing modified autoyast profile will work, whereas this approach won't work for class based autoyast installations. So it was decided to introduce changes to the openQA backend:
https://github.com/os-autoinst/os-autoinst/pull/877

After changes are introduced, we can use CASEDIR and AUTOYAST variables to read profile and then use autoinst_url to set url to modified file which will be used for installation.

#16 Updated by riafarov about 4 years ago

okurz I believe common scenario will be to use registration data in the profile (or addons urls, as they are generated when cloning the system). I'll check if all packages iso can help here, as we still need to point to the media in some way.

#17 Updated by riafarov about 4 years ago

Following 3 test suites use same autoyast profile:
autoyast+supportserver
gnome_http_autoyast
autoyast_gnome

Leaving only autoyast_gnome

#18 Updated by riafarov about 4 years ago

For the profiles which are not blocked by bugs we've proposed a temporary solution which uses all packages DVD. See https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3865

#19 Updated by riafarov about 4 years ago

Temporary solution for profiles here: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3865
Needs test suites settings adjustment. Once we have changes in openQA, we can modify profile in the runtime.

#20 Updated by riafarov about 4 years ago

  • Due date deleted (2017-11-08)

As per okurz, we remove ticket from sprint back log. Try the first approach with all packages iso first and create a new ticket to modify templates during the runtime.

#21 Updated by riafarov about 4 years ago

  • Blocked by deleted (action #27076: [tools][functional][hard] Add functionality to be able to modify data available via http in share directory)

#22 Updated by riafarov about 4 years ago

  • Related to action #27505: [sle][functional][y][autoyast][fast] Modify autoyast profiles during the run added

#23 Updated by riafarov about 4 years ago

Better approach with runtime modification of profiles will be implemented in another ticket, please see https://progress.opensuse.org/issues/27505

#24 Updated by okurz about 4 years ago

  • Target version set to Milestone 12

#25 Updated by riafarov about 4 years ago

  • Status changed from Feedback to Resolved

All profiles in distri repo adjusted to use all packages iso, all test suites properly labeled: https://openqa.suse.de/tests/overview?distri=sle&version=15&build=333.2&groupid=129

Next enhancements will be implemented in this ticket: https://progress.opensuse.org/issues/27505

#26 Updated by okurz about 4 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: autoyast_lvm
https://openqa.suse.de/tests/1268995

#27 Updated by riafarov almost 4 years ago

  • Has duplicate action #23722: [sle][functional][sle15] Update autoyast profiles to be compatible with SLE15 added

Also available in: Atom PDF