Project

General

Profile

action #19438

[tools][sle][functional][aarch64]double key press, test fails in xorg_vt typing "pps" instead of "ps"

Added by okurz almost 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Infrastructure
Start date:
2017-05-30
Due date:
2018-01-16
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP3-Server-DVD-aarch64-cryptlvm_minimal_x@aarch64 fails in
xorg_vt

Reproducible

Fails since (at least) Build 0405 (current job)

Expected result

Last good: 0402 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #26856: [qam] test fails in wireshark - assert_script_run not typing command correctlyRejected2017-10-19

History

#1 Updated by okurz over 4 years ago

  • Related to action #26856: [qam] test fails in wireshark - assert_script_run not typing command correctly added

#2 Updated by okurz over 4 years ago

  • Subject changed from [aarch64]double key press, test fails in xorg_vt typing "pps" instead of "ps" to [tools][sle][functional][aarch64]double key press, test fails in xorg_vt typing "pps" instead of "ps"

same problem now in https://openqa.suse.de/tests/1235702#step/textinfo/6 in the curl URL. Compare the two URLs in the two subsequent curl calls. In the second one there is a doubled "h" which therefore resolves to an invalid URL.

#3 Updated by okurz over 4 years ago

  • Category changed from Bugs in existing tests to Infrastructure
  • Priority changed from Normal to High

#4 Updated by okurz over 4 years ago

  • Due date set to 2017-11-22
  • Target version set to Milestone 12

#5 Updated by JERiveraMoya over 4 years ago

VNC_TYPING_LIMIT already set to 10 for this job. It is a known issue in OpenQA api. When new build with aarch64 architecture will be available I will be able to retrigger the job lowering VNC_TYPING_LIMIT to 7.

#6 Updated by JERiveraMoya over 4 years ago

  • Assignee set to JERiveraMoya

#7 Updated by JERiveraMoya over 4 years ago

  • Status changed from New to In Progress

#8 Updated by okurz over 4 years ago

  • Due date deleted (2017-11-22)

#9 Updated by sebchlad over 4 years ago

  • Due date set to 2017-12-22

#10 Updated by JERiveraMoya over 4 years ago

Cannot see this failure anymore, not even in sle12sp4, at least in the mentioned job.

#11 Updated by okurz over 4 years ago

  • Due date changed from 2017-12-22 to 2018-01-30
  • Target version changed from Milestone 12 to Milestone 13

To my understanding aarch64 should not behave different than x86_64 therefore no special VNC_TYPING_LIMIT should be applied unless we know a specific problem which should then be handled in os-autoinst. I suggest the following:

  • Trigger 100-1000 jobs on aarch64 with VNC_TYPING_LIMIT= (unset) and check if there are any failures
  • If yes, find the specific reason and comment that into the backend or at least a comment next to the openQA settings
  • If no, remove the override of VNC_TYPING_LIMIT completely for osd and o3

To trigger many jobs an example:

for i in {1..100}; do openqa-clone-job --skip-chained-deps --from https://openqa.suse.de --host https://openqa.suse.de --skip-download 1356341 VNC_TYPING_LIMIT= TEST=test_poo19438_jeriveramoya_$i _GROUP="Test Development: SLE 15" BUILD=XXX@test_poo19438 ; done

#12 Updated by JERiveraMoya over 4 years ago

#13 Updated by okurz over 4 years ago

that did not seem to work. Some incompletes. Looks like the ISO can not be found in the pool directory. Maybe the original job does not have the ISO as well anymore? You could select a SLE15 corresponding job if that one has the ISO still.

#14 Updated by JERiveraMoya over 4 years ago

I realized that the sample code was cloning a sle12sp4 job in sle15 development group so I edited the link (while you were writing probably :))
I used sle12 sp4 that is where the error was found originally. No incomplete atm: https://openqa.suse.de/tests/overview?version=12-SP4&groupid=132&build=XXX%40test_poo19438&distri=sle

#15 Updated by JERiveraMoya over 4 years ago

It looks good except for some incomplete and one failure tests, but not related with typing. Removed setting VNC_TYPING_LIMIT for aarch64 in Machines configuration in OSD.

#16 Updated by JERiveraMoya over 4 years ago

  • Due date changed from 2018-01-30 to 2018-01-16
  • Status changed from In Progress to Feedback

#17 Updated by JERiveraMoya over 4 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF