Project

General

Profile

action #16602

Comment with unicode characters do not work because of an error in rabbitmq client (was: The comment couldn't be updated: Internal Server Error on openqa.suse.de.)

Added by xlai over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Concrete Bugs
Target version:
Start date:
2017-02-09
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

observation

An error message is reported when I updated result for a build on virtualization group on openqa.suse.de

What was typed on comment:

**Date:** <2017-02-09>

**Build:** 0234

**Arch:** x86_64 

**Status: <font color="red">Red</font>


**New Product bugs:**

* No

**Requirement:**

* one more ipmi machine: poo#15376

**Existing Product bugs:**

* sles12sp3 pv guest installation: bsc#1012005
* pvusb bug on sles12sp3 xen: bsc#1023948



**Existing openqa issues:**

* guest migration job fail/multi-machine:    poo#15376
* ipmi ikvm unstable:    poo#14338
* ipmi serial console unstable:    poo#13914
* ipmi keyboard simulator unstable:    poo#12982 poo#16088

steps to reproduce

  • on an openQA instance with enabled rabbitmq plugin
  • type character '/' in any comment
  • observe reported error

problem

H1. Mojo::RabbitMQ::Client does not handle unicode input correctly
https://github.com/inway/mojo-rabbitmq-client/commit/c043447d4fa53a1456515c4def1c4d1367cd87b0#commitcomment-20829251
H2. lib/OpenQA/WebAPI/Plugin/AMQP.pm does not forward unicode correctly to Mojo::RabbitMQ::Client

workaround

only type ascii within comments.

History

#2 Updated by xlai over 5 years ago

But I can update common comments like 'test'.

Besides, Oliver, if you think you should not be the target issue owner, please help to assign to others. Thanks in advance.

#3 Updated by okurz over 5 years ago

  • Project changed from openQA Tests to openQA Project
  • Subject changed from The comment couldn't be updated: Internal Server Error on openqa.suse.de. to Comment with unicode characters do not work because of an error in rabbitmq clilent (was: The comment couldn't be updated: Internal Server Error on openqa.suse.de.)
  • Category changed from Infrastructure to Concrete Bugs
  • Assignee changed from okurz to mkittler
  • Priority changed from Normal to High
  • Target version set to Milestone 5

xlai wrote:

Besides, Oliver, if you think you should not be the target issue owner, please help to assign to others. Thanks in advance.

no problem.

From the screenshot I can see the time to be "10:20 AM Bejing" which I assume is 2017-02-09 10:20 AM CST so corresponding to 2017-02-09 03:20 CET

From this time on osd taking a look into the logfile /var/log/openqa I can find

[Thu Feb  9 03:17:11 2017] [21168:error] Wide character in subroutine entry at /usr/lib/perl5/vendor_perl/5.18.2/Mojo/RabbitMQ/Client.pm line 457.
[Thu Feb  9 03:17:20 2017] [22463:info] Connecting to AMQP server
[Thu Feb  9 03:17:20 2017] [22463:info] AMQP connection established
[Thu Feb  9 03:17:42 2017] [20431:error] Wide character in subroutine entry at /usr/lib/perl5/vendor_perl/5.18.2/Mojo/RabbitMQ/Client.pm line 457.
[Thu Feb  9 03:18:04 2017] [websockets:debug] Worker overdrive2:5 not seen since 18319 seconds
[Thu Feb  9 03:18:04 2017] [websockets:debug] Worker overdrive2:2 not seen since 49879 seconds
[Thu Feb  9 03:18:04 2017] [websockets:debug] Worker overdrive2:3 not seen since 39347 seconds
[Thu Feb  9 03:18:04 2017] [websockets:debug] Worker openqaworker2:17 not seen since 922 seconds
[Thu Feb  9 03:18:07 2017] [20844:error] Wide character in subroutine entry at /usr/lib/perl5/vendor_perl/5.18.2/Mojo/RabbitMQ/Client.pm line 457.
[Thu Feb  9 03:18:30 2017] [20974:error] Wide character in subroutine entry at /usr/lib/perl5/vendor_perl/5.18.2/Mojo/RabbitMQ/Client.pm line 457.
[Thu Feb  9 03:18:43 2017] [20845:error] Wide character in subroutine entry at /usr/lib/perl5/vendor_perl/5.18.2/Mojo/RabbitMQ/Client.pm line 457.
[Thu Feb  9 03:19:13 2017] [22463:error] Wide character in subroutine entry at /usr/lib/perl5/vendor_perl/5.18.2/Mojo/RabbitMQ/Client.pm line 457.
[Thu Feb  9 03:19:31 2017] [20974:error] Wide character in subroutine entry at /usr/lib/perl5/vendor_perl/5.18.2/Mojo/RabbitMQ/Client.pm line 457.

and also I see in your screenshot as well as the content that you provided that you are using an uncommon backward diagonal line character which is not the standard /.
This yields an error in the rabbit mq plugin which does not expect non-ascii characters, it seems.

workaround

only type ascii within comments.

#4 Updated by xlai over 5 years ago

  • Project changed from openQA Project to openQA Tests
  • Category deleted (Concrete Bugs)
  • Assignee changed from mkittler to okurz
  • Priority changed from High to Normal
  • Target version deleted (Milestone 5)

and also I see in your screenshot as well as the content that you provided that you are using an uncommon backward diagonal line character / which is not the standard /

Yes, it contained that. However I could comment such a message successfully for build 0209 result 23 days ago.

Today I have a look at the comments for virtualization group. It is weird that yesterday's fail-to-add comment (the one i pasted) shows up, however with 3 copies. And unable to delete.

#5 Updated by xlai over 5 years ago

  • Project changed from openQA Tests to openQA Project
  • Category set to Concrete Bugs
  • Assignee changed from okurz to mkittler
  • Priority changed from Normal to High
  • Target version set to Milestone 5

#6 Updated by okurz over 5 years ago

  • Subject changed from Comment with unicode characters do not work because of an error in rabbitmq clilent (was: The comment couldn't be updated: Internal Server Error on openqa.suse.de.) to Comment with unicode characters do not work because of an error in rabbitmq client (was: The comment couldn't be updated: Internal Server Error on openqa.suse.de.)

#7 Updated by okurz over 5 years ago

  • Description updated (diff)

#8 Updated by coolo over 5 years ago

commenting unrelated commits won't help

#9 Updated by okurz over 5 years ago

Just imagine I am stupid and did not know any better.

#10 Updated by dheidler over 5 years ago

  • Status changed from New to In Progress
  • Assignee changed from mkittler to dheidler
  • % Done changed from 0 to 80

#11 Updated by dheidler over 5 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 80 to 100

merged.

Also available in: Atom PDF