Project

General

Profile

Actions

action #161756

closed

QA - coordination #121720: [saga][epic] Migration to QE setup in PRG2+NUE3 while ensuring availability

QA - coordination #123800: [epic] Provide SUSE QE Tools services running in PRG2 aka. Prg CoLo

QA - coordination #137630: [epic] QE (non-openQA) setup in PRG2

IPMI access over IPv6 doesn't work on blackbauhinia size:S

Added by okurz about 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
Start date:
2024-04-24
Due date:
% Done:

0%

Estimated time:
Tags:

Description

Observation

In #153739 blackbauhinia was setup from PRG2e but blackbauhinia-ipmi.qe.prg2.suse.org is only reachable when restricting to IPv4. We should ensure that blackbauhinia-ipmi.qe.prg2.suse.org is reachable without needing to restrict to only IPv4.

Acceptance criteria

  • AC1: blackbauhinia-ipmi.qe.prg2.suse.org is reachable without needing to restrict to only IPv4

Suggestions

https://imagetester-sp.qe.nue2.suse.org was confirmed to be working using IPv6, confirmed over developer tools, by mkittler and okurz but ipmitool using credentials from https://gitlab.suse.de/openqa/salt-pillars-openqa/-/merge_requests/793/diffs does not seem to work, though IPv4 works.

Suggestions


Related issues 2 (0 open2 closed)

Related to QA - action #153739: Move of openqa.opensuse.org machine NUE1 to PRG2 - blackbauhiniaResolvedokurz2024-01-16

Actions
Copied from openQA Infrastructure - action #159555: IPMI access over IPv6 doesn't work on imagetester - try to update BIOS with physical access size:SResolvedokurz2024-04-24

Actions
Actions #1

Updated by okurz about 2 months ago

  • Copied from action #159555: IPMI access over IPv6 doesn't work on imagetester - try to update BIOS with physical access size:S added
Actions #2

Updated by okurz about 2 months ago

  • Target version changed from Ready to Tools - Next
Actions #3

Updated by okurz about 2 months ago

  • Related to action #153739: Move of openqa.opensuse.org machine NUE1 to PRG2 - blackbauhinia added
Actions #4

Updated by Julie_CAO about 1 month ago

@nanzhang Could you help with updating BMC on this machine?

Actions #5

Updated by nanzhang about 1 month ago

Julie_CAO wrote in #note-4:

@nanzhang Could you help with updating BMC on this machine?

Hi Julie,
I've updated bmc and bios firmware for blackbauhinia. You can try your test again.
iDARC: 7.10.30.00
BIOS: 2.14.1

Actions #6

Updated by Julie_CAO about 1 month ago

Thank Nan for the update. but we still had not luck, ipmitool did not work, even with "ipmitool mc reset cold".

https://10.145.10.207/tests/14550493

[2024-06-07T07:59:35.727686+02:00] [info] [pid:117557] ::: backend::baseclass::die_handler: Backend process died, backend errors are reported below in the following lines:
  ipmitool -I lanplus -H blackbauhinia-ipmi.qe.prg2.suse.org -U root -P [masked] mc guid: Error: Unable to establish IPMI v2 / RMCP+ session at /usr/lib/os-autoinst/backend/ipmi.pm line 45.

@okurz, could you help from your side?

Actions #7

Updated by okurz about 1 month ago

  • Target version changed from Tools - Next to Ready

We will. This ticket will be looked into by the tools team in the upcoming days/weeks

Actions #8

Updated by okurz about 1 month ago

  • Subject changed from IPMI access over IPv6 doesn't work on blackbauhinia to IPMI access over IPv6 doesn't work on blackbauhinia size:S
  • Status changed from New to Workable
Actions #9

Updated by mkittler about 1 month ago

  • Status changed from Workable to In Progress
  • Assignee set to mkittler
Actions #10

Updated by mkittler about 1 month ago · Edited

According to page 150 on https://dl.dell.com/content/manual54104854-benutzerhandbuch-f%C3%BCr-integrated-dell-remote-access-controller-9.pdf?language=de-de IPv6 is supported:

ANMERKUNG: Ab iDRAC-Version 2.30.30.30 unterstützt IPMI das IPv6-Adressprotokoll für Linux-basierte Betriebssysteme.

IPv6 is also enabled in the connectivity settings and also DHCP to get an IPv6 address. Not sure why it isn't working.

EDIT: Looks like disabling IPv6 and enabling it again was a bad idea. Now the management interface is not reachable anymore.

EDIT: It came back. On a closer look it seems that the IPv6 address the machine has is not in accordance with what host tells me. That's probably the problem. I can actually connect via the actual IPv6 just fine (via SSH and ipmitool -I lanplus -H 2a07:de40:b230:1:a330:366a:a0aa:40ab -U root -P '…' sol activate).

EDIT: Not sure why it doesn't take the address from the DHCP server. I played around with the settings but nothing worked. I suppose DHCPv6 needs to be enabled but that was actually enabled from the beginning. Not sure what the relevant DHCP server is. Maybe suttner1.oqa.prg2.suse.org but I couldn't see anything relevant messages in the dhcpd log there.

Actions #11

Updated by mkittler about 1 month ago

  • Status changed from In Progress to Resolved

I gave up and just configured "our" IPv6 statically. Now everything works - even access using the other previously assigned address which now shows up as "IP-Adresse 2" on the web UI within the IPv6 panel. I think that's good enough.

Actions

Also available in: Atom PDF