Project

General

Profile

Actions

action #159555

closed

QA - coordination #121720: [saga][epic] Migration to QE setup in PRG2+NUE3 while ensuring availability

QA - coordination #129280: [epic] Move from SUSE NUE1 (Maxtorhof) to new NBG Datacenters

IPMI access over IPv6 doesn't work on imagetester - try to update BIOS with physical access size:S

Added by okurz about 2 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Regressions/Crashes
Target version:
Start date:
2024-04-24
Due date:
% Done:

0%

Estimated time:

Description

Observation

https://imagetester-sp.qe.nue2.suse.org was confirmed to be working using IPv6, confirmed over developer tools, by mkittler and okurz but ipmitool using credentials from https://gitlab.suse.de/openqa/salt-pillars-openqa/-/merge_requests/793/diffs does not seem to work, though IPv4 works.

Suggestions


Related issues 3 (0 open3 closed)

Related to openQA Infrastructure - action #159270: openqaworker-arm-1 is Unreachable size:SResolvedybonatakis2024-04-19

Actions
Related to QA - action #156250: Ensure IPv6 works in qe.nue2.suse.orgResolvedokurz2024-02-28

Actions
Copied to openQA Infrastructure - action #161756: IPMI access over IPv6 doesn't work on blackbauhinia size:SResolvedmkittler2024-04-24

Actions
Actions #1

Updated by okurz about 2 months ago

  • Tags set to infra, ipmi, ipv6
  • Description updated (diff)
  • Category set to Regressions/Crashes
  • Target version set to Ready
Actions #2

Updated by okurz about 2 months ago

  • Related to action #159270: openqaworker-arm-1 is Unreachable size:S added
Actions #3

Updated by okurz about 2 months ago

  • Related to action #156250: Ensure IPv6 works in qe.nue2.suse.org added
Actions #4

Updated by okurz about 2 months ago

  • Parent task set to #129280
Actions #5

Updated by nicksinger about 2 months ago

  • Description updated (diff)
Actions #6

Updated by nicksinger about 2 months ago

  • Status changed from New to In Progress
  • Assignee set to nicksinger

quickly giving a FW upgrade a try. We're still on 2.5 on that machine and thomas-krenn.com offers a download for 3.16

Actions #7

Updated by okurz about 2 months ago

  • Subject changed from IPMI access over IPv6 seems to not work to IPMI access over IPv6 doesn't work on imagetester size:S
  • Description updated (diff)
Actions #8

Updated by nicksinger about 2 months ago

  • Tags changed from infra, ipmi, ipv6 to infra, ipmi, ipv6, next-frankencampus-visit
  • Subject changed from IPMI access over IPv6 doesn't work on imagetester size:S to IPMI access over IPv6 doesn't work on imagetester - try to update BIOS with physical access size:S
  • Status changed from In Progress to Workable
  • Assignee deleted (nicksinger)
  • Priority changed from Normal to Low

firmware update was successful. Unfortunately every described step I found regarding enabling IPv6 for RMCP did not work on that machine (mostly missing options or commands ending up in errors) - so I assume this machine is just too old. There is a new BIOS available too but the process of installing it requires you to boot DOS (or windows 98…) and execute supermicros special flash-script. I tried to archive this with remotely mounting a FreeDOS ISO but then failed to provide the necessary tools from supermicro so I gave up and created: https://gitlab.suse.de/OPS-Service/salt/-/merge_requests/5036

Maybe the BIOS update can be done in person next time somebody feels adventurous in FC Labs - the files for it can be downloaded here: https://www.thomas-krenn.com/de/download.html?manufacturer=5&category=82&product=8032

Since we can technically still do something I'm putting this back into our queue but with low prio.

Actions #9

Updated by okurz about 2 months ago · Edited

  • Status changed from Workable to In Progress
  • Assignee set to okurz

wine was not successful

2024-04-25 11:05:19.110 | DISPLAY: Initialized 758x569 window-mode using Bilinear scaling on 768p display-0
2024-04-25 11:05:19.113 | SDL: Failed to create window: Could not create EGL window surface
2024-04-25 11:05:19.113 | Could not create OpenGL window, switching back to surface
2024-04-25 11:05:19.116 | SDL: Failed to create window: Could not create EGL window surface
Stack trace:
7       0x55fea200768a dosbox(+0x3c68a) [0x55fea200768a]
6       0x7fdd695f524d __libc_start_main + 239
5       0x55fea2186457 dosbox(+0x1bb457) [0x55fea2186457]
4       0x55fea2028611 dosbox(+0x5d611) [0x55fea2028611]
3       0x55fea2028555 dosbox(+0x5d555) [0x55fea2028555]
2       0x55fea218aa74 dosbox(+0x1bfa74) [0x55fea218aa74]
1       0x55fea218a2eb dosbox(+0x1bf2eb) [0x55fea218a2eb]
0       0x55fea203798c dosbox(+0x6c98c) [0x55fea203798c]
2024-04-25 11:05:19.116 | ABORT: Could not initialize video: Could not create EGL window surface
********************************************
  PLEASE REBOOT SYSTEM NOW 
********************************************

Also tried dosbox and apparently that's the crashing command. Also tried dosemu but that program also vanishes as soon as I start AFUDOS.EXE even with -s for complete physical hardware access. I then extracted the BIOS zip archive to my USB thumb drive, started freedos from my multi-boot grub menu, renamed AFUDOS.SMC to AFUDOS.EXE, booted FreeDOS with the "+HIMEM" option and then

C:
afudos.exe H8DG63.B25 /P /B /N /C /R

which ended with "Program ended normally." After that the expected error about CMOS having invalid config, went into BIOS config utility, configured some additional minor stuff, e.g. ACPI 3.0 support. I saw that there is a possibility to configure the BMC network but only IPv4. Saved, exited, continued the boot. The system said that BMC is re-initialized and the system continued to boot.

The BIOS reports Supermicro H8DG6/i(-F), version 3.5, build date 2013-11-25

After boot I verified that I can ping the IPv6 address 2a07:de40:a102:5:225:90ff:feA2:B848 but ipmitool -6 -I lanplus -C 3 -H 2a07:de40:a102:5:225:90ff:feA2:B848 does not manage to connect properly.

ipmitool -vvvvv -6 -I lanplus -C 3 -H 2a07:de40:a102:5:225:90ff:feA2:B848 … shows connection attempts which look successful but then the IPMI commands are not correctly evaluated.

ipmitool version 1.8.18

Loading IANA PEN Registry...
Testing wlan0 interface address: 2a07:de40:8c00:20:2611:1633:1f4a:55a4 scope=0
Successful connected on wlan0 interface with scope id 0

>> Sending IPMI command payload
>>    netfn   : 0x06
>>    command : 0x38
>>    data    : 0x8e 0x04 

BUILDING A v1.5 COMMAND
added list entry seq=0x00 cmd=0x38
>> IPMI Request Session Header
>>   Authtype   : NONE
>>   Sequence   : 0x00000000
>>   Session ID : 0x00000000
>> IPMI Request Message Header
…

As https://gitlab.suse.de/OPS-Service/salt/-/merge_requests/5036 is merged and deployed I think there is not more we can do regarding IPMI. However now the problem is a bit severe because the Linux system does not see an ethernet adapter anymore.

https://www.supermicro.com/en/support/resources/downloadcenter/firmware/MBD-H8DG6-F/BIOS shows 3.5c

Actions #10

Updated by okurz about 2 months ago

  • Status changed from In Progress to Resolved

https://www.supermicro.com/en/support/resources/downloadcenter/firmware/MBD-H8DG6-F/BIOS shows 3.5c, could try that. First following a suggestion from nsinger and in BIOS loaded "Optimal defaults", left ACPI 2.0 default, also selected to clean NVRAM and continued boot into Leap. Now I saw an ethernet adapter showing up in boot dmesg output. And I could later ssh in just fine. But as I am already on it I will try the supermicro bios, back to FreeDOS and AFUDOS.EXE H8DG66.318 /P /B /N /C /R

Also successful, now newer version 3.5 from 2016 but no change in IPMI. So still resolving then as we have an IPv4-only IPMI but besides that everything works fine.

Actions #11

Updated by okurz 17 days ago

  • Copied to action #161756: IPMI access over IPv6 doesn't work on blackbauhinia size:S added
Actions

Also available in: Atom PDF