Project

General

Profile

Actions

action #123637

closed

microos-old2microosnext: old is 'too old' and does not know about the new 4k RSA key

Added by dimstar about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2023-01-25
Due date:
% Done:

100%

Estimated time:
Difficulty:
Tags:

Description

Observation

Tumbleweed was changed to a 4k RSA key (previously 2k RSA) for Snapshot 0123. The new public key has been deployed to end users for the last 5 months. Any machine that did not update in this time-frame will be presented with 'unknown key, do you want to trust it'

In this specific test though, we're using zypper -n (no questions asked), which makes this fail immediately.

We should provide an 'old image' that is slightly less old (or anticipate such issues better)

openQA test in scenario microos-Tumbleweed-MicroOS-Image-x86_64-microos-old2microosnext@64bit fails in
zypper_ref

Test suite description

Boot from existing, static MicroOS image and transactional-update dup to snapshot under test

Reproducible

Fails since (at least) Build 20230124

Expected result

Last good: 20230123 (or more recent)

Further details

Always latest result in this scenario: latest

Actions

Also available in: Atom PDF